aboutsummaryrefslogtreecommitdiff
path: root/misc/usbrh-libusb
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-27 12:52:17 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-27 12:52:17 +0000
commit6db69e9fe779ce0bdb130401495b58ddc83be89b (patch)
tree3bd656a95de3b34a64a7a62c3d2d33046ffdf99a /misc/usbrh-libusb
parent4b4e000712f10bd4a412a9ae6e225aee06f19b96 (diff)
downloadports-6db69e9fe779ce0bdb130401495b58ddc83be89b.tar.gz
ports-6db69e9fe779ce0bdb130401495b58ddc83be89b.zip
Notes
Diffstat (limited to 'misc/usbrh-libusb')
-rw-r--r--misc/usbrh-libusb/Makefile5
-rw-r--r--misc/usbrh-libusb/files/patch-Makefile6
-rw-r--r--misc/usbrh-libusb/files/patch-usbrh_main.c14
3 files changed, 14 insertions, 11 deletions
diff --git a/misc/usbrh-libusb/Makefile b/misc/usbrh-libusb/Makefile
index 7e55a6c4b924..f18b38c9f07a 100644
--- a/misc/usbrh-libusb/Makefile
+++ b/misc/usbrh-libusb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= usbrh-libusb
PORTVERSION= 0.05
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.dd.iij4u.or.jp/~briareos/soft/ \
LOCAL/sanpei
@@ -11,9 +12,11 @@ DISTNAME= usbrh-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another reads temperatures and humidity from a Strawberry Linux USB-RH
+LICENSE= GPLv2
+
PLIST_FILES= bin/usbrh
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/usbrh ${STAGEDIR}${PREFIX}/bin/usbrh
+ ${INSTALL_PROGRAM} ${WRKSRC}/usbrh ${STAGEDIR}${PREFIX}/bin/usbrh
.include <bsd.port.mk>
diff --git a/misc/usbrh-libusb/files/patch-Makefile b/misc/usbrh-libusb/files/patch-Makefile
index 72bdc441f6e3..c391bbbf122e 100644
--- a/misc/usbrh-libusb/files/patch-Makefile
+++ b/misc/usbrh-libusb/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig 2008-03-24 23:22:09.000000000 +0900
-+++ ./Makefile 2009-07-20 23:23:39.000000000 +0900
+--- Makefile.orig 2008-03-24 14:22:09 UTC
++++ Makefile
@@ -2,8 +2,9 @@
SRC = usbrh_main.c
EXE = usbrh
@@ -7,7 +7,7 @@
+all: $(EXE)
$(EXE): $(SRC)
- gcc -lusb -g -o $@ $^
-+ cc -lusb -g -o $@ $(SRC)
++ ${CC} ${CFLAGS} ${LDFLAGS} -lusb -o $@ $(SRC)
clean:
rm $(EXE)
diff --git a/misc/usbrh-libusb/files/patch-usbrh_main.c b/misc/usbrh-libusb/files/patch-usbrh_main.c
index c6c6a9ec77ea..71c223c35e7c 100644
--- a/misc/usbrh-libusb/files/patch-usbrh_main.c
+++ b/misc/usbrh-libusb/files/patch-usbrh_main.c
@@ -1,6 +1,6 @@
---- ./usbrh_main.c.orig 2008-03-24 23:23:26.000000000 +0900
-+++ ./usbrh_main.c 2009-07-20 23:22:59.000000000 +0900
-@@ -198,7 +198,7 @@
+--- usbrh_main.c.orig 2008-03-24 14:23:26 UTC
++++ usbrh_main.c
+@@ -198,7 +198,7 @@ int DeviceNum;
break;
default:
usage();
@@ -9,7 +9,7 @@
break;
}
}
-@@ -209,7 +209,7 @@
+@@ -209,7 +209,7 @@ int DeviceNum;
if(flag_l){
listdevice(USBRH_VENDOR, USBRH_PRODUCT);
@@ -18,7 +18,7 @@
}
if(flag_d)
-@@ -217,7 +217,7 @@
+@@ -217,7 +217,7 @@ int DeviceNum;
if((dev = searchdevice(USBRH_VENDOR, USBRH_PRODUCT, DeviceNum)) == (struct usb_device *)NULL){
puts("USBRH not found");
@@ -27,7 +27,7 @@
}
if(flag_d){
-@@ -226,26 +226,30 @@
+@@ -226,26 +226,30 @@ int DeviceNum;
dh = usb_open(dev);
if(dh == NULL){
puts("usb_open error");
@@ -61,7 +61,7 @@
}
}
}
-@@ -311,7 +315,7 @@
+@@ -311,7 +315,7 @@ int DeviceNum;
if((rc = usb_release_interface(dh, dev->config->interface->altsetting->bInterfaceNumber))<0){
puts("usb_release_interface error");
usb_close(dh);