aboutsummaryrefslogtreecommitdiff
path: root/misc/utouch-kmod
diff options
context:
space:
mode:
authorVladimir Kondratyev <wulf@FreeBSD.org>2019-09-09 20:37:45 +0000
committerVladimir Kondratyev <wulf@FreeBSD.org>2019-09-09 20:37:45 +0000
commitfe9c3eb5aa5c672cbafd8bcd4b31165f15639da5 (patch)
tree1fd4afe03ae7b1dd3993200af363d7f7eeea426b /misc/utouch-kmod
parent43a2d74d7b69f9fa00f589fa683adf41e43d21cd (diff)
downloadports-fe9c3eb5aa5c672cbafd8bcd4b31165f15639da5.tar.gz
ports-fe9c3eb5aa5c672cbafd8bcd4b31165f15639da5.zip
Notes
Diffstat (limited to 'misc/utouch-kmod')
-rw-r--r--misc/utouch-kmod/Makefile41
-rw-r--r--misc/utouch-kmod/distinfo3
-rw-r--r--misc/utouch-kmod/pkg-descr9
-rw-r--r--misc/utouch-kmod/pkg-message14
4 files changed, 67 insertions, 0 deletions
diff --git a/misc/utouch-kmod/Makefile b/misc/utouch-kmod/Makefile
new file mode 100644
index 000000000000..5287efce8562
--- /dev/null
+++ b/misc/utouch-kmod/Makefile
@@ -0,0 +1,41 @@
+# Created by: Vladimir Kondratyev <wulf@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= utouch-kmod
+PORTVERSION= 0.0.1
+CATEGORIES= misc
+
+MAINTAINER= wulf@FreeBSD.org
+COMMENT= Kernel driver for absolute USB HID mouses
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= kmod uidfix
+
+OPTIONS_DEFINE= SOURCE
+OPTIONS_DEFAULT=SOURCE
+SOURCE_DESC= Install kernel module sources
+
+USE_GITHUB= yes
+GH_ACCOUNT= wulf7
+GH_PROJECT= utouch
+
+PLIST_FILES= ${KMODDIR}/utouch.ko
+
+KMODSRC_DIR= sys/modules/${PORTNAME}
+KMODSRC_FILES= Makefile utouch.c
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSOURCE}
+PLIST_FILES+= ${KMODSRC_FILES:S|^|${KMODSRC_DIR}/|}
+.endif
+
+post-install-SOURCE-on:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${KMODSRC_DIR}
+.for file in ${KMODSRC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/${KMODSRC_DIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/misc/utouch-kmod/distinfo b/misc/utouch-kmod/distinfo
new file mode 100644
index 000000000000..ee80710c1e74
--- /dev/null
+++ b/misc/utouch-kmod/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1567539845
+SHA256 (wulf7-utouch-0.0.1_GH0.tar.gz) = cb173ac478d51af06f3c6cac86c4f4613c8f7f1cb5a23867aae745fa99bdb4ba
+SIZE (wulf7-utouch-0.0.1_GH0.tar.gz) = 5338
diff --git a/misc/utouch-kmod/pkg-descr b/misc/utouch-kmod/pkg-descr
new file mode 100644
index 000000000000..617beceb8754
--- /dev/null
+++ b/misc/utouch-kmod/pkg-descr
@@ -0,0 +1,9 @@
+utouch - Kernel driver for absolute USB HID mouses emulated by some
+virtualization systems like Virtual Box, BHyve, etc. It uses evdev
+protocol to communicate with userland applications like libinput and
+xf86-input-evdev.
+
+The driver should be installed in to the guest FreeBSD system. Host system
+should be configured to emulate mouse as a single-touch USB tablet.
+
+WWW: https://github.com/wulf7/utouch
diff --git a/misc/utouch-kmod/pkg-message b/misc/utouch-kmod/pkg-message
new file mode 100644
index 000000000000..d0c2e4d509f3
--- /dev/null
+++ b/misc/utouch-kmod/pkg-message
@@ -0,0 +1,14 @@
+[
+{ type: install
+ message: <<EOM
+To load installed driver in to the kernel type:
+"kldload /boot/modules/utouch.ko"
+
+It may be necessary to unload conflicting uhid(4) driver
+with "kldunload uhid" after utouch.ko has been loaded.
+
+To load driver automaticaly at the boot time add
+utouch_load="YES" string to /boot/loader.conf file.
+EOM
+}
+]