aboutsummaryrefslogtreecommitdiff
path: root/misc/valentina
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-20 22:07:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-20 22:07:05 +0000
commit2c82e08966bd3a259884c2cde531a2402c0b6736 (patch)
tree963a106a9d3922d8ecfafe1aa872822c906aeb60 /misc/valentina
parent6dd358c98a0ff6a2e4024a81f85a3ca1703234be (diff)
downloadports-2c82e08966bd3a259884c2cde531a2402c0b6736.tar.gz
ports-2c82e08966bd3a259884c2cde531a2402c0b6736.zip
misc/valentina: fix build with powerpc*
PR: 232485 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=482630
Diffstat (limited to 'misc/valentina')
-rw-r--r--misc/valentina/Makefile3
-rw-r--r--misc/valentina/files/patch-src_libs_vmisc_debugbreak.h16
2 files changed, 18 insertions, 1 deletions
diff --git a/misc/valentina/Makefile b/misc/valentina/Makefile
index a662d54343c8..dca948863858 100644
--- a/misc/valentina/Makefile
+++ b/misc/valentina/Makefile
@@ -13,7 +13,7 @@ COMMENT= Sewing pattern drafting tool aiming to remake the garment industry
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE_GPL.txt
-USES= desktop-file-utils gmake qmake qt:5
+USES= compiler:c++11-lang desktop-file-utils gl gmake qmake qt:5
USE_QT= concurrent core gui network opengl printsupport svg widgets xml xmlpatterns buildtools_build linguisttools_build testlib_build
USE_GL= gl
USE_LDCONFIG= yes
@@ -33,5 +33,6 @@ WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
post-patch:
@${REINPLACE_CMD} 's|DEFAULT_PREFIX = /usr|DEFAULT_PREFIX = ${PREFIX}|' ${WRKSRC}/common.pri
@${REINPLACE_CMD} 's|/usr/share|${PREFIX}/share|' ${WRKSRC}/src/app/valentina/valentina.pro ${WRKSRC}/src/app/tape/tape.pro
+ @${REINPLACE_CMD} 's|g++ -dumpversion|g++${GCC_DEFAULT} -dumpversion|' ${WRKSRC}/Valentina.pro
.include <bsd.port.mk>
diff --git a/misc/valentina/files/patch-src_libs_vmisc_debugbreak.h b/misc/valentina/files/patch-src_libs_vmisc_debugbreak.h
new file mode 100644
index 000000000000..42adbfe2bc30
--- /dev/null
+++ b/misc/valentina/files/patch-src_libs_vmisc_debugbreak.h
@@ -0,0 +1,16 @@
+--- src/libs/vmisc/debugbreak.h.orig 2018-10-20 17:36:33 UTC
++++ src/libs/vmisc/debugbreak.h
+@@ -100,6 +100,13 @@ __inline__ static void trap_instruction(void)
+ * 'aarch64_default_breakpoint' */
+ __asm__ volatile(".inst 0xd4200000");
+ }
++#elif defined(__powerpc__)
++enum { HAVE_TRAP_INSTRUCTION = 1 };
++__attribute__((gnu_inline, always_inline))
++__inline__ static void trap_instruction(void)
++{
++ __asm__ volatile(".4byte 0x7d821008");
++}
+ #else
+ enum { HAVE_TRAP_INSTRUCTION = 0 };
+ #endif