aboutsummaryrefslogtreecommitdiff
path: root/misc/wmforecast/Makefile
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-01-19 19:01:06 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-01-19 19:01:06 +0000
commit158a0d34046945a6108f05adf3ec8c17f4ed8e43 (patch)
treef1365cb86243c65e1a6239cc3145c9d9964d4693 /misc/wmforecast/Makefile
parent1421789736b8bdcd48b1e140fd2357971438d1be (diff)
downloadports-158a0d34046945a6108f05adf3ec8c17f4ed8e43.tar.gz
ports-158a0d34046945a6108f05adf3ec8c17f4ed8e43.zip
Notes
Diffstat (limited to 'misc/wmforecast/Makefile')
-rw-r--r--misc/wmforecast/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/misc/wmforecast/Makefile b/misc/wmforecast/Makefile
new file mode 100644
index 000000000000..4aa0aec3af29
--- /dev/null
+++ b/misc/wmforecast/Makefile
@@ -0,0 +1,34 @@
+# Created by: Igor Pokrovsky <ip@unixway.org>
+# $FreeBSD$
+
+PORTNAME= wmforecast
+DISTVERSION= 1.4
+CATEGORIES= misc windowmaker geography
+MASTER_SITES= https://github.com/d-torrance/${PORTNAME}/releases/download/v${DISTVERSION}/
+
+MAINTAINER= ip@unixway.org
+COMMENT= Weather dockapp for Window Maker using the Yahoo Weather API
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libgweather-3.so:net/libgweather \
+ libWINGs.so:x11-wm/windowmaker \
+ libwraster.so:x11-wm/libwraster
+
+USES= gmake gettext-runtime gnome pkgconfig xorg
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 pango
+INSTALLS_ICONS= yes
+USE_XORG= x11
+
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= GEOCLUE NLS
+
+GEOCLUE_DESC= Use GeoClue
+
+GEOCLUE_LIB_DEPENDS= libgeoclue-2.so:net/geoclue
+GEOCLUE_CONFIGURE_WITH= geoclue
+NLS_USES= gettext
+
+.include <bsd.port.mk>