aboutsummaryrefslogtreecommitdiff
path: root/misc/wmjulia/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-09-23 12:10:46 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-09-23 12:10:46 +0000
commit862a3a90225614bcedf5862d01ad143e889b91f3 (patch)
tree98e67ee9664c6c555853aeccb965cb9e735b8c04 /misc/wmjulia/Makefile
parent5b7a14fcb9ba2bee1adb4c3337696ffc4b7cac7b (diff)
downloadports-862a3a90225614bcedf5862d01ad143e889b91f3.tar.gz
ports-862a3a90225614bcedf5862d01ad143e889b91f3.zip
Notes
Diffstat (limited to 'misc/wmjulia/Makefile')
-rw-r--r--misc/wmjulia/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/misc/wmjulia/Makefile b/misc/wmjulia/Makefile
index 0cc4a48fb91a..1ce65b5b4401 100644
--- a/misc/wmjulia/Makefile
+++ b/misc/wmjulia/Makefile
@@ -12,12 +12,15 @@ COMMENT= Dockapp that creates an animated Julia set
LICENSE= GPLv2
-PLIST_FILES= bin/wmjulia
-WRKSRC= ${WRKDIR}/${PORTNAME}.app/${PORTNAME}
USES= gmake xorg
-USE_XORG= xpm xext
+USE_XORG= x11 xext xpm
+
+WRKSRC= ${WRKDIR}/${PORTNAME}.app
+PLIST_FILES= bin/wmjulia
+
+MAKE_ARGS= -C ${PORTNAME}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>