aboutsummaryrefslogtreecommitdiff
path: root/misc/wmweather+
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-23 09:23:15 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-23 09:23:15 +0000
commit63d85f6036a4b4a1a3aada92c9e9648bf350c6b8 (patch)
tree085943c75c3056c6ad31ba7ac810058e2462149e /misc/wmweather+
parentc6f4080368403707c7d2211c4ee91877b5e2fc96 (diff)
downloadports-63d85f6036a4b4a1a3aada92c9e9648bf350c6b8.tar.gz
ports-63d85f6036a4b4a1a3aada92c9e9648bf350c6b8.zip
Convert to new options framework
Feature safe: yes
Notes
Notes: svn path=/head/; revision=306302
Diffstat (limited to 'misc/wmweather+')
-rw-r--r--misc/wmweather+/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/misc/wmweather+/Makefile b/misc/wmweather+/Makefile
index 1ad3d830614e..7ea08a47651a 100644
--- a/misc/wmweather+/Makefile
+++ b/misc/wmweather+/Makefile
@@ -1,5 +1,4 @@
# Created by: Harald Wille <harald.wille@students.jku.at>
-#
# $FreeBSD$
PORTNAME= wmweather+
@@ -30,17 +29,19 @@ CONFIGURE_ARGS+= --with-libwraster=${LOCALBASE} \
--with-xpm-includes=${LOCALBASE} \
--with-xpm-libraries=${LOCALBASE}
-OPTIONS= WM "Depend on Window Maker port (otherwise only libwraster)" on
+OPTIONS_DEFINE= WM EXAMPLES
+OPTIONS_DEFAULT= WM
+WM_DESC= Depend on Window Maker port (otherwise only libwraster)
MAN1= wmweather+.1
PLIST_FILES= bin/wmweather+
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CFLAGS:= ${CFLAGS:C/-O[0-9]/-O0/}
-.if !defined(WITHOUT_WM)
+.if ${PORT_OPTIONS:MWM}
LIB_DEPENDS+= wraster:${PORTSDIR}/x11-wm/windowmaker
.else
LIB_DEPENDS+= wraster:${PORTSDIR}/x11-wm/libwraster
@@ -56,7 +57,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmweather+ ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/wmweather+.1 ${PREFIX}/man/man1
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/HINTS ${EXAMPLESDIR}/HINTS
${INSTALL_DATA} ${WRKSRC}/example.conf ${EXAMPLESDIR}/example.conf
@@ -68,7 +69,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.endif
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${ECHO} "===================================================" > ${PM}
@${ECHO} "A sample configuration file has been copied to" >> ${PM}
@${ECHO} "${EXAMPLESDIR}/example.conf" >> ${PM}
@@ -79,4 +80,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>