aboutsummaryrefslogtreecommitdiff
path: root/misc/xbiso/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-11 07:56:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-11 07:56:20 +0000
commit54da1ac1b2929512285d0b792eb72d59130ac37e (patch)
tree24d9265ce7fcd0e5c440b51e7c19254d1764027e /misc/xbiso/Makefile
parentc52e18b93095e8fa2121f80626cb5b1e4a53abd4 (diff)
downloadports-54da1ac1b2929512285d0b792eb72d59130ac37e.tar.gz
ports-54da1ac1b2929512285d0b792eb72d59130ac37e.zip
Notes
Diffstat (limited to 'misc/xbiso/Makefile')
-rw-r--r--misc/xbiso/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/misc/xbiso/Makefile b/misc/xbiso/Makefile
new file mode 100644
index 000000000000..03bdfb817acf
--- /dev/null
+++ b/misc/xbiso/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: xbiso
+# Date created: Jan 28, 2004
+# Whom: ijliao ij
+#
+# $FreeBSD$
+#
+
+PORTNAME= xbiso
+PORTVERSION= 0.6.0
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= XBox xdvdfs iso extraction utility
+
+LIB_DEPENDS= ftp.3:${PORTSDIR}/ftp/ftplib
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ENV= LIBS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/xbiso
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,^LIBS =,LIBS+=," ${WRKSRC}/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xbiso ${PREFIX}/bin
+
+.include <bsd.port.mk>