aboutsummaryrefslogtreecommitdiff
path: root/misc/xfce4-appfinder/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-03-05 22:52:30 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-03-05 22:52:30 +0000
commit86e4cb7cb047c17951de23b2ebea9c14d0f76af2 (patch)
tree0f1a4d58acfbb6944387e341f218a018154dc4ad /misc/xfce4-appfinder/Makefile
parent507a1eba6aabfd52efceabca5986a46398cfa02f (diff)
downloadports-86e4cb7cb047c17951de23b2ebea9c14d0f76af2.tar.gz
ports-86e4cb7cb047c17951de23b2ebea9c14d0f76af2.zip
Notes
Diffstat (limited to 'misc/xfce4-appfinder/Makefile')
-rw-r--r--misc/xfce4-appfinder/Makefile32
1 files changed, 15 insertions, 17 deletions
diff --git a/misc/xfce4-appfinder/Makefile b/misc/xfce4-appfinder/Makefile
index 1165d10c0435..35980cbafa5a 100644
--- a/misc/xfce4-appfinder/Makefile
+++ b/misc/xfce4-appfinder/Makefile
@@ -2,35 +2,33 @@
# $FreeBSD$
PORTNAME= xfce4-appfinder
-PORTVERSION= 4.10.1
-PORTREVISION= 1
+PORTVERSION= 4.12.0
CATEGORIES= misc xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR= src/xfce/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Application launcher and finder
+LICENSE= GPLv2
+
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
GNU_CONFIGURE= yes
-USES= gmake pathfix pkgconfig tar:bzip2
-USE_GNOME= gtk20 glib20 intltool intlhack
-USE_XFCE= configenv garcon libmenu libutil xfconf
-
-OPTIONS_DEFINE= NLS
+USES= gmake pkgconfig gettext-tools tar:bzip2
+USE_GNOME= glib20 intltool intlhack
+USE_XFCE= garcon
+
+OPTIONS_DEFINE= GTK3 NLS
+GTK3_USES= xfce:gtk3
+GTK3_USE= gnome=gtk30
+GTK3_CONFIGURE_ENABLE= gtk3
+GTK3_USES_OFF= xfce
+GTK3_USE_OFF= gnome=gtk20
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-.else
-CONFIGURE_ARGS+=--disable-nls
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's|=gtk-find|=system-search|' \
${WRKSRC}/data/xfce4-appfinder.desktop.in