aboutsummaryrefslogtreecommitdiff
path: root/misc/xfce4-weather-plugin
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2017-10-11 07:21:42 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2017-10-11 07:21:42 +0000
commit0c38eb603ed8e7dfb6d51059e59b5e067295a10d (patch)
tree375551eb04583e28012219c07adbef30871faa13 /misc/xfce4-weather-plugin
parent51ab38e87c3cebb2766fbce1d0a5f777dfcb7d14 (diff)
downloadports-0c38eb603ed8e7dfb6d51059e59b5e067295a10d.tar.gz
ports-0c38eb603ed8e7dfb6d51059e59b5e067295a10d.zip
Import xfce4-weather-plugin upstream patch required to make location
search work after external site added additional requirement. PR: 222909 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com> Obtained from: https://git.xfce.org/panel-plugins/xfce4-weather-plugin/commit/?id=7c976663e8790e5b06ca31a4a3165b11aeb89f11 MFH: 2017Q4
Notes
Notes: svn path=/head/; revision=451735
Diffstat (limited to 'misc/xfce4-weather-plugin')
-rw-r--r--misc/xfce4-weather-plugin/Makefile8
-rw-r--r--misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c11
2 files changed, 16 insertions, 3 deletions
diff --git a/misc/xfce4-weather-plugin/Makefile b/misc/xfce4-weather-plugin/Makefile
index fa5d9859e672..130af82a4163 100644
--- a/misc/xfce4-weather-plugin/Makefile
+++ b/misc/xfce4-weather-plugin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-weather-plugin
PORTVERSION= 0.8.9
+PORTREVISION= 1
CATEGORIES= misc xfce geography
MASTER_SITES= XFCE/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -17,12 +18,13 @@ LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
-INSTALL_TARGET= install-strip
USES= gettext gmake libtool pkgconfig xfce tar:bzip2
+GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk20 intltool intlhack libxml2 cairo
USE_XFCE= panel
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= UPOWER
UPOWER_DESC= Power management tasks
diff --git a/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c
new file mode 100644
index 000000000000..4a191a69f063
--- /dev/null
+++ b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c
@@ -0,0 +1,11 @@
+--- panel-plugin/weather.c.orig 2017-02-16 18:59:12 UTC
++++ panel-plugin/weather.c
+@@ -1849,6 +1849,8 @@ xfceweather_create_control(XfcePanelPlugin *plugin)
+
+ /* Setup session for HTTP connections */
+ data->session = soup_session_async_new();
++ g_object_set(data->session, SOUP_SESSION_USER_AGENT,
++ PACKAGE_NAME "-" PACKAGE_VERSION, NULL);
+ g_object_set(data->session, SOUP_SESSION_TIMEOUT,
+ CONN_TIMEOUT, NULL);
+