aboutsummaryrefslogtreecommitdiff
path: root/misc/xfce4-weather-plugin
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2020-07-03 22:06:52 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2020-07-03 22:06:52 +0000
commit5d30841c2827f2f5f361901bd5cb67beb4983a39 (patch)
treea8627be54095598094acc1a6473c9b46d6728add /misc/xfce4-weather-plugin
parent123b995b418f5358bfac5148b7e5e7291c10f717 (diff)
downloadports-5d30841c2827f2f5f361901bd5cb67beb4983a39.tar.gz
ports-5d30841c2827f2f5f361901bd5cb67beb4983a39.zip
Switch to the 2.0 API for locationforecast.
PR: 247644 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com>
Notes
Notes: svn path=/head/; revision=541151
Diffstat (limited to 'misc/xfce4-weather-plugin')
-rw-r--r--misc/xfce4-weather-plugin/Makefile1
-rw-r--r--misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c11
-rw-r--r--misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.h11
3 files changed, 23 insertions, 0 deletions
diff --git a/misc/xfce4-weather-plugin/Makefile b/misc/xfce4-weather-plugin/Makefile
index 18a570b5376d..56d3fbf5b07c 100644
--- a/misc/xfce4-weather-plugin/Makefile
+++ b/misc/xfce4-weather-plugin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-weather-plugin
PORTVERSION= 0.10.1
+PORTREVISION= 1
CATEGORIES= misc xfce geography
MASTER_SITES= XFCE/panel-plugins
DIST_SUBDIR= xfce4
diff --git a/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c
new file mode 100644
index 000000000000..21fca9ad5523
--- /dev/null
+++ b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c
@@ -0,0 +1,11 @@
+--- panel-plugin/weather.c.orig 2020-02-23 00:39:53 UTC
++++ panel-plugin/weather.c
+@@ -656,7 +656,7 @@ update_handler(plugin_data *data)
+ /* build url */
+ url = g_strdup_printf("https://api.met.no"
+ "/weatherapi/locationforecast/%s/"
+- "?lat=%s&lon=%s&msl=%d",
++ "classic?lat=%s&lon=%s&altitude=%d",
+ api_version,
+ data->lat, data->lon, data->msl);
+
diff --git a/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.h b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.h
new file mode 100644
index 000000000000..8cc1676f8873
--- /dev/null
+++ b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.h
@@ -0,0 +1,11 @@
+--- panel-plugin/weather.h.orig 2020-02-23 00:39:53 UTC
++++ panel-plugin/weather.h
+@@ -31,7 +31,7 @@
+ #define MAX_FORECAST_DAYS 10
+ #define DEFAULT_FORECAST_DAYS 5
+ #define MAX_SCROLLBOX_LINES 10
+-#define FORECAST_API "1.9"
++#define FORECAST_API "2.0"
+
+ G_BEGIN_DECLS
+