aboutsummaryrefslogtreecommitdiff
path: root/misc/xplr/Makefile
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2021-12-26 20:06:53 +0000
committerLewis Cook <lcook@FreeBSD.org>2021-12-26 20:07:59 +0000
commitfd31c9c7ce190d8b85134850871fde2d18e6623a (patch)
treec9d959a2fe6e3f909952313b4193ae847ce5e9fe /misc/xplr/Makefile
parentd32527ecf7e8356b40a57398c21cad129a018c7b (diff)
downloadports-fd31c9c7ce190d8b85134850871fde2d18e6623a.tar.gz
ports-fd31c9c7ce190d8b85134850871fde2d18e6623a.zip
Diffstat (limited to 'misc/xplr/Makefile')
-rw-r--r--misc/xplr/Makefile75
1 files changed, 38 insertions, 37 deletions
diff --git a/misc/xplr/Makefile b/misc/xplr/Makefile
index c73b618d8127..b832b3ab07d7 100644
--- a/misc/xplr/Makefile
+++ b/misc/xplr/Makefile
@@ -1,7 +1,6 @@
PORTNAME= xplr
DISTVERSIONPREFIX= v
-DISTVERSION= 0.15.2
-PORTREVISION= 1
+DISTVERSION= 0.17.0
CATEGORIES= misc
MAINTAINER= lcook@FreeBSD.org
@@ -15,19 +14,19 @@ USE_GITHUB= yes
GH_ACCOUNT= sayanarijit
CARGO_CRATES= ansi-to-tui-0.4.1 \
- anyhow-1.0.44 \
+ anyhow-1.0.51 \
assert_cmd-2.0.2 \
atty-0.2.14 \
autocfg-1.0.1 \
bitflags-1.3.2 \
- bstr-0.2.16 \
- bumpalo-3.7.0 \
+ bstr-0.2.17 \
+ bumpalo-3.8.0 \
cassowary-0.3.0 \
cast-0.2.7 \
- cc-1.0.70 \
+ cc-1.0.72 \
cfg-if-1.0.0 \
chrono-0.4.19 \
- clap-2.33.3 \
+ clap-2.34.0 \
criterion-0.3.5 \
criterion-plot-0.4.4 \
crossbeam-channel-0.5.1 \
@@ -48,29 +47,29 @@ CARGO_CRATES= ansi-to-tui-0.4.1 \
either-1.6.1 \
erased-serde-0.3.16 \
getrandom-0.2.3 \
- half-1.7.1 \
+ half-1.8.2 \
hashbrown-0.11.2 \
hermit-abi-0.1.19 \
humansize-1.1.1 \
indexmap-1.7.0 \
- instant-0.1.10 \
- itertools-0.10.1 \
+ instant-0.1.12 \
+ itertools-0.10.3 \
itoa-0.4.8 \
- js-sys-0.3.53 \
+ js-sys-0.3.55 \
lazy_static-1.4.0 \
- libc-0.2.105 \
+ libc-0.2.109 \
linked-hash-map-0.5.4 \
lock_api-0.4.5 \
log-0.4.14 \
- lua-src-543.0.0 \
- luajit-src-210.2.0+resty5f13855 \
+ lua-src-543.1.0 \
+ luajit-src-210.3.2+resty1085a4d \
memchr-2.4.1 \
- memoffset-0.6.4 \
+ memoffset-0.6.5 \
mime-0.3.16 \
mime_guess-2.0.3 \
- mio-0.7.13 \
+ mio-0.7.14 \
miow-0.3.7 \
- mlua-0.6.6 \
+ mlua-0.7.0 \
natord-1.0.9 \
ntapi-0.3.6 \
num-integer-0.1.44 \
@@ -80,15 +79,15 @@ CARGO_CRATES= ansi-to-tui-0.4.1 \
oorandom-11.1.3 \
parking_lot-0.11.2 \
parking_lot_core-0.8.5 \
- pkg-config-0.3.19 \
+ pkg-config-0.3.24 \
plotters-0.3.1 \
plotters-backend-0.3.2 \
plotters-svg-0.3.1 \
- predicates-2.0.2 \
+ predicates-2.1.0 \
predicates-core-1.0.2 \
- predicates-tree-1.0.3 \
- proc-macro2-1.0.29 \
- quote-1.0.9 \
+ predicates-tree-1.0.4 \
+ proc-macro2-1.0.33 \
+ quote-1.0.10 \
rayon-1.5.1 \
rayon-core-1.9.1 \
redox_syscall-0.2.10 \
@@ -96,40 +95,42 @@ CARGO_CRATES= ansi-to-tui-0.4.1 \
regex-1.5.4 \
regex-automata-0.1.10 \
regex-syntax-0.6.25 \
+ rustc-hash-1.1.0 \
rustc_version-0.4.0 \
- ryu-1.0.5 \
+ ryu-1.0.7 \
same-file-1.0.6 \
scopeguard-1.1.0 \
semver-1.0.4 \
- serde-1.0.130 \
+ serde-1.0.131 \
serde_cbor-0.11.2 \
- serde_derive-1.0.130 \
- serde_json-1.0.67 \
+ serde_derive-1.0.131 \
+ serde_json-1.0.72 \
serde_yaml-0.8.21 \
- signal-hook-0.3.10 \
+ signal-hook-0.3.12 \
signal-hook-mio-0.2.1 \
signal-hook-registry-1.4.0 \
- smallvec-1.6.1 \
- syn-1.0.75 \
+ smallvec-1.7.0 \
+ syn-1.0.82 \
+ termtree-0.2.3 \
textwrap-0.11.0 \
time-0.1.44 \
tinytemplate-1.2.1 \
- treeline-0.1.0 \
tui-0.16.0 \
+ tui-input-0.1.2 \
unicase-2.6.0 \
unicode-segmentation-1.8.0 \
- unicode-width-0.1.8 \
+ unicode-width-0.1.9 \
unicode-xid-0.2.2 \
version_check-0.9.3 \
wait-timeout-0.2.0 \
walkdir-2.3.2 \
wasi-0.10.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.76 \
- wasm-bindgen-backend-0.2.76 \
- wasm-bindgen-macro-0.2.76 \
- wasm-bindgen-macro-support-0.2.76 \
- wasm-bindgen-shared-0.2.76 \
- web-sys-0.3.53 \
+ wasm-bindgen-0.2.78 \
+ wasm-bindgen-backend-0.2.78 \
+ wasm-bindgen-macro-0.2.78 \
+ wasm-bindgen-macro-support-0.2.78 \
+ wasm-bindgen-shared-0.2.78 \
+ web-sys-0.3.55 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-util-0.1.5 \