aboutsummaryrefslogtreecommitdiff
path: root/misc/xyzcmd/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-01-20 05:37:27 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-01-20 05:37:27 +0000
commit2beda26d2307ca197641483ecfad6c0ae3a1d712 (patch)
tree8ef58f96a5d9f4523f89816ebf6fb9233ac4e32b /misc/xyzcmd/Makefile
parent900df766a54762e728221fd7ca253b6368c30c94 (diff)
downloadports-2beda26d2307ca197641483ecfad6c0ae3a1d712.tar.gz
ports-2beda26d2307ca197641483ecfad6c0ae3a1d712.zip
Notes
Diffstat (limited to 'misc/xyzcmd/Makefile')
-rw-r--r--misc/xyzcmd/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/misc/xyzcmd/Makefile b/misc/xyzcmd/Makefile
new file mode 100644
index 000000000000..f834c90339b6
--- /dev/null
+++ b/misc/xyzcmd/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: xyzcmd
+# Date created: 2010-01-18
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xyzcmd
+PORTVERSION= 0.0.3
+CATEGORIES= misc
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Pure console visual file manager
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/urwid/raw_display.py:${PORTSDIR}/devel/py-urwid
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/urwid/raw_display.py:${PORTSDIR}/devel/py-urwid
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+INSTALLS_EGGINFO=yes
+
+.include <bsd.port.mk>