aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-06-09 16:50:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-06-09 16:50:22 +0000
commit01efb90dab8c4b72de4e683b6fee7eabe39aa2d9 (patch)
treebab0202ca72ff44990788397dd6c7e5164fd8981 /misc
parentbb48f860f119116483e86cb9f5d87364e8abbf15 (diff)
downloadports-01efb90dab8c4b72de4e683b6fee7eabe39aa2d9.tar.gz
ports-01efb90dab8c4b72de4e683b6fee7eabe39aa2d9.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/linm/Makefile58
-rw-r--r--misc/linm/distinfo4
-rw-r--r--misc/linm/files/patch-Makefile.in27
-rw-r--r--misc/linm/files/patch-configure28
-rw-r--r--misc/linm/pkg-plist21
5 files changed, 70 insertions, 68 deletions
diff --git a/misc/linm/Makefile b/misc/linm/Makefile
index f7d8f71a0d3e..4f8f0525521f 100644
--- a/misc/linm/Makefile
+++ b/misc/linm/Makefile
@@ -2,49 +2,53 @@
# $FreeBSD$
PORTNAME= linm
-PORTVERSION= ${LINM_VER}.1
-PORTREVISION= 3
+DISTVERSION= 0.8.1-1
CATEGORIES= misc shells
-MASTER_SITES= http://kldp.net/frs/download.php/3152/ \
- ftp://ftp.kr.freebsd.org/pub/kldp.net/download/mls/1.LinMStable/LinM${LINM_VER}/
-DISTNAME= linm_${LINM_VER}-1
+MASTER_SITES= http://kldp.net/frs/download.php/4508/
+DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Clone of Mdir, mc-style terminal file manager
-USES= pkgconfig iconv
-USE_AUTOTOOLS= libtool
+LICENSE= GPLv2 # (or later)
+
+OPTIONS_DEFINE= SMB
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/-.*//}
+
+USES= gettext pkgconfig
USE_OPENSSL= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+CONFIGURE_ARGS= --enable-cfgpath="${ETCDIR}"
+MAKE_JOBS_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-# does not work now
-#.if defined(WITHOUT_NLS)
-#CONFIGURE_ARGS+=--disable-nls
-#PLIST_SUB+= NLS="@comment "
-#.else
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl -liconv"
-USES+= gettext
-PLIST_SUB+= NLS=""
-#.endif
-
-CONFIGURE_ARGS+= --enable-cfgpath="${PREFIX}/etc/linm" --enable-kolocalepath="${PREFIX}/share/locale/ko/LC_MESSAGES"
-
-LINM_VER= 0.7.7
-WRKSRC= ${WRKDIR}/linm-${LINM_VER}
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MSMB}
+LIB_DEPENDS+= smbclient:${PORTSDIR}/net/samba-libsmbclient
+PLIST_SUB+= SMB=""
+.else
+CONFIGURE_ENV+= ac_cv_lib_smbclient_smbc_new_context=no
+PLIST_SUB+= SMB="@comment "
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's|Panel::SetCur|SetCur|' ${WRKSRC}/panel/common/panel.h
- @${REINPLACE_CMD} -e 's|Position::Show|Show|' ${WRKSRC}/src/ncurses/dialog.h
+ @${REINPLACE_CMD} -e \
+ 's|configpath|cfgpath|g ; \
+ /LIBS=/s|-lpthread|-pthread|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/^AM_CFLAGS/s|=.*|= -fPIC -std=gnu89|' \
+ ${WRKSRC}/panel/vfs/libssh2/Makefile.in
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${PREFIX}/share/doc/linm
-.for file in AUTHORS COPYING ChangeLog README README.ko_euckr README.ko_utf8
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+.for i in AUTHORS ChangeLog README README.ko_euckr README.ko_utf8
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
.endfor
.endif
diff --git a/misc/linm/distinfo b/misc/linm/distinfo
index 9d0dc086b752..260ca94811a9 100644
--- a/misc/linm/distinfo
+++ b/misc/linm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (linm_0.7.7-1.tar.gz) = e09e8aca1f31dbd2d191de90214c569e248a791c4341296756ed2eeb6657e656
-SIZE (linm_0.7.7-1.tar.gz) = 670100
+SHA256 (linm_0.8.1-1.tar.gz) = 18f7a99059e3d741f6300078a946ecb55a6bc7014b12c0178819434e38892d97
+SIZE (linm_0.8.1-1.tar.gz) = 947761
diff --git a/misc/linm/files/patch-Makefile.in b/misc/linm/files/patch-Makefile.in
index 6d8dae1e3fd2..707a13b1266b 100644
--- a/misc/linm/files/patch-Makefile.in
+++ b/misc/linm/files/patch-Makefile.in
@@ -1,6 +1,26 @@
--- Makefile.in.orig Tue Jan 31 01:14:27 2006
+++ Makefile.in Thu Feb 16 15:16:59 2006
-@@ -673,15 +673,7 @@
+@@ -239,7 +239,7 @@
+ # have all needed files, that a GNU package needs
+ AUTOMAKE_OPTIONS = foreign 1.4
+ ACLOCAL_AMFLAGS = -I m4
+-SUBDIRS = intl po lib panel editor src sh
++SUBDIRS = po lib panel editor src sh
+ noinst_DATA = README.ko_euckr README.ko_utf8 linm.spec debian/*
+ EXTRA_DIST = config.rpath m4/ChangeLog $(noinst_DATA)
+ all: config.h
+@@ -695,6 +695,10 @@
+
+
+ install-exec-hook :
++ if ! test -d $(DESTDIR)$(sysconfdir)/profile.d ; then \
++ install -d -m 755 $(DESTDIR)$(sysconfdir)/profile.d \
++ ; fi
++
+ if test -d $(DESTDIR)$(sysconfdir)/profile.d ; then \
+ if test -w $(DESTDIR)$(sysconfdir)/profile.d ; then \
+ install -c -m 755 $(top_srcdir)/sh/linm_alias.sh $(DESTDIR)$(sysconfdir)/profile.d \
+@@ -710,14 +714,6 @@
$(top_srcdir)/sh/colorset.cfg \
$(top_srcdir)/sh/keyset.cfg \
$(DESTDIR)$(LINM_CFGPATH) \
@@ -12,7 +32,6 @@
- $(top_srcdir)/sh/colorset.cfg \
- $(top_srcdir)/sh/keyset.cfg \
- ~/.linm \
- ; fi
+ ; fi
- if ! test -d $(DESTDIR)$(KO_LOCALE_FILEPATH) ; then \
- install -d -m 755 $(DESTDIR)$(KO_LOCALE_FILEPATH) \
+ if ! test -d $(DESTDIR)$(datadir)/pixmaps ; then \
diff --git a/misc/linm/files/patch-configure b/misc/linm/files/patch-configure
deleted file mode 100644
index 8b55f812c518..000000000000
--- a/misc/linm/files/patch-configure
+++ /dev/null
@@ -1,28 +0,0 @@
---- configure.orig Thu Feb 16 15:55:08 2006
-+++ configure Thu Feb 16 15:56:04 2006
-@@ -29097,9 +29097,9 @@
- fi
-
-
--# Check whether --enable-configpath or --disable-configpath was given.
--if test "${enable_configpath+set}" = set; then
-- enableval="$enable_configpath"
-+# Check whether --enable-cfgpath or --disable-cfgpath was given.
-+if test "${enable_cfgpath+set}" = set; then
-+ enableval="$enable_cfgpath"
- enable_cfgpath=${enableval}
- else
- enable_cfgpath=default
-@@ -29125,9 +29125,9 @@
-
-
-
--# Check whether --enable-configpath or --disable-configpath was given.
--if test "${enable_configpath+set}" = set; then
-- enableval="$enable_configpath"
-+# Check whether --enable-kolocalepath or --disable-kolocalepath was given.
-+if test "${enable_kolocalepath+set}" = set; then
-+ enableval="$enable_kolocalepath"
- enable_kolocalepath=${enableval}
- else
- enable_kolocalepath=default
diff --git a/misc/linm/pkg-plist b/misc/linm/pkg-plist
index 15fb92901f25..53a7bc4c858b 100644
--- a/misc/linm/pkg-plist
+++ b/misc/linm/pkg-plist
@@ -2,10 +2,10 @@
bin/linm
bin/linm.csh
bin/linm.sh
-etc/linm/colorset.cfg
-etc/linm/default.cfg
-etc/linm/keyset.cfg
-@dirrm etc/linm
+%%ETCDIR%%/colorset.cfg
+%%ETCDIR%%/default.cfg
+%%ETCDIR%%/keyset.cfg
+etc/profile.d/linm_alias.sh
lib/liblinmpluginarc.a
lib/liblinmpluginarc.la
lib/liblinmpluginarc.so
@@ -18,12 +18,19 @@ lib/liblinmpluginsftp.a
lib/liblinmpluginsftp.la
lib/liblinmpluginsftp.so
lib/liblinmpluginsftp.so.0
+%%SMB%%lib/liblinmpluginsmb.a
+%%SMB%%lib/liblinmpluginsmb.la
+%%SMB%%lib/liblinmpluginsmb.so
+%%SMB%%lib/liblinmpluginsmb.so.0
+share/applications/LinM.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.ko_euckr
%%PORTDOCS%%%%DOCSDIR%%/README.ko_utf8
+share/locale/ko/LC_MESSAGES/linm.mo
+share/pixmaps/linm.xpm
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%NLS%%share/locale/ko/LC_MESSAGES/linm_euckr.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/linm_utf8.mo
+@dirrmtry share/applications
+@dirrmtry etc/profile.d
+@dirrm %%ETCDIR%%