aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-13 23:39:20 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-13 23:39:20 +0000
commit040d7bde757ab61572e6abb68ed7466b9509a4e3 (patch)
treef0fd9149eeb85490bc2fbbd3de220207733d8cb2 /misc
parent2fdb4f61f644490f7c4cbcb43453af33a860b82a (diff)
downloadports-040d7bde757ab61572e6abb68ed7466b9509a4e3.tar.gz
ports-040d7bde757ab61572e6abb68ed7466b9509a4e3.zip
misc/orange3: Update 3.19.0 -> 3.28.0
PR: 252540
Notes
Notes: svn path=/head/; revision=568297
Diffstat (limited to 'misc')
-rw-r--r--misc/orange3/Makefile30
-rw-r--r--misc/orange3/distinfo6
-rw-r--r--misc/orange3/files/patch-requirements-core.txt8
-rw-r--r--misc/orange3/files/patch-requirements-gui.txt13
4 files changed, 44 insertions, 13 deletions
diff --git a/misc/orange3/Makefile b/misc/orange3/Makefile
index 3f95943d96ab..bd71b75b36ae 100644
--- a/misc/orange3/Makefile
+++ b/misc/orange3/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= orange3
-DISTVERSION= 3.19.0
-PORTREVISION= 5
+DISTVERSION= 3.28.0
CATEGORIES= misc python
MAINTAINER= yuri@FreeBSD.org
@@ -10,35 +9,46 @@ COMMENT= Component-based data mining software
LICENSE= GPLv3
+BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}AnyQt>=0.0.8:x11-toolkits/py-AnyQt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}baycomp>=1.0.2:math/py-baycomp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bottleneck>=1.0.0:math/py-bottleneck@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}chardet>=3.0.2:textproc/py-chardet@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}docutils>0:textproc/py-docutils@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}fastTSNE>=0.2.12:biology/py-fastTSNE@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}joblib>=0.9.4:devel/py-joblib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httpx>=0.14.0:www/py-httpx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}keyring>0:security/py-keyring@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}keyrings.alt>0:security/py-keyrings.alt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=2.0.0:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}networkx>0:math/py-networkx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openTSNE>=0.4.3:math/py-openTSNE@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}orange-canvas-core>=0.1.19:devel/py-orange-canvas-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}orange-widget-base>=4.12.0:devel/py-orange-widget-base@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openpyxl>0:textproc/py-openpyxl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=1.0.0:math/py-pandas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}python-louvain>0:math/py-python-louvain@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyqtgraph>=0.10.0:graphics/py-pyqtgraph@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-louvain>=0.13:math/py-python-louvain@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyqtgraph>=0.11.0:graphics/py-pyqtgraph@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.20.0:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.22.0:science/py-scikit-learn@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.16.1:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}serverfiles>0:misc/py-serverfiles@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}xlrd>=0.9.2:textproc/py-xlrd@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}xlrd>=0.9.2:textproc/py-xlrd@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}XlsxWriter>0:misc/py-XlsxWriter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
USES= python:3.4+ pyqt:5
+USE_PYTHON= distutils cython autoplist noflavors
+USE_PYQT= core_run gui_run printsupport_run widgets_run webengine_run
+
USE_GITHUB= yes
GH_ACCOUNT= biolab
-USE_PYTHON= distutils autoplist noflavors
-USE_PYQT= core_run gui_run printsupport_run widgets_run webengine_run
CFLAGS+= -DQSORT_R_STYLE_BSD=yes
LDFLAGS+= -Xlinker -strip-all # strip, stage-qa doesn't catch that it isn't stripped
-post-install:
+xpost-install:
@${REINPLACE_CMD} -e 's|^"${PREFIX}/|| ; s|"$$||' ${_PYTHONPKGLIST} # https://github.com/biolab/orange3/issues/3060
@${REINPLACE_CMD} -e 's|import sys|& ; from OpenGL import GL|' ${STAGEDIR}${PREFIX}/bin/orange-canvas # https://github.com/biolab/orange3/issues/3062
diff --git a/misc/orange3/distinfo b/misc/orange3/distinfo
index 0c394b4ea530..f77d3a4b7811 100644
--- a/misc/orange3/distinfo
+++ b/misc/orange3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1544861883
-SHA256 (biolab-orange3-3.19.0_GH0.tar.gz) = 9ae6e72fa2ffebe3945d1813439e809fd353ef386fb8cfa10c3cfe3917e03042
-SIZE (biolab-orange3-3.19.0_GH0.tar.gz) = 24877077
+TIMESTAMP = 1615667909
+SHA256 (biolab-orange3-3.28.0_GH0.tar.gz) = 2484904ae1d087c8fac241c8de2607ecdaabfd33637dd56ca9107d5e4e42492a
+SIZE (biolab-orange3-3.28.0_GH0.tar.gz) = 27040658
diff --git a/misc/orange3/files/patch-requirements-core.txt b/misc/orange3/files/patch-requirements-core.txt
new file mode 100644
index 000000000000..662a1bef5708
--- /dev/null
+++ b/misc/orange3/files/patch-requirements-core.txt
@@ -0,0 +1,8 @@
+--- requirements-core.txt.orig 2021-03-13 22:01:25 UTC
++++ requirements-core.txt
+@@ -23,4 +23,4 @@ baycomp>=1.0.2
+ pandas>=1.0.0
+ pyyaml
+ openpyxl
+-httpx>=0.14.0,<0.17
++httpx>=0.14.0
diff --git a/misc/orange3/files/patch-requirements-gui.txt b/misc/orange3/files/patch-requirements-gui.txt
new file mode 100644
index 000000000000..8721258d2d4b
--- /dev/null
+++ b/misc/orange3/files/patch-requirements-gui.txt
@@ -0,0 +1,13 @@
+- fails to find PyQt5 with the line as given
+
+--- requirements-gui.txt.orig 2021-03-13 22:03:33 UTC
++++ requirements-gui.txt
+@@ -1,7 +1,7 @@
+ orange-canvas-core>=0.1.19,<0.2a
+ orange-widget-base>=4.12.0
+
+-PyQt5>=5.12,!=5.15.1 # 5.15.1 skipped because of QTBUG-87057 - affects select columns
++#PyQt5>=5.12,!=5.15.1 # 5.15.1 skipped because of QTBUG-87057 - affects select columns
+ PyQtWebEngine>=5.12
+ AnyQt>=0.0.11
+