aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:43:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:43:12 +0000
commit15afb458d7a59b7a848b69f47b76a34ecaa30cbc (patch)
tree0888d1dbc60a96df27ee9d19d2d431a685decca0 /misc
parent7d527625adb90fe7010ca7d3c48c707048ea80fe (diff)
downloadports-15afb458d7a59b7a848b69f47b76a34ecaa30cbc.tar.gz
ports-15afb458d7a59b7a848b69f47b76a34ecaa30cbc.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Coder-Googlev3/Makefile28
-rw-r--r--misc/p5-Geo-Coder-Googlev3/distinfo2
-rw-r--r--misc/p5-Geo-Coder-Googlev3/pkg-descr9
-rw-r--r--misc/p5-Geo-Coder-Googlev3/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b7fde68fca08..c44f394221e7 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -403,6 +403,7 @@
SUBDIR += p5-Geo-Cache
SUBDIR += p5-Geo-Coder-Bing
SUBDIR += p5-Geo-Coder-Google
+ SUBDIR += p5-Geo-Coder-Googlev3
SUBDIR += p5-Geo-Coder-Multiple
SUBDIR += p5-Geo-Postcodes
SUBDIR += p5-Geo-Postcodes-DK
diff --git a/misc/p5-Geo-Coder-Googlev3/Makefile b/misc/p5-Geo-Coder-Googlev3/Makefile
new file mode 100644
index 000000000000..cd83c3b45567
--- /dev/null
+++ b/misc/p5-Geo-Coder-Googlev3/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Geo-Coder-Googlev3
+# Date created: 2011-10-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-Googlev3
+PORTVERSION= 0.10
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Maps v3 Geocoding API
+
+BUILD_DEPENDS= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::Googlev3.3
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Geo-Coder-Googlev3/distinfo b/misc/p5-Geo-Coder-Googlev3/distinfo
new file mode 100644
index 000000000000..6e3c5f5040ba
--- /dev/null
+++ b/misc/p5-Geo-Coder-Googlev3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coder-Googlev3-0.10.tar.gz) = 8f301803436bbc257756b037718bc766d122be4232da0f4d2e079962c0a6ab01
+SIZE (Geo-Coder-Googlev3-0.10.tar.gz) = 5742
diff --git a/misc/p5-Geo-Coder-Googlev3/pkg-descr b/misc/p5-Geo-Coder-Googlev3/pkg-descr
new file mode 100644
index 000000000000..afb79b7ca4c7
--- /dev/null
+++ b/misc/p5-Geo-Coder-Googlev3/pkg-descr
@@ -0,0 +1,9 @@
+Use Geo::Coder::Googlev3 just like Geo::Coder::Google. Note that no apikey is
+used in Google's v3 API, and the returned data structure differs.
+
+Please check also [1] for more information about Google's Geocoding API and
+especially usage limits.
+
+[1] http://code.google.com/intl/en/apis/maps/documentation/geocoding/
+
+WWW: http://search.cpan.org/dist/Geo-Coder-Googlev3/
diff --git a/misc/p5-Geo-Coder-Googlev3/pkg-plist b/misc/p5-Geo-Coder-Googlev3/pkg-plist
new file mode 100644
index 000000000000..9799c61e00ef
--- /dev/null
+++ b/misc/p5-Geo-Coder-Googlev3/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Geo/Coder/Googlev3.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Googlev3/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Googlev3
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo