aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-08-26 14:11:02 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-08-26 14:11:02 +0000
commit2a013fa858bf73724d86cde8b49d40bccfda33ab (patch)
tree949d4cc4a9ed36f002e2f37722b6e398839245ef /misc
parent05f50f43f6cd80810d24f52d3b6ad59e30d77b94 (diff)
downloadports-2a013fa858bf73724d86cde8b49d40bccfda33ab.tar.gz
ports-2a013fa858bf73724d86cde8b49d40bccfda33ab.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/alevt/Makefile8
-rw-r--r--misc/alevt/distinfo4
-rw-r--r--misc/alevt/files/patch-aa14
-rw-r--r--misc/alevt/files/patch-ab32
-rw-r--r--misc/alevt/files/patch-ac8
-rw-r--r--misc/alevt/pkg-plist1
6 files changed, 27 insertions, 40 deletions
diff --git a/misc/alevt/Makefile b/misc/alevt/Makefile
index 1f3e3d97a523..a93493bc1227 100644
--- a/misc/alevt/Makefile
+++ b/misc/alevt/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= alevt
-PORTVERSION= 1.6.0
-PORTREVISION= 1
+PORTVERSION= 1.6.1
+PORTREVISION= 0
CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- http://user.exit.mytoday.de/froese/alevt/
-MASTER_SITE_SUBDIR= apps/video
+MASTER_SITES= http://www.goron.de/~froese/alevt/
MAINTAINER= roger@freebsd.org
COMMENT= X11 Teletext decoding and display program. (reads from /dev/vbi)
diff --git a/misc/alevt/distinfo b/misc/alevt/distinfo
index 7e18d3be2b45..e38880b8aa08 100644
--- a/misc/alevt/distinfo
+++ b/misc/alevt/distinfo
@@ -1,2 +1,2 @@
-MD5 (alevt-1.6.0.tar.gz) = 3826d99d14d0a8f70f8d3625b2d06d03
-SIZE (alevt-1.6.0.tar.gz) = 116646
+MD5 (alevt-1.6.1.tar.gz) = df6e241c6e2c6505c95d50cde0e1bc73
+SIZE(alevt-1.6.1.tar.gz) = 117731
diff --git a/misc/alevt/files/patch-aa b/misc/alevt/files/patch-aa
index 4bc0be55e357..7437b0417a19 100644
--- a/misc/alevt/files/patch-aa
+++ b/misc/alevt/files/patch-aa
@@ -19,13 +19,13 @@
# anything below this line is just for me!
install: all
-! install -m 0755 alevt $(X11BASE)/bin
-! install -m 0755 alevt-date $(X11BASE)/bin
-! install -m 0755 alevt-cap $(X11BASE)/bin
-! install -m 0644 alevt.1x $(X11BASE)/man/man1
-! install -m 0644 alevt-date.1 $(X11BASE)/man/man1
-! install -m 0644 alevt-cap.1 $(X11BASE)/man/man1
-! install -m 0644 contrib/mini-alevt.xpm $(X11BASE)/include/X11/pixmaps
+! install -m 0755 alevt $(PREFIX)/bin
+! install -m 0755 alevt-date $(PREFIX)/bin
+! install -m 0755 alevt-cap $(PREFIX)/bin
+! install -m 0644 alevt.1x $(PREFIX)/man/man1
+! install -m 0644 alevt-date.1 $(PREFIX)/man/man1
+! install -m 0644 alevt-cap.1 $(PREFIX)/man/man1
+! install -m 0644 contrib/mini-alevt.xpm $(PREFIX)/include/X11/pixmaps
sync
depend:
diff --git a/misc/alevt/files/patch-ab b/misc/alevt/files/patch-ab
index c23be7e251df..b499e4a160a4 100644
--- a/misc/alevt/files/patch-ab
+++ b/misc/alevt/files/patch-ab
@@ -1,34 +1,16 @@
---- exp-html.c.orig Tue May 30 02:09:15 2000
-+++ exp-html.c Wed Oct 18 08:50:59 2000
-@@ -214,7 +214,7 @@
- {
- if (last_space)
- {
-- fprintf(fp,"&nbsp;");
-+ fprintf(fp,"&nbsp");
- last_space=0;
- nbsp=1;
- }
-@@ -251,7 +251,7 @@
- {
- if (last_space)
- {
-- fprintf(fp,"&nbsp;");
-+ fprintf(fp,"&nbsp");
- last_space=0;
- nbsp=1;
- }
+--- exp-html.c.orig Tue Oct 17 21:28:30 2000
++++ exp-html.c Tue Aug 17 16:31:33 2004
@@ -268,7 +268,12 @@
{
//if previous nbsp --> put semicolon!!!
if (nbsp) fputc(';',fp);
- fputc(pg->data[y][z].ch,fp);
+
-+ // Handle ascii characters which have HTML meanings
-+ if (pg->data[y][z].ch == '<') fprintf(fp,"&lt;");
-+ else if (pg->data[y][z].ch == '>') fprintf(fp,"&gt;");
-+ else if (pg->data[y][z].ch == '&') fprintf(fp,"&amp;");
-+ else fputc(pg->data[y][z].ch,fp);
++ // Handle ascii characters which have HTML meanings
++ if (pg->data[y][z].ch == '<') fprintf(fp,"&lt;");
++ else if (pg->data[y][z].ch == '>') fprintf(fp,"&gt;");
++ else if (pg->data[y][z].ch == '&') fprintf(fp,"&amp;");
++ else fputc(pg->data[y][z].ch,fp);
last_space=0;
nbsp=0;
}
diff --git a/misc/alevt/files/patch-ac b/misc/alevt/files/patch-ac
new file mode 100644
index 000000000000..9ecfa0504e21
--- /dev/null
+++ b/misc/alevt/files/patch-ac
@@ -0,0 +1,8 @@
+--- lang.h.orig Tue Aug 17 16:34:24 2004
++++ lang.h Tue Aug 17 16:34:36 2004
+@@ -19,4 +19,4 @@
+ void add_enhance(struct enhance *eh, int dcode, u32 *data);
+ void enhance(struct enhance *eh, struct vt_page *vtp);
+
+-#endif LANG_H
++#endif /* LANG_H */
diff --git a/misc/alevt/pkg-plist b/misc/alevt/pkg-plist
index 2f2cb14a7848..2670eb247291 100644
--- a/misc/alevt/pkg-plist
+++ b/misc/alevt/pkg-plist
@@ -1,5 +1,4 @@
bin/alevt
bin/alevt-date
bin/alevt-cap
-
include/X11/pixmaps/mini-alevt.xpm