aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 14:32:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 14:32:59 +0000
commit2c1d5c8d64cc101a3c165a9655d6b6016bae8c81 (patch)
tree2a74d01b36c39e20dfd54a67d639e5c2e7a76046 /misc
parentf6bc9847f71a8cb6b2709f94fceb770b8811cc80 (diff)
downloadports-2c1d5c8d64cc101a3c165a9655d6b6016bae8c81.tar.gz
ports-2c1d5c8d64cc101a3c165a9655d6b6016bae8c81.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/hello/Makefile10
-rw-r--r--misc/lifelines/Makefile5
-rw-r--r--misc/rabbit/Makefile26
3 files changed, 18 insertions, 23 deletions
diff --git a/misc/hello/Makefile b/misc/hello/Makefile
index ee1edfbed4fb..99aca1c5c047 100644
--- a/misc/hello/Makefile
+++ b/misc/hello/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: hello
-# Date created: Fri Jul 23, 1999
-# Whom: shipley@dis.org
-#
+# Created by: shipley@dis.org
# $FreeBSD$
-#
PORTNAME= hello
PORTVERSION= 2.8
@@ -20,7 +16,9 @@ GNU_CONFIGURE= YES
MAN1= hello.1
INFO= hello
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/misc/lifelines/Makefile b/misc/lifelines/Makefile
index 6c3e92fc9ed1..19e2db79140d 100644
--- a/misc/lifelines/Makefile
+++ b/misc/lifelines/Makefile
@@ -16,7 +16,8 @@ USES= bison iconv
MAN1= btedit.1 dbverify.1 llines.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -27,7 +28,7 @@ PLIST_SUB+= NLS="@comment "
post-patch:
@${REINPLACE_CMD} -e 's,ncursesw/curses.h,curses.h,' \
${WRKSRC}/src/hdrs/mycurses.h
-.ifdef NOPORTDOCS
+.if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e 's,install-data-am: install-docDATA,install-data-am:,' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's,install-data-am: install-dist_pkgdataDATA install-docDATA install-man,install-data-am: install-dist_pkgdataDATA,' \
diff --git a/misc/rabbit/Makefile b/misc/rabbit/Makefile
index 34fc34e14a6e..65eb1b759ba2 100644
--- a/misc/rabbit/Makefile
+++ b/misc/rabbit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rabbit
-# Date created: 2010-08-01
-# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
-#
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= rabbit
PORTVERSION= 1.0.9
@@ -32,14 +28,6 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
USE_RUBY= yes
USE_RUBY_SETUP= yes
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
-USES= gettext
-RUN_DEPENDS+= rubygem-gettext>0:${PORTSDIR}/devel/rubygem-gettext
-PLIST_SUB+= NLS=""
-.endif
-
RUBY_SHEBANG_FILES= bin/rabbirack \
bin/rabbirc \
bin/rabbit \
@@ -58,6 +46,14 @@ TWITTER_DESC= Run with Twitter
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MNLS}
+USES= gettext
+RUN_DEPENDS+= rubygem-gettext>0:${PORTSDIR}/devel/rubygem-gettext
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
.if ${PORT_OPTIONS:MMIMETEX}
RUN_DEPENDS+= ${LOCALBASE}/www/mimetex/cgi-bin/mimetex.cgi:${PORTSDIR}/www/mimetex
.endif
@@ -79,12 +75,12 @@ post-patch:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
@cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@cd ${WRKSRC}/sample && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
.endif