aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-02-24 22:15:01 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-02-24 22:15:01 +0000
commit44a098df42f711a7cf387acc33139964d8ce7c05 (patch)
tree5c30864841ba608ac935240881d9eb54754fcd66 /misc
parent18d0289d459968ea28afd012df38849e476aa223 (diff)
downloadports-44a098df42f711a7cf387acc33139964d8ce7c05.tar.gz
ports-44a098df42f711a7cf387acc33139964d8ce7c05.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/libisocodes/Makefile32
-rw-r--r--misc/libisocodes/distinfo2
-rw-r--r--misc/libisocodes/pkg-descr10
-rw-r--r--misc/libisocodes/pkg-plist17
5 files changed, 62 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 68141ce2be98..5a3aab38f3fe 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -249,6 +249,7 @@
SUBDIR += lesspipe
SUBDIR += libeatmydata
SUBDIR += libhome
+ SUBDIR += libisocodes
SUBDIR += libkdeedu
SUBDIR += libmetalink
SUBDIR += libpri
diff --git a/misc/libisocodes/Makefile b/misc/libisocodes/Makefile
new file mode 100644
index 000000000000..bff010139680
--- /dev/null
+++ b/misc/libisocodes/Makefile
@@ -0,0 +1,32 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libisocodes
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= http://pkg-isocodes.alioth.debian.org/downloads/
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Interaction library for iso-codes
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
+LIB_DEPENDS= libgee.so:${PORTSDIR}/devel/libgee06
+RUN_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes
+
+USE_XZ= yes
+USES= gettext gmake libtool pathfix pkgconfig
+USE_GNOME= glib20 gnomehier introspection:build libxml2
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/xml/|${LOCALBASE}/share/xml/|g' \
+ ${WRKSRC}/src/iso_15924.* ${WRKSRC}/src/iso_3166* \
+ ${WRKSRC}/src/iso_4217.* ${WRKSRC}/src/iso_639* \
+ ${WRKSRC}/src/isocodes.* ${WRKSRC}/tests/test_iso_*.vala
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libisocodes.so.0.0.0
+
+.include <bsd.port.mk>
diff --git a/misc/libisocodes/distinfo b/misc/libisocodes/distinfo
new file mode 100644
index 000000000000..27e36f2d9135
--- /dev/null
+++ b/misc/libisocodes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libisocodes-1.0.tar.xz) = 215fa3c4dc87490ff96bf76c61e1bda86c042b1626fad5311542791bd7aa570f
+SIZE (libisocodes-1.0.tar.xz) = 284856
diff --git a/misc/libisocodes/pkg-descr b/misc/libisocodes/pkg-descr
new file mode 100644
index 000000000000..715a1e5011cb
--- /dev/null
+++ b/misc/libisocodes/pkg-descr
@@ -0,0 +1,10 @@
+This library can be used to easily access XML data of the iso-codes
+package. It will provide an abstraction layer to handle both the
+version 3 and the upcoming version 4 of iso-codes. Moreover, all
+available translations can be used as well.
+
+This library makes use of the GObject introspection features, so that
+it is accessible from a variety of programming languages, for example
+C, Vala, Ruby, Python, Perl, Lua, JavaScript, PHP and many more.
+
+WWW: http://pkg-isocodes.alioth.debian.org/
diff --git a/misc/libisocodes/pkg-plist b/misc/libisocodes/pkg-plist
new file mode 100644
index 000000000000..ab2124a3b691
--- /dev/null
+++ b/misc/libisocodes/pkg-plist
@@ -0,0 +1,17 @@
+include/libisocodes.h
+lib/girepository-1.0/libisocodes-1.0.typelib
+lib/libisocodes.a
+lib/libisocodes.la
+lib/libisocodes.so
+lib/libisocodes.so.0
+lib/libisocodes.so.0.0.0
+libdata/pkgconfig/libisocodes.pc
+share/gir-1.0/libisocodes-1.0.gir
+share/locale/de/LC_MESSAGES/libisocodes.mo
+share/locale/en@boldquot/LC_MESSAGES/libisocodes.mo
+share/locale/en@quot/LC_MESSAGES/libisocodes.mo
+share/vala/vapi/libisocodes.vapi
+@dirrmtry share/locale/en@quot/LC_MESSAGES
+@dirrmtry share/locale/en@quot
+@dirrmtry share/locale/en@boldquot/LC_MESSAGES
+@dirrmtry share/locale/en@boldquot