aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-29 19:38:37 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-29 19:38:37 +0000
commit4522ef8f18c478fecf7f3a4009785fd1a6298a26 (patch)
tree743ee298d6dc36b52d1ae0bf46fb72e3b3e87c91 /misc
parent6ff958cc9b55f04f0a15be36feaea28454ae8f4e (diff)
downloadports-4522ef8f18c478fecf7f3a4009785fd1a6298a26.tar.gz
ports-4522ef8f18c478fecf7f3a4009785fd1a6298a26.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/adios2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/misc/adios2/Makefile b/misc/adios2/Makefile
index 62deac01ddc8..36ce74e85f98 100644
--- a/misc/adios2/Makefile
+++ b/misc/adios2/Makefile
@@ -13,6 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libblosc.so:archivers/c-blosc \
+ libepoll-shim.so:devel/libepoll-shim \
libfabric.so:net/libfabric \
libffi.so:devel/libffi \
libmpi.so:net/openmpi \
@@ -20,7 +21,8 @@ LIB_DEPENDS= libblosc.so:archivers/c-blosc \
libzfp.so:devel/zfp
RUN_DEPENDS= bash:shells/bash
-USES= bison cmake pkgconfig perl5 python shebangfix
+USES= bison cmake compiler:c++11-lang localbase:ldflags pkgconfig \
+ perl5 python shebangfix
SHEBANG_FILES= cmake/install/post/adios2-config.pre.sh.in cmake/install/post/generate-adios2-config.sh.in source/utils/bp4dbg/bp4dbg.py
USE_GITHUB= yes
GH_ACCOUNT= ornladios
@@ -28,5 +30,6 @@ GH_PROJECT= ADIOS2
USE_LDCONFIG= yes
CMAKE_OFF= BUILD_TESTING
+LDFLAGS+= -lepoll-shim
.include <bsd.port.mk>