aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
commit4ca0e60800b90ba4a6de31beabeee8ccce611649 (patch)
tree8324ab31f68eba587c532d238cd3f502d0a56322 /misc
parent7530f93a62fb8bcd686d08f2bfa5dc0f623f3c73 (diff)
downloadports-4ca0e60800b90ba4a6de31beabeee8ccce611649.tar.gz
ports-4ca0e60800b90ba4a6de31beabeee8ccce611649.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/emma/Makefile2
-rw-r--r--misc/gnomepm/Makefile2
-rw-r--r--misc/gnomeusersguide/Makefile2
-rw-r--r--misc/gnomeutils/Makefile2
-rw-r--r--misc/gnomeutils2/Makefile2
-rw-r--r--misc/grdb/Makefile2
-rw-r--r--misc/metatheme/Makefile2
-rw-r--r--misc/metatheme2/Makefile2
-rw-r--r--misc/misterproper/Makefile2
-rw-r--r--misc/pybliographer/Makefile2
10 files changed, 10 insertions, 10 deletions
diff --git a/misc/emma/Makefile b/misc/emma/Makefile
index 44af09361aeb..69055e2c333d 100644
--- a/misc/emma/Makefile
+++ b/misc/emma/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/misc/gnomepm/Makefile b/misc/gnomepm/Makefile
index d6bf14ce61c2..581379ff5acf 100644
--- a/misc/gnomepm/Makefile
+++ b/misc/gnomepm/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/misc/gnomeusersguide/Makefile b/misc/gnomeusersguide/Makefile
index 44fcd0b1d123..c6ec6b4c5f06 100644
--- a/misc/gnomeusersguide/Makefile
+++ b/misc/gnomeusersguide/Makefile
@@ -20,7 +20,7 @@ USE_GNOME= yes
GNU_CONFIGURE= yes
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/misc/gnomeutils/Makefile b/misc/gnomeutils/Makefile
index 0200e1f452ff..255eb9d58b55 100644
--- a/misc/gnomeutils/Makefile
+++ b/misc/gnomeutils/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/misc/gnomeutils2/Makefile b/misc/gnomeutils2/Makefile
index 0200e1f452ff..255eb9d58b55 100644
--- a/misc/gnomeutils2/Makefile
+++ b/misc/gnomeutils2/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/misc/grdb/Makefile b/misc/grdb/Makefile
index 2a8bbca84e2f..ade1426afbeb 100644
--- a/misc/grdb/Makefile
+++ b/misc/grdb/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ARGS= --disable-gnome
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
diff --git a/misc/metatheme/Makefile b/misc/metatheme/Makefile
index 05b251888c2d..a0d3dfbc0873 100644
--- a/misc/metatheme/Makefile
+++ b/misc/metatheme/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/misc/metatheme2/Makefile b/misc/metatheme2/Makefile
index 05b251888c2d..a0d3dfbc0873 100644
--- a/misc/metatheme2/Makefile
+++ b/misc/metatheme2/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/misc/misterproper/Makefile b/misc/misterproper/Makefile
index cfd64822e288..5ddd4a545497 100644
--- a/misc/misterproper/Makefile
+++ b/misc/misterproper/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/misc/pybliographer/Makefile b/misc/pybliographer/Makefile
index e566fdc285b1..68966cbc2f9c 100644
--- a/misc/pybliographer/Makefile
+++ b/misc/pybliographer/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --with-recode-prefix="${LOCALBASE}"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \