aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-02-26 17:32:10 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-02-26 17:32:10 +0000
commit59d0124eb217b222fc8d5706df81968c5b4e358c (patch)
tree1a1315311a4c1a883663bc70729d12062bce2e21 /misc
parent392f1bde4dd0f0bb05cf77ba11afeca6c1dc0fec (diff)
downloadports-59d0124eb217b222fc8d5706df81968c5b4e358c.tar.gz
ports-59d0124eb217b222fc8d5706df81968c5b4e358c.zip
New port: misc/py-wurlitzer: Capture C-level output in context managers
Notes
Notes: svn path=/head/; revision=566621
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-wurlitzer/Makefile30
-rw-r--r--misc/py-wurlitzer/distinfo3
-rw-r--r--misc/py-wurlitzer/pkg-descr3
4 files changed, 37 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d2c0bc154156..4f18651f6ee9 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -419,6 +419,7 @@
SUBDIR += py-toil
SUBDIR += py-tqdm
SUBDIR += py-tvm
+ SUBDIR += py-wurlitzer
SUBDIR += py-xgboost
SUBDIR += pyobd
SUBDIR += qbrew
diff --git a/misc/py-wurlitzer/Makefile b/misc/py-wurlitzer/Makefile
new file mode 100644
index 000000000000..79fa6cd64433
--- /dev/null
+++ b/misc/py-wurlitzer/Makefile
@@ -0,0 +1,30 @@
+# Created by: Rainer Hurling <rhurlin@gwdg.de>
+# $FreeBSD$
+
+PORTNAME= wurlitzer
+PORTVERSION= 2.0.1
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rhurlin@FreeBSD.org
+COMMENT= Capture C-level output in context managers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}codecov>0:devel/py-codecov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -x -v test.py
+
+.include <bsd.port.mk>
diff --git a/misc/py-wurlitzer/distinfo b/misc/py-wurlitzer/distinfo
new file mode 100644
index 000000000000..250a3195841e
--- /dev/null
+++ b/misc/py-wurlitzer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614355503
+SHA256 (wurlitzer-2.0.1.tar.gz) = d08f0728a998441aac3d7a0f8cd6dfed2ba2525144878fb49599b719085b7543
+SIZE (wurlitzer-2.0.1.tar.gz) = 10638
diff --git a/misc/py-wurlitzer/pkg-descr b/misc/py-wurlitzer/pkg-descr
new file mode 100644
index 000000000000..04187c659f26
--- /dev/null
+++ b/misc/py-wurlitzer/pkg-descr
@@ -0,0 +1,3 @@
+Wurlitzer captures C-level stdout/stderr pipes in Python via os.dup2.
+
+WWW: https://github.com/minrk/wurlitzer