aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-22 04:27:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-22 04:27:49 +0000
commit5ad38fa35a8344b99856e507531c23a79120b0af (patch)
treecbe3e26bc542f0916c42ff204109553bd9377b5f /misc
parentc1db67f9318c22a48315eeedbb85c69a11e961f6 (diff)
downloadports-5ad38fa35a8344b99856e507531c23a79120b0af.tar.gz
ports-5ad38fa35a8344b99856e507531c23a79120b0af.zip
Diffstat (limited to 'misc')
-rw-r--r--misc/py-onnx/Makefile3
-rw-r--r--misc/py-onnx/distinfo6
-rw-r--r--misc/py-onnx/files/patch-CMakeLists.txt20
-rw-r--r--misc/py-onnx/files/patch-setup.py38
4 files changed, 33 insertions, 34 deletions
diff --git a/misc/py-onnx/Makefile b/misc/py-onnx/Makefile
index 8a075f912b1f..3490b55623b5 100644
--- a/misc/py-onnx/Makefile
+++ b/misc/py-onnx/Makefile
@@ -1,6 +1,5 @@
PORTNAME= onnx
-DISTVERSION= 1.13.1
-PORTREVISION= 1
+DISTVERSION= 1.14.0
CATEGORIES= misc # machine-learning
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/misc/py-onnx/distinfo b/misc/py-onnx/distinfo
index db8a8241c7b1..be7508d3b078 100644
--- a/misc/py-onnx/distinfo
+++ b/misc/py-onnx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1678353559
-SHA256 (onnx-1.13.1.tar.gz) = 0bdcc25c2c1ce4a8750e4ffbd93ae945442e7fac6e51176f38e366b74a97dfd9
-SIZE (onnx-1.13.1.tar.gz) = 10405481
+TIMESTAMP = 1687406533
+SHA256 (onnx-1.14.0.tar.gz) = 43b85087c6b919de66872a043c7f4899fe6f840e11ffca7e662b2ce9e4cc2927
+SIZE (onnx-1.14.0.tar.gz) = 11329418
diff --git a/misc/py-onnx/files/patch-CMakeLists.txt b/misc/py-onnx/files/patch-CMakeLists.txt
index 7444f85f429d..57ed278e4e2f 100644
--- a/misc/py-onnx/files/patch-CMakeLists.txt
+++ b/misc/py-onnx/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt.orig 2023-02-22 16:34:35 UTC
+--- CMakeLists.txt.orig 2023-04-12 23:29:41 UTC
+++ CMakeLists.txt
-@@ -18,7 +18,7 @@ project(onnx C CXX)
- option(ONNX_BUILD_BENCHMARKS "Build ONNX micro-benchmarks" OFF)
- option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag and Protobuf_USE_STATIC_LIBS. " OFF)
-
--option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
-+option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
- option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
- option(ONNX_WERROR "Build with Werror" OFF)
- option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
+@@ -18,7 +18,7 @@ project(onnx C CXX)
+ option(ONNX_BUILD_BENCHMARKS "Build ONNX micro-benchmarks" OFF)
+ option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag and Protobuf_USE_STATIC_LIBS. " OFF)
+
+-option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
++option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
+ option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
+ option(ONNX_WERROR "Build with Werror" OFF)
+ option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
diff --git a/misc/py-onnx/files/patch-setup.py b/misc/py-onnx/files/patch-setup.py
index b20306abb9fb..550ecb070c95 100644
--- a/misc/py-onnx/files/patch-setup.py
+++ b/misc/py-onnx/files/patch-setup.py
@@ -1,20 +1,20 @@
---- setup.py.orig 2023-02-22 16:34:50 UTC
+--- setup.py.orig 2023-04-12 23:29:42 UTC
+++ setup.py
-@@ -56,11 +56,12 @@ COVERAGE = bool(os.getenv("COVERAGE", "0") == "1")
- ################################################################################
-
- try:
-- git_version = (
-- subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
-- .decode("ascii")
-- .strip()
-- )
-+ #git_version = (
-+ # subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
-+ # .decode("ascii")
-+ # .strip()
-+ #)
-+ git_version = None
- except (OSError, subprocess.CalledProcessError):
- git_version = None
-
+@@ -59,11 +59,12 @@ COVERAGE = bool(os.getenv("COVERAGE", "0") == "1")
+ ################################################################################
+
+ try:
+- git_version = (
+- subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
+- .decode("ascii")
+- .strip()
+- )
++ #git_version = (
++ # subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
++ # .decode("ascii")
++ # .strip()
++ #)
++ git_version = None
+ except (OSError, subprocess.CalledProcessError):
+ git_version = None
+