aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-03-14 16:21:42 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-03-14 16:21:42 +0000
commit5c08de67ecc2a01b1b3722eed176a38e88a9594f (patch)
treef1bebc5439846f51b0fa94b349d952e1f59a39eb /misc
parent0ca48c214f64971a460092b2385d31126ef19266 (diff)
downloadports-5c08de67ecc2a01b1b3722eed176a38e88a9594f.tar.gz
ports-5c08de67ecc2a01b1b3722eed176a38e88a9594f.zip
misc/py-xgboost: Fix packaging with Python 3.8
* While I'm here, level up port compliance (strip shared library). * Bump PORTREVISION due changed package contents. PR: 253815 Approved by: python (with hat)
Notes
Notes: svn path=/head/; revision=568400
Diffstat (limited to 'misc')
-rw-r--r--misc/py-xgboost/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/misc/py-xgboost/Makefile b/misc/py-xgboost/Makefile
index 56307d4c824c..b695a4da28e6 100644
--- a/misc/py-xgboost/Makefile
+++ b/misc/py-xgboost/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xgboost
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= misc # machine-learning
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -38,7 +39,10 @@ POST_PLIST= fix-plist
BROKEN_i386= undefined symbol: __atomic_load (on 11 and 12, but not on 13)
.endif
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}/lib/libxgboost.so
+
fix-plist: # https://github.com/dmlc/xgboost/issues/5705
- @${REINPLACE_CMD} 's|/libxgboost.so$$|/xgboost/lib/libxgboost.so|' ${TMPPLIST}
+ @${REINPLACE_CMD} 's|/libxgboost${PYTHON_EXT_SUFFIX}.so$$|/xgboost/lib/libxgboost.so|' ${TMPPLIST}
.include <bsd.port.post.mk>