aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-02-11 13:25:38 +0000
committerClement Laforet <clement@FreeBSD.org>2004-02-11 13:25:38 +0000
commit6b40729543fb189f696258667035c8a85657cfde (patch)
treefeb6b672fdd90367a61b25991c764478ce1fd836 /misc
parenta7ca41e6b3c0eb27484686ebc5fe38a8a3acbd16 (diff)
downloadports-6b40729543fb189f696258667035c8a85657cfde.tar.gz
ports-6b40729543fb189f696258667035c8a85657cfde.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Howto/Makefile27
-rw-r--r--misc/Howto/distinfo7
-rw-r--r--misc/Howto/pkg-plist410
-rw-r--r--misc/argparse/pkg-plist6
-rw-r--r--misc/bb/Makefile5
-rw-r--r--misc/bb/pkg-plist7
-rw-r--r--misc/biblereader/Makefile6
-rw-r--r--misc/biblereader/pkg-plist4
-rw-r--r--misc/biblereader/pkg-plist.dictionaries10
-rw-r--r--misc/biblereader/pkg-plist.notes2
-rw-r--r--misc/biblereader/pkg-plist.translations4
-rw-r--r--misc/boxes/Makefile10
-rw-r--r--misc/boxes/pkg-plist3
13 files changed, 251 insertions, 250 deletions
diff --git a/misc/Howto/Makefile b/misc/Howto/Makefile
index 1cec1806a217..7570bea1246a 100644
--- a/misc/Howto/Makefile
+++ b/misc/Howto/Makefile
@@ -7,10 +7,9 @@
PORTNAME= Howto
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= misc
MASTER_SITES= ftp://metalab.unc.edu/pub/Linux/docs/HOWTO/other-formats/sgml/ \
- ftp://metalab.unc.edu/pub/Linux/docs/HOWTO/mini/other-formats/sgml/ \
ftp://metalab.unc.edu/pub/Linux/docs/HOWTO/other-formats/docbook/
DISTFILES= Linux+FreeBSD.sgml.gz \
DNS-HOWTO.sgml.gz \
@@ -25,20 +24,22 @@ BUILD_DEPENDS= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
DIST_SUBDIR= Howto
NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_BZIP2= yes
do-extract:
@${MKDIR} ${WRKSRC}
- @for file in ${DISTFILES}; do \
- ${CP} ${_DISTDIR}/$$file ${WRKSRC} ; \
- case $$file in \
+ @for f in ${DISTFILES}; do \
+ ${CP} ${_DISTDIR}/$$f ${WRKSRC} ; \
+ case $$f in \
*.Z|*.gz) \
- ${GZIP_CMD} -d ${WRKSRC}/$$file ; \
+ ${GZIP_CMD} -d ${WRKSRC}/$$f ; \
;; \
*.zip) \
- cd ${WRKSRC} && unzip $$file ; \
+ cd ${WRKSRC} && ${UNZIP_CMD} $$f ; \
;; \
*.bz2) \
- bzip2 -d ${WRKSRC}/$$file ; \
+ ${BZIP2_CMD} -d ${WRKSRC}/$$f ; \
;; \
esac; \
done
@@ -51,10 +52,10 @@ do-build:
.endfor
do-install:
- @${MKDIR} ${PREFIX}/share/doc/Howto/HTML
- @${INSTALL_MAN} ${FILESDIR}/HOWTO-INDEX.html ${PREFIX}/share/doc/Howto
- @${INSTALL_MAN} ${WRKSRC}/*.html ${PREFIX}/share/doc/Howto/HTML
- @${INSTALL_MAN} ${WRKSRC}/*.latin1 ${PREFIX}/share/doc/Howto
- @${INSTALL_MAN} ${WRKSRC}/*.ascii ${PREFIX}/share/doc/Howto
+ @${MKDIR} ${DOCSDIR}/HTML
+ @${INSTALL_MAN} ${FILESDIR}/HOWTO-INDEX.html ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/*.html ${DOCSDIR}/HTML
+ @${INSTALL_MAN} ${WRKSRC}/*.latin1 ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/*.ascii ${DOCSDIR}
.include <bsd.port.mk>
diff --git a/misc/Howto/distinfo b/misc/Howto/distinfo
index 2c59db8930e2..a1af509584d8 100644
--- a/misc/Howto/distinfo
+++ b/misc/Howto/distinfo
@@ -1,5 +1,10 @@
MD5 (Howto/Linux+FreeBSD.sgml.gz) = 6c24d994421b4c336f7f7621fd849858
+SIZE (Howto/Linux+FreeBSD.sgml.gz) = 7530
MD5 (Howto/DNS-HOWTO.sgml.gz) = 86b63214d1f0bec0b26a4fc62816a13d
-MD5 (Howto/NIS-HOWTO.sgml.gz) = cfe7b8f28476e3b236b083e8f08295d6
+SIZE (Howto/DNS-HOWTO.sgml.gz) = 28065
MD5 (Howto/NFS-HOWTO.sgml.gz) = 8f610c8c0329e5637eaf2a8185a480b0
+SIZE (Howto/NFS-HOWTO.sgml.gz) = 743
+MD5 (Howto/NIS-HOWTO.sgml.gz) = cfe7b8f28476e3b236b083e8f08295d6
+SIZE (Howto/NIS-HOWTO.sgml.gz) = 17702
MD5 (Howto/Security-HOWTO.sgml.gz) = da012cfb35ad470a18bd20d8a24a0d87
+SIZE (Howto/Security-HOWTO.sgml.gz) = 51824
diff --git a/misc/Howto/pkg-plist b/misc/Howto/pkg-plist
index 9455d7b2bc67..105c4a60c151 100644
--- a/misc/Howto/pkg-plist
+++ b/misc/Howto/pkg-plist
@@ -1,205 +1,205 @@
-share/doc/Howto/DNS-HOWTO.ascii
-share/doc/Howto/DNS-HOWTO.latin1
-share/doc/Howto/HOWTO-INDEX.html
-share/doc/Howto/HTML/DNS-HOWTO.html
-share/doc/Howto/HTML/DNS-HOWTO1.html
-share/doc/Howto/HTML/DNS-HOWTO10.html
-share/doc/Howto/HTML/DNS-HOWTO11.html
-share/doc/Howto/HTML/DNS-HOWTO12.html
-share/doc/Howto/HTML/DNS-HOWTO13.html
-share/doc/Howto/HTML/DNS-HOWTO14.html
-share/doc/Howto/HTML/DNS-HOWTO15.html
-share/doc/Howto/HTML/DNS-HOWTO16.html
-share/doc/Howto/HTML/DNS-HOWTO17.html
-share/doc/Howto/HTML/DNS-HOWTO18.html
-share/doc/Howto/HTML/DNS-HOWTO19.html
-share/doc/Howto/HTML/DNS-HOWTO2.html
-share/doc/Howto/HTML/DNS-HOWTO20.html
-share/doc/Howto/HTML/DNS-HOWTO21.html
-share/doc/Howto/HTML/DNS-HOWTO22.html
-share/doc/Howto/HTML/DNS-HOWTO23.html
-share/doc/Howto/HTML/DNS-HOWTO24.html
-share/doc/Howto/HTML/DNS-HOWTO25.html
-share/doc/Howto/HTML/DNS-HOWTO26.html
-share/doc/Howto/HTML/DNS-HOWTO27.html
-share/doc/Howto/HTML/DNS-HOWTO28.html
-share/doc/Howto/HTML/DNS-HOWTO29.html
-share/doc/Howto/HTML/DNS-HOWTO3.html
-share/doc/Howto/HTML/DNS-HOWTO30.html
-share/doc/Howto/HTML/DNS-HOWTO31.html
-share/doc/Howto/HTML/DNS-HOWTO32.html
-share/doc/Howto/HTML/DNS-HOWTO33.html
-share/doc/Howto/HTML/DNS-HOWTO34.html
-share/doc/Howto/HTML/DNS-HOWTO35.html
-share/doc/Howto/HTML/DNS-HOWTO4.html
-share/doc/Howto/HTML/DNS-HOWTO5.html
-share/doc/Howto/HTML/DNS-HOWTO6.html
-share/doc/Howto/HTML/DNS-HOWTO7.html
-share/doc/Howto/HTML/DNS-HOWTO8.html
-share/doc/Howto/HTML/DNS-HOWTO9.html
-share/doc/Howto/HTML/DNS-HOWTO_toc.html
-share/doc/Howto/HTML/Linux+FreeBSD.html
-share/doc/Howto/HTML/Linux+FreeBSD1.html
-share/doc/Howto/HTML/Linux+FreeBSD10.html
-share/doc/Howto/HTML/Linux+FreeBSD11.html
-share/doc/Howto/HTML/Linux+FreeBSD12.html
-share/doc/Howto/HTML/Linux+FreeBSD13.html
-share/doc/Howto/HTML/Linux+FreeBSD14.html
-share/doc/Howto/HTML/Linux+FreeBSD15.html
-share/doc/Howto/HTML/Linux+FreeBSD16.html
-share/doc/Howto/HTML/Linux+FreeBSD17.html
-share/doc/Howto/HTML/Linux+FreeBSD18.html
-share/doc/Howto/HTML/Linux+FreeBSD2.html
-share/doc/Howto/HTML/Linux+FreeBSD3.html
-share/doc/Howto/HTML/Linux+FreeBSD4.html
-share/doc/Howto/HTML/Linux+FreeBSD5.html
-share/doc/Howto/HTML/Linux+FreeBSD6.html
-share/doc/Howto/HTML/Linux+FreeBSD7.html
-share/doc/Howto/HTML/Linux+FreeBSD8.html
-share/doc/Howto/HTML/Linux+FreeBSD9.html
-share/doc/Howto/HTML/Linux+FreeBSD_toc.html
-share/doc/Howto/HTML/NFS-HOWTO.html
-share/doc/Howto/HTML/NFS-HOWTO_toc.html
-share/doc/Howto/HTML/NIS-HOWTO.html
-share/doc/Howto/HTML/NIS-HOWTO1.html
-share/doc/Howto/HTML/NIS-HOWTO10.html
-share/doc/Howto/HTML/NIS-HOWTO11.html
-share/doc/Howto/HTML/NIS-HOWTO12.html
-share/doc/Howto/HTML/NIS-HOWTO13.html
-share/doc/Howto/HTML/NIS-HOWTO14.html
-share/doc/Howto/HTML/NIS-HOWTO15.html
-share/doc/Howto/HTML/NIS-HOWTO16.html
-share/doc/Howto/HTML/NIS-HOWTO17.html
-share/doc/Howto/HTML/NIS-HOWTO18.html
-share/doc/Howto/HTML/NIS-HOWTO19.html
-share/doc/Howto/HTML/NIS-HOWTO2.html
-share/doc/Howto/HTML/NIS-HOWTO20.html
-share/doc/Howto/HTML/NIS-HOWTO21.html
-share/doc/Howto/HTML/NIS-HOWTO22.html
-share/doc/Howto/HTML/NIS-HOWTO23.html
-share/doc/Howto/HTML/NIS-HOWTO24.html
-share/doc/Howto/HTML/NIS-HOWTO25.html
-share/doc/Howto/HTML/NIS-HOWTO26.html
-share/doc/Howto/HTML/NIS-HOWTO27.html
-share/doc/Howto/HTML/NIS-HOWTO28.html
-share/doc/Howto/HTML/NIS-HOWTO29.html
-share/doc/Howto/HTML/NIS-HOWTO3.html
-share/doc/Howto/HTML/NIS-HOWTO30.html
-share/doc/Howto/HTML/NIS-HOWTO31.html
-share/doc/Howto/HTML/NIS-HOWTO32.html
-share/doc/Howto/HTML/NIS-HOWTO33.html
-share/doc/Howto/HTML/NIS-HOWTO34.html
-share/doc/Howto/HTML/NIS-HOWTO35.html
-share/doc/Howto/HTML/NIS-HOWTO36.html
-share/doc/Howto/HTML/NIS-HOWTO37.html
-share/doc/Howto/HTML/NIS-HOWTO38.html
-share/doc/Howto/HTML/NIS-HOWTO39.html
-share/doc/Howto/HTML/NIS-HOWTO4.html
-share/doc/Howto/HTML/NIS-HOWTO40.html
-share/doc/Howto/HTML/NIS-HOWTO5.html
-share/doc/Howto/HTML/NIS-HOWTO6.html
-share/doc/Howto/HTML/NIS-HOWTO7.html
-share/doc/Howto/HTML/NIS-HOWTO8.html
-share/doc/Howto/HTML/NIS-HOWTO9.html
-share/doc/Howto/HTML/NIS-HOWTO_toc.html
-share/doc/Howto/HTML/Security-HOWTO.html
-share/doc/Howto/HTML/Security-HOWTO1.html
-share/doc/Howto/HTML/Security-HOWTO10.html
-share/doc/Howto/HTML/Security-HOWTO11.html
-share/doc/Howto/HTML/Security-HOWTO12.html
-share/doc/Howto/HTML/Security-HOWTO13.html
-share/doc/Howto/HTML/Security-HOWTO14.html
-share/doc/Howto/HTML/Security-HOWTO15.html
-share/doc/Howto/HTML/Security-HOWTO16.html
-share/doc/Howto/HTML/Security-HOWTO17.html
-share/doc/Howto/HTML/Security-HOWTO18.html
-share/doc/Howto/HTML/Security-HOWTO19.html
-share/doc/Howto/HTML/Security-HOWTO2.html
-share/doc/Howto/HTML/Security-HOWTO20.html
-share/doc/Howto/HTML/Security-HOWTO21.html
-share/doc/Howto/HTML/Security-HOWTO22.html
-share/doc/Howto/HTML/Security-HOWTO23.html
-share/doc/Howto/HTML/Security-HOWTO24.html
-share/doc/Howto/HTML/Security-HOWTO25.html
-share/doc/Howto/HTML/Security-HOWTO26.html
-share/doc/Howto/HTML/Security-HOWTO27.html
-share/doc/Howto/HTML/Security-HOWTO28.html
-share/doc/Howto/HTML/Security-HOWTO29.html
-share/doc/Howto/HTML/Security-HOWTO3.html
-share/doc/Howto/HTML/Security-HOWTO30.html
-share/doc/Howto/HTML/Security-HOWTO31.html
-share/doc/Howto/HTML/Security-HOWTO32.html
-share/doc/Howto/HTML/Security-HOWTO33.html
-share/doc/Howto/HTML/Security-HOWTO34.html
-share/doc/Howto/HTML/Security-HOWTO35.html
-share/doc/Howto/HTML/Security-HOWTO36.html
-share/doc/Howto/HTML/Security-HOWTO37.html
-share/doc/Howto/HTML/Security-HOWTO38.html
-share/doc/Howto/HTML/Security-HOWTO39.html
-share/doc/Howto/HTML/Security-HOWTO4.html
-share/doc/Howto/HTML/Security-HOWTO40.html
-share/doc/Howto/HTML/Security-HOWTO41.html
-share/doc/Howto/HTML/Security-HOWTO42.html
-share/doc/Howto/HTML/Security-HOWTO43.html
-share/doc/Howto/HTML/Security-HOWTO44.html
-share/doc/Howto/HTML/Security-HOWTO45.html
-share/doc/Howto/HTML/Security-HOWTO46.html
-share/doc/Howto/HTML/Security-HOWTO47.html
-share/doc/Howto/HTML/Security-HOWTO48.html
-share/doc/Howto/HTML/Security-HOWTO49.html
-share/doc/Howto/HTML/Security-HOWTO5.html
-share/doc/Howto/HTML/Security-HOWTO50.html
-share/doc/Howto/HTML/Security-HOWTO51.html
-share/doc/Howto/HTML/Security-HOWTO52.html
-share/doc/Howto/HTML/Security-HOWTO53.html
-share/doc/Howto/HTML/Security-HOWTO54.html
-share/doc/Howto/HTML/Security-HOWTO55.html
-share/doc/Howto/HTML/Security-HOWTO56.html
-share/doc/Howto/HTML/Security-HOWTO57.html
-share/doc/Howto/HTML/Security-HOWTO58.html
-share/doc/Howto/HTML/Security-HOWTO59.html
-share/doc/Howto/HTML/Security-HOWTO6.html
-share/doc/Howto/HTML/Security-HOWTO60.html
-share/doc/Howto/HTML/Security-HOWTO61.html
-share/doc/Howto/HTML/Security-HOWTO62.html
-share/doc/Howto/HTML/Security-HOWTO63.html
-share/doc/Howto/HTML/Security-HOWTO64.html
-share/doc/Howto/HTML/Security-HOWTO65.html
-share/doc/Howto/HTML/Security-HOWTO66.html
-share/doc/Howto/HTML/Security-HOWTO67.html
-share/doc/Howto/HTML/Security-HOWTO68.html
-share/doc/Howto/HTML/Security-HOWTO69.html
-share/doc/Howto/HTML/Security-HOWTO7.html
-share/doc/Howto/HTML/Security-HOWTO70.html
-share/doc/Howto/HTML/Security-HOWTO71.html
-share/doc/Howto/HTML/Security-HOWTO72.html
-share/doc/Howto/HTML/Security-HOWTO73.html
-share/doc/Howto/HTML/Security-HOWTO74.html
-share/doc/Howto/HTML/Security-HOWTO75.html
-share/doc/Howto/HTML/Security-HOWTO76.html
-share/doc/Howto/HTML/Security-HOWTO77.html
-share/doc/Howto/HTML/Security-HOWTO78.html
-share/doc/Howto/HTML/Security-HOWTO79.html
-share/doc/Howto/HTML/Security-HOWTO8.html
-share/doc/Howto/HTML/Security-HOWTO80.html
-share/doc/Howto/HTML/Security-HOWTO81.html
-share/doc/Howto/HTML/Security-HOWTO82.html
-share/doc/Howto/HTML/Security-HOWTO83.html
-share/doc/Howto/HTML/Security-HOWTO84.html
-share/doc/Howto/HTML/Security-HOWTO85.html
-share/doc/Howto/HTML/Security-HOWTO86.html
-share/doc/Howto/HTML/Security-HOWTO87.html
-share/doc/Howto/HTML/Security-HOWTO88.html
-share/doc/Howto/HTML/Security-HOWTO89.html
-share/doc/Howto/HTML/Security-HOWTO9.html
-share/doc/Howto/HTML/Security-HOWTO_toc.html
-share/doc/Howto/Linux+FreeBSD.ascii
-share/doc/Howto/Linux+FreeBSD.latin1
-share/doc/Howto/NFS-HOWTO.ascii
-share/doc/Howto/NFS-HOWTO.latin1
-share/doc/Howto/NIS-HOWTO.ascii
-share/doc/Howto/NIS-HOWTO.latin1
-share/doc/Howto/Security-HOWTO.ascii
-share/doc/Howto/Security-HOWTO.latin1
-@dirrm share/doc/Howto/HTML
-@dirrm share/doc/Howto
+%%DOCSDIR%%/DNS-HOWTO.ascii
+%%DOCSDIR%%/DNS-HOWTO.latin1
+%%DOCSDIR%%/HOWTO-INDEX.html
+%%DOCSDIR%%/HTML/DNS-HOWTO.html
+%%DOCSDIR%%/HTML/DNS-HOWTO1.html
+%%DOCSDIR%%/HTML/DNS-HOWTO10.html
+%%DOCSDIR%%/HTML/DNS-HOWTO11.html
+%%DOCSDIR%%/HTML/DNS-HOWTO12.html
+%%DOCSDIR%%/HTML/DNS-HOWTO13.html
+%%DOCSDIR%%/HTML/DNS-HOWTO14.html
+%%DOCSDIR%%/HTML/DNS-HOWTO15.html
+%%DOCSDIR%%/HTML/DNS-HOWTO16.html
+%%DOCSDIR%%/HTML/DNS-HOWTO17.html
+%%DOCSDIR%%/HTML/DNS-HOWTO18.html
+%%DOCSDIR%%/HTML/DNS-HOWTO19.html
+%%DOCSDIR%%/HTML/DNS-HOWTO2.html
+%%DOCSDIR%%/HTML/DNS-HOWTO20.html
+%%DOCSDIR%%/HTML/DNS-HOWTO21.html
+%%DOCSDIR%%/HTML/DNS-HOWTO22.html
+%%DOCSDIR%%/HTML/DNS-HOWTO23.html
+%%DOCSDIR%%/HTML/DNS-HOWTO24.html
+%%DOCSDIR%%/HTML/DNS-HOWTO25.html
+%%DOCSDIR%%/HTML/DNS-HOWTO26.html
+%%DOCSDIR%%/HTML/DNS-HOWTO27.html
+%%DOCSDIR%%/HTML/DNS-HOWTO28.html
+%%DOCSDIR%%/HTML/DNS-HOWTO29.html
+%%DOCSDIR%%/HTML/DNS-HOWTO3.html
+%%DOCSDIR%%/HTML/DNS-HOWTO30.html
+%%DOCSDIR%%/HTML/DNS-HOWTO31.html
+%%DOCSDIR%%/HTML/DNS-HOWTO32.html
+%%DOCSDIR%%/HTML/DNS-HOWTO33.html
+%%DOCSDIR%%/HTML/DNS-HOWTO34.html
+%%DOCSDIR%%/HTML/DNS-HOWTO35.html
+%%DOCSDIR%%/HTML/DNS-HOWTO4.html
+%%DOCSDIR%%/HTML/DNS-HOWTO5.html
+%%DOCSDIR%%/HTML/DNS-HOWTO6.html
+%%DOCSDIR%%/HTML/DNS-HOWTO7.html
+%%DOCSDIR%%/HTML/DNS-HOWTO8.html
+%%DOCSDIR%%/HTML/DNS-HOWTO9.html
+%%DOCSDIR%%/HTML/DNS-HOWTO_toc.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD1.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD10.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD11.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD12.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD13.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD14.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD15.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD16.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD17.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD18.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD2.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD3.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD4.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD5.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD6.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD7.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD8.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD9.html
+%%DOCSDIR%%/HTML/Linux+FreeBSD_toc.html
+%%DOCSDIR%%/HTML/NFS-HOWTO.html
+%%DOCSDIR%%/HTML/NFS-HOWTO_toc.html
+%%DOCSDIR%%/HTML/NIS-HOWTO.html
+%%DOCSDIR%%/HTML/NIS-HOWTO1.html
+%%DOCSDIR%%/HTML/NIS-HOWTO10.html
+%%DOCSDIR%%/HTML/NIS-HOWTO11.html
+%%DOCSDIR%%/HTML/NIS-HOWTO12.html
+%%DOCSDIR%%/HTML/NIS-HOWTO13.html
+%%DOCSDIR%%/HTML/NIS-HOWTO14.html
+%%DOCSDIR%%/HTML/NIS-HOWTO15.html
+%%DOCSDIR%%/HTML/NIS-HOWTO16.html
+%%DOCSDIR%%/HTML/NIS-HOWTO17.html
+%%DOCSDIR%%/HTML/NIS-HOWTO18.html
+%%DOCSDIR%%/HTML/NIS-HOWTO19.html
+%%DOCSDIR%%/HTML/NIS-HOWTO2.html
+%%DOCSDIR%%/HTML/NIS-HOWTO20.html
+%%DOCSDIR%%/HTML/NIS-HOWTO21.html
+%%DOCSDIR%%/HTML/NIS-HOWTO22.html
+%%DOCSDIR%%/HTML/NIS-HOWTO23.html
+%%DOCSDIR%%/HTML/NIS-HOWTO24.html
+%%DOCSDIR%%/HTML/NIS-HOWTO25.html
+%%DOCSDIR%%/HTML/NIS-HOWTO26.html
+%%DOCSDIR%%/HTML/NIS-HOWTO27.html
+%%DOCSDIR%%/HTML/NIS-HOWTO28.html
+%%DOCSDIR%%/HTML/NIS-HOWTO29.html
+%%DOCSDIR%%/HTML/NIS-HOWTO3.html
+%%DOCSDIR%%/HTML/NIS-HOWTO30.html
+%%DOCSDIR%%/HTML/NIS-HOWTO31.html
+%%DOCSDIR%%/HTML/NIS-HOWTO32.html
+%%DOCSDIR%%/HTML/NIS-HOWTO33.html
+%%DOCSDIR%%/HTML/NIS-HOWTO34.html
+%%DOCSDIR%%/HTML/NIS-HOWTO35.html
+%%DOCSDIR%%/HTML/NIS-HOWTO36.html
+%%DOCSDIR%%/HTML/NIS-HOWTO37.html
+%%DOCSDIR%%/HTML/NIS-HOWTO38.html
+%%DOCSDIR%%/HTML/NIS-HOWTO39.html
+%%DOCSDIR%%/HTML/NIS-HOWTO4.html
+%%DOCSDIR%%/HTML/NIS-HOWTO40.html
+%%DOCSDIR%%/HTML/NIS-HOWTO5.html
+%%DOCSDIR%%/HTML/NIS-HOWTO6.html
+%%DOCSDIR%%/HTML/NIS-HOWTO7.html
+%%DOCSDIR%%/HTML/NIS-HOWTO8.html
+%%DOCSDIR%%/HTML/NIS-HOWTO9.html
+%%DOCSDIR%%/HTML/NIS-HOWTO_toc.html
+%%DOCSDIR%%/HTML/Security-HOWTO.html
+%%DOCSDIR%%/HTML/Security-HOWTO1.html
+%%DOCSDIR%%/HTML/Security-HOWTO10.html
+%%DOCSDIR%%/HTML/Security-HOWTO11.html
+%%DOCSDIR%%/HTML/Security-HOWTO12.html
+%%DOCSDIR%%/HTML/Security-HOWTO13.html
+%%DOCSDIR%%/HTML/Security-HOWTO14.html
+%%DOCSDIR%%/HTML/Security-HOWTO15.html
+%%DOCSDIR%%/HTML/Security-HOWTO16.html
+%%DOCSDIR%%/HTML/Security-HOWTO17.html
+%%DOCSDIR%%/HTML/Security-HOWTO18.html
+%%DOCSDIR%%/HTML/Security-HOWTO19.html
+%%DOCSDIR%%/HTML/Security-HOWTO2.html
+%%DOCSDIR%%/HTML/Security-HOWTO20.html
+%%DOCSDIR%%/HTML/Security-HOWTO21.html
+%%DOCSDIR%%/HTML/Security-HOWTO22.html
+%%DOCSDIR%%/HTML/Security-HOWTO23.html
+%%DOCSDIR%%/HTML/Security-HOWTO24.html
+%%DOCSDIR%%/HTML/Security-HOWTO25.html
+%%DOCSDIR%%/HTML/Security-HOWTO26.html
+%%DOCSDIR%%/HTML/Security-HOWTO27.html
+%%DOCSDIR%%/HTML/Security-HOWTO28.html
+%%DOCSDIR%%/HTML/Security-HOWTO29.html
+%%DOCSDIR%%/HTML/Security-HOWTO3.html
+%%DOCSDIR%%/HTML/Security-HOWTO30.html
+%%DOCSDIR%%/HTML/Security-HOWTO31.html
+%%DOCSDIR%%/HTML/Security-HOWTO32.html
+%%DOCSDIR%%/HTML/Security-HOWTO33.html
+%%DOCSDIR%%/HTML/Security-HOWTO34.html
+%%DOCSDIR%%/HTML/Security-HOWTO35.html
+%%DOCSDIR%%/HTML/Security-HOWTO36.html
+%%DOCSDIR%%/HTML/Security-HOWTO37.html
+%%DOCSDIR%%/HTML/Security-HOWTO38.html
+%%DOCSDIR%%/HTML/Security-HOWTO39.html
+%%DOCSDIR%%/HTML/Security-HOWTO4.html
+%%DOCSDIR%%/HTML/Security-HOWTO40.html
+%%DOCSDIR%%/HTML/Security-HOWTO41.html
+%%DOCSDIR%%/HTML/Security-HOWTO42.html
+%%DOCSDIR%%/HTML/Security-HOWTO43.html
+%%DOCSDIR%%/HTML/Security-HOWTO44.html
+%%DOCSDIR%%/HTML/Security-HOWTO45.html
+%%DOCSDIR%%/HTML/Security-HOWTO46.html
+%%DOCSDIR%%/HTML/Security-HOWTO47.html
+%%DOCSDIR%%/HTML/Security-HOWTO48.html
+%%DOCSDIR%%/HTML/Security-HOWTO49.html
+%%DOCSDIR%%/HTML/Security-HOWTO5.html
+%%DOCSDIR%%/HTML/Security-HOWTO50.html
+%%DOCSDIR%%/HTML/Security-HOWTO51.html
+%%DOCSDIR%%/HTML/Security-HOWTO52.html
+%%DOCSDIR%%/HTML/Security-HOWTO53.html
+%%DOCSDIR%%/HTML/Security-HOWTO54.html
+%%DOCSDIR%%/HTML/Security-HOWTO55.html
+%%DOCSDIR%%/HTML/Security-HOWTO56.html
+%%DOCSDIR%%/HTML/Security-HOWTO57.html
+%%DOCSDIR%%/HTML/Security-HOWTO58.html
+%%DOCSDIR%%/HTML/Security-HOWTO59.html
+%%DOCSDIR%%/HTML/Security-HOWTO6.html
+%%DOCSDIR%%/HTML/Security-HOWTO60.html
+%%DOCSDIR%%/HTML/Security-HOWTO61.html
+%%DOCSDIR%%/HTML/Security-HOWTO62.html
+%%DOCSDIR%%/HTML/Security-HOWTO63.html
+%%DOCSDIR%%/HTML/Security-HOWTO64.html
+%%DOCSDIR%%/HTML/Security-HOWTO65.html
+%%DOCSDIR%%/HTML/Security-HOWTO66.html
+%%DOCSDIR%%/HTML/Security-HOWTO67.html
+%%DOCSDIR%%/HTML/Security-HOWTO68.html
+%%DOCSDIR%%/HTML/Security-HOWTO69.html
+%%DOCSDIR%%/HTML/Security-HOWTO7.html
+%%DOCSDIR%%/HTML/Security-HOWTO70.html
+%%DOCSDIR%%/HTML/Security-HOWTO71.html
+%%DOCSDIR%%/HTML/Security-HOWTO72.html
+%%DOCSDIR%%/HTML/Security-HOWTO73.html
+%%DOCSDIR%%/HTML/Security-HOWTO74.html
+%%DOCSDIR%%/HTML/Security-HOWTO75.html
+%%DOCSDIR%%/HTML/Security-HOWTO76.html
+%%DOCSDIR%%/HTML/Security-HOWTO77.html
+%%DOCSDIR%%/HTML/Security-HOWTO78.html
+%%DOCSDIR%%/HTML/Security-HOWTO79.html
+%%DOCSDIR%%/HTML/Security-HOWTO8.html
+%%DOCSDIR%%/HTML/Security-HOWTO80.html
+%%DOCSDIR%%/HTML/Security-HOWTO81.html
+%%DOCSDIR%%/HTML/Security-HOWTO82.html
+%%DOCSDIR%%/HTML/Security-HOWTO83.html
+%%DOCSDIR%%/HTML/Security-HOWTO84.html
+%%DOCSDIR%%/HTML/Security-HOWTO85.html
+%%DOCSDIR%%/HTML/Security-HOWTO86.html
+%%DOCSDIR%%/HTML/Security-HOWTO87.html
+%%DOCSDIR%%/HTML/Security-HOWTO88.html
+%%DOCSDIR%%/HTML/Security-HOWTO89.html
+%%DOCSDIR%%/HTML/Security-HOWTO9.html
+%%DOCSDIR%%/HTML/Security-HOWTO_toc.html
+%%DOCSDIR%%/Linux+FreeBSD.ascii
+%%DOCSDIR%%/Linux+FreeBSD.latin1
+%%DOCSDIR%%/NFS-HOWTO.ascii
+%%DOCSDIR%%/NFS-HOWTO.latin1
+%%DOCSDIR%%/NIS-HOWTO.ascii
+%%DOCSDIR%%/NIS-HOWTO.latin1
+%%DOCSDIR%%/Security-HOWTO.ascii
+%%DOCSDIR%%/Security-HOWTO.latin1
+@dirrm %%DOCSDIR%%/HTML
+@dirrm %%DOCSDIR%%
diff --git a/misc/argparse/pkg-plist b/misc/argparse/pkg-plist
index 86b24d508f17..4ac8e0a71625 100644
--- a/misc/argparse/pkg-plist
+++ b/misc/argparse/pkg-plist
@@ -1,4 +1,4 @@
bin/argparse
-share/doc/argparse/example/argparse-demo.sh
-@dirrm share/doc/argparse/example
-@dirrm share/doc/argparse
+%%DOCSDIR%%/example/argparse-demo.sh
+@dirrm %%DOCSDIR%%/example
+@dirrm %%DOCSDIR%%
diff --git a/misc/bb/Makefile b/misc/bb/Makefile
index b34cf0e3076f..dc537f394e06 100644
--- a/misc/bb/Makefile
+++ b/misc/bb/Makefile
@@ -22,6 +22,9 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/bb-1.3.0
MAN1= bb.1
+PORTDOCS= README
+PLIST_FILES= bin/bb share/bb/bb.s3m share/bb/bb2.s3m share/bb/bb3.s3m
+PLIST_DIRS= share/bb
pre-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -E -e "s@#include +<malloc.h>@#include <stdlib.h>@g"
@@ -29,7 +32,7 @@ pre-patch:
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/misc/bb/pkg-plist b/misc/bb/pkg-plist
deleted file mode 100644
index fda7598757c0..000000000000
--- a/misc/bb/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-bin/bb
-share/bb/bb.s3m
-share/bb/bb2.s3m
-share/bb/bb3.s3m
-%%PORTDOCS%%share/doc/bb/README
-@dirrm share/bb
-%%PORTDOCS%%@dirrm share/doc/bb
diff --git a/misc/biblereader/Makefile b/misc/biblereader/Makefile
index 8c48b37a3e4f..3f0b0f43644c 100644
--- a/misc/biblereader/Makefile
+++ b/misc/biblereader/Makefile
@@ -69,9 +69,9 @@ pre-install:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/biblereader ${PREFIX}/bin/biblereader
- ${MKDIR} ${PREFIX}/share/biblereader
- for file in ${DATAFILES}; do \
- ${INSTALL_DATA} $${file} ${PREFIX}/share/biblereader; \
+ ${MKDIR} ${DATADIR}
+ for F in ${DATAFILES}; do \
+ ${INSTALL_DATA} $${F} ${DATADIR}; \
done
.include <bsd.port.mk>
diff --git a/misc/biblereader/pkg-plist b/misc/biblereader/pkg-plist
index 11295b4d263e..a57292672d51 100644
--- a/misc/biblereader/pkg-plist
+++ b/misc/biblereader/pkg-plist
@@ -1,3 +1,3 @@
bin/biblereader
-share/biblereader/kjv
-@dirrm share/biblereader
+%%DATADIR%%/kjv
+@dirrm %%DATADIR%%
diff --git a/misc/biblereader/pkg-plist.dictionaries b/misc/biblereader/pkg-plist.dictionaries
index da2ffb8740b5..af9edd247c5b 100644
--- a/misc/biblereader/pkg-plist.dictionaries
+++ b/misc/biblereader/pkg-plist.dictionaries
@@ -1,5 +1,5 @@
-share/biblereader/eastons.dict
-share/biblereader/kjv-strongs
-share/biblereader/strongs-greek.dict
-share/biblereader/strongs-hebrew.dict
-share/biblereader/torrey.dict
+%%DATADIR%%/eastons.dict
+%%DATADIR%%/kjv-strongs
+%%DATADIR%%/strongs-greek.dict
+%%DATADIR%%/strongs-hebrew.dict
+%%DATADIR%%/torrey.dict
diff --git a/misc/biblereader/pkg-plist.notes b/misc/biblereader/pkg-plist.notes
index 15d59a498b12..fa70d65c4005 100644
--- a/misc/biblereader/pkg-plist.notes
+++ b/misc/biblereader/pkg-plist.notes
@@ -1 +1 @@
-share/biblereader/mhc
+%%DATADIR%%/mhc
diff --git a/misc/biblereader/pkg-plist.translations b/misc/biblereader/pkg-plist.translations
index 3ecb786aaea4..f54884711e27 100644
--- a/misc/biblereader/pkg-plist.translations
+++ b/misc/biblereader/pkg-plist.translations
@@ -1,2 +1,2 @@
-share/biblereader/darby
-share/biblereader/asv
+%%DATADIR%%/darby
+%%DATADIR%%/asv
diff --git a/misc/boxes/Makefile b/misc/boxes/Makefile
index 708163911a06..36c2bdf5fe0d 100644
--- a/misc/boxes/Makefile
+++ b/misc/boxes/Makefile
@@ -23,12 +23,14 @@ USE_BISON= yes
ALL_TARGET= boxes
MAKE_ARGS= GLOBALCONF=${GLOBALCONF} CFLAGS_ADDTL="${CFLAGS}"
-GLOBALCONF= ${PREFIX}/share/boxes/boxes-config
+GLOBALCONF= ${DATADIR}/boxes-config
+PLIST_FILES= bin/boxes share/boxes/boxes-config
+PLIST_DIRS= share/boxes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/boxes ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/boxes
- ${INSTALL_DATA} ${WRKSRC}/boxes-config ${PREFIX}/share/boxes
- ${INSTALL_MAN} ${WRKSRC}/doc/$(MAN1) ${PREFIX}/man/man1
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/boxes-config ${DATADIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/misc/boxes/pkg-plist b/misc/boxes/pkg-plist
deleted file mode 100644
index d85e62d21281..000000000000
--- a/misc/boxes/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/boxes
-share/boxes/boxes-config
-@dirrm share/boxes