aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-11-02 12:58:52 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-11-02 12:58:52 +0000
commit76c0ae56963f140569573eb3db99a4938ac9621c (patch)
treeebab2868c990dd81a90ada95b6399d918525da41 /misc
parent2e282743a2dc059814c7b21ed456606dc1811252 (diff)
downloadports-76c0ae56963f140569573eb3db99a4938ac9621c.tar.gz
ports-76c0ae56963f140569573eb3db99a4938ac9621c.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/gkrellweather2/Makefile41
-rw-r--r--misc/gkrellweather2/distinfo4
-rw-r--r--misc/gkrellweather2/files/extra-patch-lrintf11
-rw-r--r--misc/gkrellweather2/files/patch-Makefile2
-rw-r--r--misc/gkrellweather2/files/patch-gkrellweather.c16
-rw-r--r--misc/gkrellweather2/pkg-descr4
6 files changed, 32 insertions, 46 deletions
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
index 8db42f57e3fa..15980db6b4bd 100644
--- a/misc/gkrellweather2/Makefile
+++ b/misc/gkrellweather2/Makefile
@@ -2,36 +2,33 @@
# $FreeBSD$
PORTNAME= gkrellweather
-PORTVERSION= 2.0.7
-PORTREVISION= 9
+PORTVERSION= 2.0.8
CATEGORIES= misc geography
-MASTER_SITES= http://makovick.googlepages.com/
+MASTER_SITES= https://sites.google.com/site/makovick/projects/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= GKrellWeather is a weather plugin for GKrellM
+COMMENT= Weather plugin for GKrellM
+
+LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
-USES= gmake pkgconfig
-ALL_TARGET= gkrellweather.so
-
-MAKE_ENV= enable_nls=1 PTHREAD_LIBS=${PTHREAD_LIBS}
+FETCH_ARGS= -Fpr
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-# uses C99 builtin lrintf
-.if ${ARCH} != "amd64"
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-lrintf
-.endif
+USES= gettext gmake pkgconfig
+MAKE_ENV= enable_nls=1
+ALL_TARGET= gkrellweather.so
do-install:
- ${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
- ${INSTALL_DATA} ${WRKSRC}/gkrellweather.so ${PREFIX}/libexec/gkrellm2/plugins
- ${MKDIR} ${PREFIX}/share/locale/ru/
- ${INSTALL_DATA} ${WRKSRC}/po/ru.mo ${PREFIX}/share/locale/ru/LC_MESSAGES/gkrellweather.mo
- ${INSTALL_SCRIPT} ${WRKSRC}/GrabWeather ${PREFIX}/bin
-
-.include <bsd.port.post.mk>
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} GrabWeather \
+ ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
+ (cd ${WRKSRC} && ${INSTALL_DATA} gkrellweather.so \
+ ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins)
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/ru
+ (cd ${WRKSRC}/po && ${INSTALL_DATA} ru.mo \
+ ${STAGEDIR}${PREFIX}/share/locale/ru/LC_MESSAGES/gkrellweather.mo)
+
+.include <bsd.port.mk>
diff --git a/misc/gkrellweather2/distinfo b/misc/gkrellweather2/distinfo
index 0215f48b2305..51e5edebabdf 100644
--- a/misc/gkrellweather2/distinfo
+++ b/misc/gkrellweather2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gkrellweather-2.0.7.tgz) = ad902acd0ffb8adb1f0d838e57545d1f52a31ae33711b73d28929c2786a740ca
-SIZE (gkrellweather-2.0.7.tgz) = 19968
+SHA256 (gkrellweather-2.0.8.tgz) = 06236ad489151019e71bab4ba63b4b8b06d58c58890caed8b1a28fdd05cde16d
+SIZE (gkrellweather-2.0.8.tgz) = 20227
diff --git a/misc/gkrellweather2/files/extra-patch-lrintf b/misc/gkrellweather2/files/extra-patch-lrintf
deleted file mode 100644
index aacc5a32a00d..000000000000
--- a/misc/gkrellweather2/files/extra-patch-lrintf
+++ /dev/null
@@ -1,11 +0,0 @@
---- gkrellweather.c.orig Wed Mar 2 00:23:34 2005
-+++ gkrellweather.c Wed Mar 2 00:28:58 2005
-@@ -7,6 +7,8 @@
- #include <gkrellm2/gkrellm.h>
- #include <math.h>
-
-+#define lrintf(x) (int)rintf(x)
-+
- #define DEFAULT_STATION_ID "YSSY"
-
- #define STYLE_NAME "weather"
diff --git a/misc/gkrellweather2/files/patch-Makefile b/misc/gkrellweather2/files/patch-Makefile
index 63618847d54f..79f121ea1e05 100644
--- a/misc/gkrellweather2/files/patch-Makefile
+++ b/misc/gkrellweather2/files/patch-Makefile
@@ -24,7 +24,7 @@
gkrellweather.so: $(OBJS)
(cd po && ${MAKE} all )
- $(CC) $(OBJS) -DVERSION=\"$(VERSION)\" -o gkrellweather.so $(LFLAGS) $(LIBS) -lpthread
-+ $(CC) $(OBJS) -DVERSION=\"$(VERSION)\" -o gkrellweather.so $(LFLAGS) $(LIBS) ${PTHREAD_LIBS}
++ $(CC) $(OBJS) -DVERSION=\"$(VERSION)\" -o gkrellweather.so $(LFLAGS) $(LIBS) -pthread
clean:
(cd po && ${MAKE} clean )
diff --git a/misc/gkrellweather2/files/patch-gkrellweather.c b/misc/gkrellweather2/files/patch-gkrellweather.c
index 78276801fa6d..6ade4424a75a 100644
--- a/misc/gkrellweather2/files/patch-gkrellweather.c
+++ b/misc/gkrellweather2/files/patch-gkrellweather.c
@@ -1,19 +1,19 @@
--- gkrellweather.c.orig Mon Mar 31 13:12:57 2003
+++ gkrellweather.c Sun Jul 13 14:30:14 2003
-@@ -983,7 +983,7 @@
+@@ -986,7 +986,7 @@
options.windspeed_unit = 1;
options.pressure_unit = 1;
strcpy(options.station, DEFAULT_STATION_ID);
-- sprintf(options.command, "/usr/share/gkrellm/GrabWeather %s", options.station);
-+ sprintf(options.command, "GrabWeather %s", options.station);
- sprintf(options.filename, "%s/.wmWeatherReports/%s.dat",
- getenv("HOME"), options.station);
- }
-@@ -993,6 +993,7 @@
+- snprintf(options.command, 512, "/usr/share/gkrellm/GrabWeather %s", options.station);
++ snprintf(options.command, 512, "GrabWeather %s", options.station);
+ options.command[511] = 0;
+ snprintf(options.filename, 512, "%s/.wmWeatherReports/%s.dat",
+ getenv("HOME"), options.station);
+@@ -998,6 +998,7 @@
gkrellm_init_plugin(void)
{
#ifdef ENABLE_NLS
-+ bindtextdomain(PACKAGE, LOCALEDIR);
++ bindtextdomain(PACKAGE, LOCALEDIR);
bind_textdomain_codeset(PACKAGE, "UTF-8");
#endif /* ENABLE_NLS */
style_id = gkrellm_add_meter_style(&air_mon, STYLE_NAME);
diff --git a/misc/gkrellweather2/pkg-descr b/misc/gkrellweather2/pkg-descr
index 790521a51830..7135ec2a9dc0 100644
--- a/misc/gkrellweather2/pkg-descr
+++ b/misc/gkrellweather2/pkg-descr
@@ -11,6 +11,6 @@ Features
- Display using metric units (degrees Celsius, millimeters of
Mercury, kilometers per hour)
- Display pressure in kPa, hPa and mmHg
-- Display wind speeds in kmph, mps and beaufort scale
+- Display wind speeds in kmph, mps and Beaufort scale
-WWW: http://makovick.googlepages.com/gkrellmplugins
+WWW: https://sites.google.com/site/makovick/gkrellm-plugins