aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-06 23:15:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-06 23:15:06 +0000
commit8adc55f62a2e10992814d0bb7f504ed8378357dc (patch)
tree4198ad9285148498133b65ad32b6044b5dce7822 /misc
parent80ea9fe904dbf7b160378baf605c2461fd6ee311 (diff)
downloadports-8adc55f62a2e10992814d0bb7f504ed8378357dc.tar.gz
ports-8adc55f62a2e10992814d0bb7f504ed8378357dc.zip
misc/veles: Fix runtime crash due to change in msgpack python module interface
Diffstat (limited to 'misc')
-rw-r--r--misc/veles/Makefile2
-rw-r--r--misc/veles/files/patch-python_veles_proto_msgpackwrap.py14
2 files changed, 15 insertions, 1 deletions
diff --git a/misc/veles/Makefile b/misc/veles/Makefile
index 4e813cafe1bf..9848abcb0eb3 100644
--- a/misc/veles/Makefile
+++ b/misc/veles/Makefile
@@ -1,7 +1,7 @@
PORTNAME= veles
DISTVERSION= 2018.05.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
diff --git a/misc/veles/files/patch-python_veles_proto_msgpackwrap.py b/misc/veles/files/patch-python_veles_proto_msgpackwrap.py
new file mode 100644
index 000000000000..df1b644b1f1d
--- /dev/null
+++ b/misc/veles/files/patch-python_veles_proto_msgpackwrap.py
@@ -0,0 +1,14 @@
+- workaround for the incompatibility with newer python's msgpack package:
+- TypeError: __init__() got an unexpected keyword argument 'encoding'
+
+--- python/veles/proto/msgpackwrap.py.orig 2021-04-01 00:13:20 UTC
++++ python/veles/proto/msgpackwrap.py
+@@ -33,7 +33,7 @@ class MsgpackWrapper(pep487.NewObject):
+ self.packer = msgpack.Packer(
+ use_bin_type=True, default=MsgpackWrapper.pack_obj)
+ self.unpacker = msgpack.Unpacker(
+- encoding='utf-8', ext_hook=MsgpackWrapper.load_obj, max_buffer_size=sys.maxsize)
++ ext_hook=MsgpackWrapper.load_obj, max_buffer_size=sys.maxsize)
+
+ @classmethod
+ def pack_obj(cls, obj):