aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-25 10:16:31 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-25 10:16:31 +0000
commit8ee6d3d021cdfe7b2ddb3a8083e617baa1b2f5c8 (patch)
tree10d119b88f46994a730888bd8e8d484139cab062 /misc
parent34480c770d113af7bc2baf8a5af127231c676781 (diff)
downloadports-8ee6d3d021cdfe7b2ddb3a8083e617baa1b2f5c8.tar.gz
ports-8ee6d3d021cdfe7b2ddb3a8083e617baa1b2f5c8.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/fortune-mod-freebsd-classic/Makefile44
-rw-r--r--misc/fortune-mod-freebsd-classic/distinfo3
-rw-r--r--misc/fortune-mod-freebsd-classic/pkg-descr4
4 files changed, 52 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 1777a2b8dd7a..efc1469447dd 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -97,6 +97,7 @@
SUBDIR += fortune-mod-bible
SUBDIR += fortune-mod-bofh
SUBDIR += fortune-mod-epictetus
+ SUBDIR += fortune-mod-freebsd-classic
SUBDIR += fortune-mod-futurama
SUBDIR += fortune-mod-psalms
SUBDIR += fortuneit
diff --git a/misc/fortune-mod-freebsd-classic/Makefile b/misc/fortune-mod-freebsd-classic/Makefile
new file mode 100644
index 000000000000..05fd36be97e7
--- /dev/null
+++ b/misc/fortune-mod-freebsd-classic/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= fortune-mod-freebsd-classic
+DISTVERSION= g20171121
+CATEGORIES= misc
+
+MAINTAINER= jdc@koitsu.org
+COMMENT= Classic FreeBSD fortunes (including offensives)
+
+# LICENSE is intentionally unset. Some fortune files, such as
+# gerrold.limerick, are copyright the author but used with permission.
+# Others have no license defined in them. I get the impression many
+# are Public Domain or possibly BSD4CLAUSE -- consider fortune was
+# originally written by Ken Arnold at UC Berkeley; the FreeBSD
+# fortune import was from 4.4BSD-Lite circa 1995.
+
+USE_GITHUB= yes
+GH_ACCOUNT= koitsu
+GH_TAGNAME= 58ee9c5
+NO_ARCH= yes
+
+SRCF= fortunes gerrold.limerick limerick murphy murphy-o startrek zippy
+PLIST_FILES= ${SRCF:S|^|share/games/fortune/|} ${SRCF:S|^|share/games/fortune/|:S|$|.dat|}
+
+.if exists(/usr/games/strfile)
+_STRFILE= /usr/games/strfile
+.elif exists(/usr/bin/strfile)
+_STRFILE= /usr/bin/strfile
+.else
+IGNORE= needs strfile command. Please install games distribution of base system
+.endif
+
+do-build:
+.for f in ${SRCF}
+ @${_STRFILE} -Cs ${WRKSRC}/datfiles/${f} ${WRKSRC}/datfiles/${f}.dat
+.endfor
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/games/fortune
+.for f in ${SRCF}
+ ${INSTALL_DATA} ${WRKSRC}/datfiles/${f} ${WRKSRC}/datfiles/${f}.dat ${STAGEDIR}${PREFIX}/share/games/fortune
+.endfor
+
+.include <bsd.port.mk>
diff --git a/misc/fortune-mod-freebsd-classic/distinfo b/misc/fortune-mod-freebsd-classic/distinfo
new file mode 100644
index 000000000000..b06bb2dcf8bd
--- /dev/null
+++ b/misc/fortune-mod-freebsd-classic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511467012
+SHA256 (koitsu-fortune-mod-freebsd-classic-g20171121-58ee9c5_GH0.tar.gz) = 4fd3376dad7e1b5682709ed6f62e30342da724e70e828a79b31e5bbce23c46f7
+SIZE (koitsu-fortune-mod-freebsd-classic-g20171121-58ee9c5_GH0.tar.gz) = 1045867
diff --git a/misc/fortune-mod-freebsd-classic/pkg-descr b/misc/fortune-mod-freebsd-classic/pkg-descr
new file mode 100644
index 000000000000..29527c70c974
--- /dev/null
+++ b/misc/fortune-mod-freebsd-classic/pkg-descr
@@ -0,0 +1,4 @@
+fortune-mod-freebsd-classic contains of all the "classic" FreeBSD
+fortunes, including offensives.
+
+WWW: https://github.com/koitsu/fortune-mod-freebsd-classic