aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-30 02:35:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-30 02:35:55 +0000
commita3e0d1a4bf8ca63e32b1ad568a48ccd0cc058c4a (patch)
tree48c6eb4f6a2bab6382014b2fd8d2e5fa297c1ace /misc
parentc503a78e9e563266eb4de2ff84e201f2c2a28066 (diff)
downloadports-a3e0d1a4bf8ca63e32b1ad568a48ccd0cc058c4a.tar.gz
ports-a3e0d1a4bf8ca63e32b1ad568a48ccd0cc058c4a.zip
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ola/Makefile35
-rw-r--r--misc/ola/distinfo3
-rw-r--r--misc/ola/pkg-descr4
-rw-r--r--misc/ola/pkg-plist389
5 files changed, 432 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index fb7b86063976..6f4aaaa02eb4 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -280,6 +280,7 @@
SUBDIR += nsf
SUBDIR += numchar
SUBDIR += nut
+ SUBDIR += ola
SUBDIR += ompl
SUBDIR += ondir
SUBDIR += onnx
diff --git a/misc/ola/Makefile b/misc/ola/Makefile
new file mode 100644
index 000000000000..acc50a9f7be0
--- /dev/null
+++ b/misc/ola/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= ola
+DISTVERSION= 0.10.9
+CATEGORIES= misc
+MASTER_SITES= https://github.com/OpenLightingProject/ola/releases/download/${DISTVERSION}/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Open Lighting Architecture: framework for lighting control information
+WWW= https://www.openlighting.org/ola/
+
+LICENSE= GPLv2+
+
+LIB_DEPENDS= libavahi-common.so:net/avahi-app \
+ libmicrohttpd.so:www/libmicrohttpd \
+ libprotobuf.so:devel/protobuf \
+ libuuid.so:misc/e2fsprogs-libuuid
+TEST_DEPENDS= cppunit>0:devel/cppunit
+
+USES= bison gmake libtool localbase pkgconfig
+USE_LDCONFIG= yes
+
+LDFLAGS+= -lprotobuf # workaround for https://github.com/OpenLightingProject/ola/issues/1871
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --disable-unittests --disable-examples
+
+TEST_TARGET= check
+INSTALL_TARGET= install-strip
+
+do-test: # 1 test fails, see https://github.com/OpenLightingProject/ola/issues/1872
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ./configure ${CONFIGURE_ARGS} --enable-unittests && \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${TEST_TARGET}
+
+.include <bsd.port.mk>
diff --git a/misc/ola/distinfo b/misc/ola/distinfo
new file mode 100644
index 000000000000..aa69c855991b
--- /dev/null
+++ b/misc/ola/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688084092
+SHA256 (ola-0.10.9.tar.gz) = 44073698c147fe641507398253c2e52ff8dc7eac8606cbf286c29f37939a4ebf
+SIZE (ola-0.10.9.tar.gz) = 2578760
diff --git a/misc/ola/pkg-descr b/misc/ola/pkg-descr
new file mode 100644
index 000000000000..fadc6e6fdc52
--- /dev/null
+++ b/misc/ola/pkg-descr
@@ -0,0 +1,4 @@
+libartnet is an implementation of the ArtNet protocol.
+ArtNet enables DMX512 and RDM data to be sent over IPv4 Networks.
+ArtNet was first developed in 2002 and is widely supported by networked
+devices in the entertainment industry.
diff --git a/misc/ola/pkg-plist b/misc/ola/pkg-plist
new file mode 100644
index 000000000000..5f1d980f1541
--- /dev/null
+++ b/misc/ola/pkg-plist
@@ -0,0 +1,389 @@
+bin/ola_trigger
+bin/olad
+bin/rdmpro_sniffer
+bin/usbpro_firmware
+include/ola/ActionQueue.h
+include/ola/AutoStart.h
+include/ola/BaseTypes.h
+include/ola/Callback.h
+include/ola/CallbackRunner.h
+include/ola/Clock.h
+include/ola/Constants.h
+include/ola/DmxBuffer.h
+include/ola/ExportMap.h
+include/ola/Logging.h
+include/ola/MultiCallback.h
+include/ola/OlaCallbackClient.h
+include/ola/OlaClientWrapper.h
+include/ola/OlaDevice.h
+include/ola/StreamingClient.h
+include/ola/StringUtils.h
+include/ola/artnet/ArtNetConfigMessages.pb.h
+include/ola/base/Array.h
+include/ola/base/Credentials.h
+include/ola/base/Env.h
+include/ola/base/Flags.h
+include/ola/base/FlagsPrivate.h
+include/ola/base/Init.h
+include/ola/base/Macro.h
+include/ola/base/SysExits.h
+include/ola/base/Version.h
+include/ola/client/CallbackTypes.h
+include/ola/client/ClientArgs.h
+include/ola/client/ClientRDMAPIShim.h
+include/ola/client/ClientTypes.h
+include/ola/client/ClientWrapper.h
+include/ola/client/Module.h
+include/ola/client/OlaClient.h
+include/ola/client/Result.h
+include/ola/client/StreamingClient.h
+include/ola/dmx/RunLengthEncoder.h
+include/ola/dmx/SourcePriorities.h
+include/ola/e131/E131ConfigMessages.pb.h
+include/ola/file/Util.h
+include/ola/http/HTTPServer.h
+include/ola/http/OlaHTTPServer.h
+include/ola/io/BigEndianStream.h
+include/ola/io/ByteString.h
+include/ola/io/Descriptor.h
+include/ola/io/ExtendedSerial.h
+include/ola/io/IOQueue.h
+include/ola/io/IOStack.h
+include/ola/io/IOUtils.h
+include/ola/io/IOVecInterface.h
+include/ola/io/InputBuffer.h
+include/ola/io/InputStream.h
+include/ola/io/MemoryBlock.h
+include/ola/io/MemoryBlockPool.h
+include/ola/io/MemoryBuffer.h
+include/ola/io/NonBlockingSender.h
+include/ola/io/OutputBuffer.h
+include/ola/io/OutputStream.h
+include/ola/io/SelectServer.h
+include/ola/io/SelectServerInterface.h
+include/ola/io/Serial.h
+include/ola/io/StdinHandler.h
+include/ola/messaging/Descriptor.h
+include/ola/messaging/DescriptorVisitor.h
+include/ola/messaging/Message.h
+include/ola/messaging/MessagePrinter.h
+include/ola/messaging/MessageVisitor.h
+include/ola/messaging/SchemaPrinter.h
+include/ola/messaging/StringMessageBuilder.h
+include/ola/network/AdvancedTCPConnector.h
+include/ola/network/HealthCheckedConnection.h
+include/ola/network/IPV4Address.h
+include/ola/network/Interface.h
+include/ola/network/InterfacePicker.h
+include/ola/network/MACAddress.h
+include/ola/network/NetworkUtils.h
+include/ola/network/Socket.h
+include/ola/network/SocketAddress.h
+include/ola/network/SocketCloser.h
+include/ola/network/TCPConnector.h
+include/ola/network/TCPSocket.h
+include/ola/network/TCPSocketFactory.h
+include/ola/plugin_id.h
+include/ola/random/Random.h
+include/ola/rdm/AckTimerResponder.h
+include/ola/rdm/AdvancedDimmerResponder.h
+include/ola/rdm/CommandPrinter.h
+include/ola/rdm/DimmerResponder.h
+include/ola/rdm/DimmerRootDevice.h
+include/ola/rdm/DimmerSubDevice.h
+include/ola/rdm/DiscoveryAgent.h
+include/ola/rdm/DummyResponder.h
+include/ola/rdm/MessageDeserializer.h
+include/ola/rdm/MessageSerializer.h
+include/ola/rdm/MovingLightResponder.h
+include/ola/rdm/NetworkManagerInterface.h
+include/ola/rdm/NetworkResponder.h
+include/ola/rdm/OpenLightingEnums.h
+include/ola/rdm/PidStore.h
+include/ola/rdm/PidStoreHelper.h
+include/ola/rdm/QueueingRDMController.h
+include/ola/rdm/RDMAPI.h
+include/ola/rdm/RDMAPIImplInterface.h
+include/ola/rdm/RDMCommand.h
+include/ola/rdm/RDMCommandSerializer.h
+include/ola/rdm/RDMControllerAdaptor.h
+include/ola/rdm/RDMControllerInterface.h
+include/ola/rdm/RDMEnums.h
+include/ola/rdm/RDMFrame.h
+include/ola/rdm/RDMHelper.h
+include/ola/rdm/RDMMessagePrinters.h
+include/ola/rdm/RDMPacket.h
+include/ola/rdm/RDMReply.h
+include/ola/rdm/RDMResponseCodes.h
+include/ola/rdm/ResponderHelper.h
+include/ola/rdm/ResponderLoadSensor.h
+include/ola/rdm/ResponderOps.h
+include/ola/rdm/ResponderOpsPrivate.h
+include/ola/rdm/ResponderPersonality.h
+include/ola/rdm/ResponderSensor.h
+include/ola/rdm/ResponderSettings.h
+include/ola/rdm/ResponderSlotData.h
+include/ola/rdm/SensorResponder.h
+include/ola/rdm/StringMessageBuilder.h
+include/ola/rdm/SubDeviceDispatcher.h
+include/ola/rdm/UID.h
+include/ola/rdm/UIDAllocator.h
+include/ola/rdm/UIDSet.h
+include/ola/rpc/RpcSessionHandler.h
+include/ola/stl/STLUtils.h
+include/ola/strings/Format.h
+include/ola/strings/FormatPrivate.h
+include/ola/strings/Utils.h
+include/ola/system/Limits.h
+include/ola/system/SystemUtils.h
+include/ola/thread/CallbackThread.h
+include/ola/thread/ConsumerThread.h
+include/ola/thread/ExecutorInterface.h
+include/ola/thread/ExecutorThread.h
+include/ola/thread/Future.h
+include/ola/thread/FuturePrivate.h
+include/ola/thread/Mutex.h
+include/ola/thread/PeriodicThread.h
+include/ola/thread/SchedulerInterface.h
+include/ola/thread/SchedulingExecutorInterface.h
+include/ola/thread/SignalThread.h
+include/ola/thread/Thread.h
+include/ola/thread/ThreadPool.h
+include/ola/thread/Utils.h
+include/ola/timecode/TimeCode.h
+include/ola/timecode/TimeCodeEnums.h
+include/ola/usbpro/UsbProConfigMessages.pb.h
+include/ola/util/Backoff.h
+include/ola/util/Deleter.h
+include/ola/util/SequenceNumber.h
+include/ola/util/Utils.h
+include/ola/util/Watchdog.h
+include/ola/web/Json.h
+include/ola/web/JsonData.h
+include/ola/web/JsonLexer.h
+include/ola/web/JsonParser.h
+include/ola/web/JsonPatch.h
+include/ola/web/JsonPatchParser.h
+include/ola/web/JsonPointer.h
+include/ola/web/JsonSchema.h
+include/ola/web/JsonSections.h
+include/ola/web/JsonTypes.h
+include/ola/web/JsonWriter.h
+include/ola/web/OptionalItem.h
+include/ola/win/CleanWinSock2.h
+include/ola/win/CleanWindows.h
+include/olad/Device.h
+include/olad/DmxSource.h
+include/olad/OlaDaemon.h
+include/olad/OlaServer.h
+include/olad/Plugin.h
+include/olad/PluginAdaptor.h
+include/olad/Port.h
+include/olad/PortBroker.h
+include/olad/PortConstants.h
+include/olad/Preferences.h
+include/olad/TokenBucket.h
+include/olad/Universe.h
+lib/libola.a
+lib/libola.so
+lib/libola.so.1
+lib/libola.so.1.0.1
+lib/libolaartnet.a
+lib/libolaartnet.so
+lib/libolaartnet.so.0
+lib/libolaartnet.so.0.0.0
+lib/libolaartnetconf.a
+lib/libolaartnetconf.so
+lib/libolaartnetconf.so.0
+lib/libolaartnetconf.so.0.0.0
+lib/libolacommon.a
+lib/libolacommon.so
+lib/libolacommon.so.0
+lib/libolacommon.so.0.0.0
+lib/liboladummy.a
+lib/liboladummy.so
+lib/liboladummy.so.0
+lib/liboladummy.so.0.0.0
+lib/libolae131.a
+lib/libolae131.so
+lib/libolae131.so.0
+lib/libolae131.so.0.0.0
+lib/libolae131conf.a
+lib/libolae131conf.so
+lib/libolae131conf.so.0
+lib/libolae131conf.so.0.0.0
+lib/libolaespnet.a
+lib/libolaespnet.so
+lib/libolaespnet.so.0
+lib/libolaespnet.so.0.0.0
+lib/libolagpio.a
+lib/libolagpio.so
+lib/libolagpio.so.0
+lib/libolagpio.so.0.0.0
+lib/libolagpiocore.a
+lib/libolagpiocore.so
+lib/libolagpiocore.so.0
+lib/libolagpiocore.so.0.0.0
+lib/libolakarate.a
+lib/libolakarate.so
+lib/libolakarate.so.0
+lib/libolakarate.so.0.0.0
+lib/libolakinet.a
+lib/libolakinet.so
+lib/libolakinet.so.0
+lib/libolakinet.so.0.0.0
+lib/libolamilinst.a
+lib/libolamilinst.so
+lib/libolamilinst.so.0
+lib/libolamilinst.so.0.0.0
+lib/libolaopendmx.a
+lib/libolaopendmx.so
+lib/libolaopendmx.so.0
+lib/libolaopendmx.so.0.0.0
+lib/libolaopenpixelcontrol.a
+lib/libolaopenpixelcontrol.so
+lib/libolaopenpixelcontrol.so.0
+lib/libolaopenpixelcontrol.so.0.0.0
+lib/libolapathport.a
+lib/libolapathport.so
+lib/libolapathport.so.0
+lib/libolapathport.so.0.0.0
+lib/libolarenard.a
+lib/libolarenard.so
+lib/libolarenard.so.0
+lib/libolarenard.so.0.0.0
+lib/libolasandnet.a
+lib/libolasandnet.so
+lib/libolasandnet.so.0
+lib/libolasandnet.so.0.0.0
+lib/libolaserver.a
+lib/libolaserver.so
+lib/libolaserver.so.0
+lib/libolaserver.so.0.0.0
+lib/libolaserverplugininterface.a
+lib/libolaserverplugininterface.so
+lib/libolaserverplugininterface.so.0
+lib/libolaserverplugininterface.so.0.0.0
+lib/libolashownet.a
+lib/libolashownet.so
+lib/libolashownet.so.0
+lib/libolashownet.so.0.0.0
+lib/libolastageprofi.a
+lib/libolastageprofi.so
+lib/libolastageprofi.so.0
+lib/libolastageprofi.so.0.0.0
+lib/libolatrigger.a
+lib/libolatrigger.so
+lib/libolatrigger.so.0
+lib/libolatrigger.so.0.0.0
+lib/libolausbdmx.a
+lib/libolausbdmx.so
+lib/libolausbdmx.so.0
+lib/libolausbdmx.so.0.0.0
+lib/libolausbpro.a
+lib/libolausbpro.so
+lib/libolausbpro.so.0
+lib/libolausbpro.so.0.0.0
+lib/libolausbproconf.a
+lib/libolausbproconf.so
+lib/libolausbproconf.so.0
+lib/libolausbproconf.so.0.0.0
+libdata/pkgconfig/libola.pc
+libdata/pkgconfig/libolaartnetconf.pc
+libdata/pkgconfig/libolae131conf.pc
+libdata/pkgconfig/libolaserver.pc
+libdata/pkgconfig/libolausbproconf.pc
+man/man1/logic_rdm_sniffer.1.gz
+man/man1/ola_artnet.1.gz
+man/man1/ola_dev_info.1.gz
+man/man1/ola_dmxconsole.1.gz
+man/man1/ola_dmxmonitor.1.gz
+man/man1/ola_e131.1.gz
+man/man1/ola_patch.1.gz
+man/man1/ola_plugin_info.1.gz
+man/man1/ola_plugin_state.1.gz
+man/man1/ola_rdm_discover.1.gz
+man/man1/ola_rdm_get.1.gz
+man/man1/ola_rdm_set.1.gz
+man/man1/ola_recorder.1.gz
+man/man1/ola_set_dmx.1.gz
+man/man1/ola_set_priority.1.gz
+man/man1/ola_streaming_client.1.gz
+man/man1/ola_timecode.1.gz
+man/man1/ola_trigger.1.gz
+man/man1/ola_uni_info.1.gz
+man/man1/ola_uni_merge.1.gz
+man/man1/ola_uni_name.1.gz
+man/man1/ola_uni_stats.1.gz
+man/man1/ola_usbpro.1.gz
+man/man1/olad.1.gz
+man/man1/rdm_model_collector.py.1.gz
+man/man1/rdm_responder_test.py.1.gz
+man/man1/rdm_test_server.py.1.gz
+man/man1/rdmpro_sniffer.1.gz
+man/man1/usbpro_firmware.1.gz
+%%DATADIR%%/pids/draft_pids.proto
+%%DATADIR%%/pids/manufacturer_pids.proto
+%%DATADIR%%/pids/pids.proto
+%%DATADIR%%d/www/back.png
+%%DATADIR%%d/www/blank.gif
+%%DATADIR%%d/www/button-bg.png
+%%DATADIR%%d/www/console_values.html
+%%DATADIR%%d/www/custombutton.css
+%%DATADIR%%d/www/discovery.png
+%%DATADIR%%d/www/editortoolbar.png
+%%DATADIR%%d/www/expander.png
+%%DATADIR%%d/www/forward.png
+%%DATADIR%%d/www/handle.vertical.png
+%%DATADIR%%d/www/hide_sections.png
+%%DATADIR%%d/www/incremental-discovery.png
+%%DATADIR%%d/www/landing.html
+%%DATADIR%%d/www/light_bulb.png
+%%DATADIR%%d/www/light_bulb_off.png
+%%DATADIR%%d/www/loader-mini.gif
+%%DATADIR%%d/www/loader.gif
+%%DATADIR%%d/www/logo-mini.png
+%%DATADIR%%d/www/logo.png
+%%DATADIR%%d/www/mobile.html
+%%DATADIR%%d/www/mobile.js
+%%DATADIR%%d/www/new/css/style.min.css
+%%DATADIR%%d/www/new/img/light_bulb.png
+%%DATADIR%%d/www/new/img/light_bulb_off.png
+%%DATADIR%%d/www/new/img/logo-mini.png
+%%DATADIR%%d/www/new/img/logo.png
+%%DATADIR%%d/www/new/index.html
+%%DATADIR%%d/www/new/js/app.min.js
+%%DATADIR%%d/www/new/js/app.min.js.map
+%%DATADIR%%d/www/new/libs/angular-route/js/angular-route.min.js
+%%DATADIR%%d/www/new/libs/angular/js/angular.min.js
+%%DATADIR%%d/www/new/libs/bootstrap/css/bootstrap.min.css
+%%DATADIR%%d/www/new/libs/bootstrap/fonts/glyphicons-halflings-regular.eot
+%%DATADIR%%d/www/new/libs/bootstrap/fonts/glyphicons-halflings-regular.svg
+%%DATADIR%%d/www/new/libs/bootstrap/fonts/glyphicons-halflings-regular.ttf
+%%DATADIR%%d/www/new/libs/bootstrap/fonts/glyphicons-halflings-regular.woff
+%%DATADIR%%d/www/new/libs/bootstrap/fonts/glyphicons-halflings-regular.woff2
+%%DATADIR%%d/www/new/libs/bootstrap/js/bootstrap.min.js
+%%DATADIR%%d/www/new/libs/jquery/js/jquery.min.js
+%%DATADIR%%d/www/new/views/overview.html
+%%DATADIR%%d/www/new/views/plugin-info.html
+%%DATADIR%%d/www/new/views/plugins.html
+%%DATADIR%%d/www/new/views/universe-add.html
+%%DATADIR%%d/www/new/views/universe-faders.html
+%%DATADIR%%d/www/new/views/universe-header.html
+%%DATADIR%%d/www/new/views/universe-keypad.html
+%%DATADIR%%d/www/new/views/universe-overview.html
+%%DATADIR%%d/www/new/views/universe-patch.html
+%%DATADIR%%d/www/new/views/universe-rdm.html
+%%DATADIR%%d/www/new/views/universe-settings.html
+%%DATADIR%%d/www/new/views/universes.html
+%%DATADIR%%d/%%WWWDIR%%.html
+%%DATADIR%%d/%%WWWDIR%%.js
+%%DATADIR%%d/www/refresh.png
+%%DATADIR%%d/www/show_sections.png
+%%DATADIR%%d/www/tick.gif
+%%DATADIR%%d/www/toolbar-bg.png
+%%DATADIR%%d/www/toolbar.css
+%%DATADIR%%d/www/toolbar_sprites.png
+%%DATADIR%%d/www/vertical.gif
+%%DATADIR%%d/www/wand.png
+%%DATADIR%%d/www/warning.png