aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-29 23:43:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-30 02:05:06 +0000
commitacb6bfa7fc9a4ce9e16f87fbdd16f2d0b58025c9 (patch)
tree546c6c6758b46b3b9735deca29846ffbb33b2d15 /misc
parent23448134b7b1a512a137991ad9603fcfcf7e6ef3 (diff)
downloadports-acb6bfa7fc9a4ce9e16f87fbdd16f2d0b58025c9.tar.gz
ports-acb6bfa7fc9a4ce9e16f87fbdd16f2d0b58025c9.zip
Diffstat (limited to 'misc')
-rw-r--r--misc/py-onnx/Makefile3
-rw-r--r--misc/py-onnx/distinfo6
-rw-r--r--misc/py-onnx/files/patch-CMakeLists.txt20
-rw-r--r--misc/py-onnx/files/patch-setup.py38
4 files changed, 33 insertions, 34 deletions
diff --git a/misc/py-onnx/Makefile b/misc/py-onnx/Makefile
index 0265b8ad42c4..cd677a82cbb3 100644
--- a/misc/py-onnx/Makefile
+++ b/misc/py-onnx/Makefile
@@ -1,6 +1,5 @@
PORTNAME= onnx
-DISTVERSION= 1.12.0
-PORTREVISION= 1
+DISTVERSION= 1.13.0
CATEGORIES= misc # machine-learning
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/misc/py-onnx/distinfo b/misc/py-onnx/distinfo
index 9625f353abb5..30db3ac69d2e 100644
--- a/misc/py-onnx/distinfo
+++ b/misc/py-onnx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1656109901
-SHA256 (onnx-1.12.0.tar.gz) = 13b3e77d27523b9dbf4f30dfc9c959455859d5e34e921c44f712d69b8369eff9
-SIZE (onnx-1.12.0.tar.gz) = 10112442
+TIMESTAMP = 1672356068
+SHA256 (onnx-1.13.0.tar.gz) = 410b39950367857f97b65093681fe2495a2e23d63777a8aceaf96c56a16d166e
+SIZE (onnx-1.13.0.tar.gz) = 10376857
diff --git a/misc/py-onnx/files/patch-CMakeLists.txt b/misc/py-onnx/files/patch-CMakeLists.txt
index 6273f7b3bb82..61d9f650f002 100644
--- a/misc/py-onnx/files/patch-CMakeLists.txt
+++ b/misc/py-onnx/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt.orig 2022-02-07 19:42:24 UTC
+--- CMakeLists.txt.orig 2022-11-17 13:03:00 UTC
+++ CMakeLists.txt
-@@ -18,7 +18,7 @@ project(onnx C CXX)
- option(ONNX_BUILD_BENCHMARKS "Build ONNX micro-benchmarks" OFF)
- option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag and Protobuf_USE_STATIC_LIBS. " OFF)
-
--option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
-+option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
- option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
- option(ONNX_WERROR "Build with Werror" OFF)
- option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
+@@ -18,7 +18,7 @@ project(onnx C CXX)
+ option(ONNX_BUILD_BENCHMARKS "Build ONNX micro-benchmarks" OFF)
+ option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag and Protobuf_USE_STATIC_LIBS. " OFF)
+
+-option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
++option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
+ option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
+ option(ONNX_WERROR "Build with Werror" OFF)
+ option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
diff --git a/misc/py-onnx/files/patch-setup.py b/misc/py-onnx/files/patch-setup.py
index 36d88911028e..55535f2d925f 100644
--- a/misc/py-onnx/files/patch-setup.py
+++ b/misc/py-onnx/files/patch-setup.py
@@ -1,20 +1,20 @@
---- setup.py.orig 2022-06-15 20:13:03 UTC
+--- setup.py.orig 2022-11-09 10:56:10 UTC
+++ setup.py
-@@ -56,11 +56,12 @@ COVERAGE = bool(os.getenv("COVERAGE", "0") == "1")
- # Version
- ################################################################################
-
--try:
-- git_version = subprocess.check_output(["git", "rev-parse", "HEAD"],
-- cwd=TOP_DIR).decode("ascii").strip()
--except (OSError, subprocess.CalledProcessError):
-- git_version = None
-+#try:
-+# git_version = subprocess.check_output(["git", "rev-parse", "HEAD"],
-+# cwd=TOP_DIR).decode("ascii").strip()
-+#except (OSError, subprocess.CalledProcessError):
-+# git_version = None
-+git_version = None
-
- with open(os.path.join(TOP_DIR, "VERSION_NUMBER")) as version_file:
- VERSION_NUMBER = version_file.read().strip()
+@@ -56,11 +56,12 @@ COVERAGE = bool(os.getenv("COVERAGE", "0") == "1")
+ ################################################################################
+
+ try:
+- git_version = (
+- subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
+- .decode("ascii")
+- .strip()
+- )
++ #git_version = (
++ # subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
++ # .decode("ascii")
++ # .strip()
++ #)
++ git_version = None
+ except (OSError, subprocess.CalledProcessError):
+ git_version = None
+