aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-03-24 13:34:35 +0000
committerRene Ladan <rene@FreeBSD.org>2021-03-24 13:34:35 +0000
commitb217c7fc9cc4e56e26f88b17551499a17c4c6d24 (patch)
tree927d28feccb5a8860ed230fbec099ccb4255ada8 /misc
parent80fa663d16236be2c6d5165f92327ed60b6a4b42 (diff)
downloadports-b217c7fc9cc4e56e26f88b17551499a17c4c6d24.tar.gz
ports-b217c7fc9cc4e56e26f88b17551499a17c4c6d24.zip
Mark ports recursively depending on Python 2.7 for expiration on June 23.
For ports optionally dependending on Python 2.7, just mark those options as expired. Remove konquerer from the x11/kde-baseapps metaport and bump its PORTREVISION. Submitted by: rene Reviewed by: portmgr, adridg, ehaupt, lme, madpilot, pizzamig, se, sunpoet, yuri Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D28665
Notes
Notes: svn path=/head/; revision=569118
Diffstat (limited to 'misc')
-rw-r--r--misc/kdeedu/Makefile7
-rw-r--r--misc/orange3/Makefile3
-rw-r--r--misc/parley/Makefile3
-rw-r--r--misc/py-orange3-associate/Makefile3
-rw-r--r--misc/py-orange3-datafusion/Makefile3
-rw-r--r--misc/py-orange3-educational/Makefile3
-rw-r--r--misc/py-orange3-network/Makefile3
-rw-r--r--misc/py-orange3-timeseries/Makefile3
8 files changed, 28 insertions, 0 deletions
diff --git a/misc/kdeedu/Makefile b/misc/kdeedu/Makefile
index 91f85ae16e21..885e7bc9fc8d 100644
--- a/misc/kdeedu/Makefile
+++ b/misc/kdeedu/Makefile
@@ -72,4 +72,11 @@ ROCS_RUN_DEPENDS= rocs>=${KDE_APPLICATIONS_VERSION}:math/rocs
STEP_DESC= Interactive physics simulator
STEP_RUN_DEPENDS= step>=${KDE_APPLICATIONS_VERSION}:science/step
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPARLEY}
+DEPRECATED= Uses EOL Python 2.7 via misc/parley
+EXPIRATION_DATE=2021-06-23
+.endif
+
.include <bsd.port.mk>
diff --git a/misc/orange3/Makefile b/misc/orange3/Makefile
index 7466138b4b6c..27bb6ddee8e3 100644
--- a/misc/orange3/Makefile
+++ b/misc/orange3/Makefile
@@ -10,6 +10,9 @@ COMMENT= Component-based data mining software
LICENSE= GPLv3
+DEPRECATED= Uses EOL Python 2.7 via www/py-qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}AnyQt>=0.0.8:x11-toolkits/py-AnyQt@${PY_FLAVOR} \
diff --git a/misc/parley/Makefile b/misc/parley/Makefile
index 088e28600ac1..08bd8bd8f29d 100644
--- a/misc/parley/Makefile
+++ b/misc/parley/Makefile
@@ -7,6 +7,9 @@ CATEGORIES= misc education kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Vocabulary trainer for KDE
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-xsl \
docbook-xml>0:textproc/docbook-xml
diff --git a/misc/py-orange3-associate/Makefile b/misc/py-orange3-associate/Makefile
index f190e98d7224..f6cd1140c127 100644
--- a/misc/py-orange3-associate/Makefile
+++ b/misc/py-orange3-associate/Makefile
@@ -10,6 +10,9 @@ COMMENT= Orange 3 add-on: Frequent itemsets and association rules mining
LICENSE= GPLv3+
+DEPRECATED= Uses EOL Python 2.7 via misc/orange3
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
diff --git a/misc/py-orange3-datafusion/Makefile b/misc/py-orange3-datafusion/Makefile
index e46a2b44664a..4ce543a84b3d 100644
--- a/misc/py-orange3-datafusion/Makefile
+++ b/misc/py-orange3-datafusion/Makefile
@@ -13,6 +13,9 @@ COMMENT= Data fusion add-on for Orange3
LICENSE= GPLv3
+DEPRECATED= Uses EOL Python 2.7 via misc/orange3
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYTHON_PKGNAMEPREFIX}scikit-fusion>0:misc/py-scikit-fusion@${PY_FLAVOR}
diff --git a/misc/py-orange3-educational/Makefile b/misc/py-orange3-educational/Makefile
index 1a1321d0b7c0..2a3e516a46d0 100644
--- a/misc/py-orange3-educational/Makefile
+++ b/misc/py-orange3-educational/Makefile
@@ -12,6 +12,9 @@ COMMENT= Orange add-on: widgets for machine learning and data mining
LICENSE= CC-BY-3.0
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Uses EOL Python 2.7 via misc/orange3
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= orange3>0:misc/orange3
USES= python:3.4+
diff --git a/misc/py-orange3-network/Makefile b/misc/py-orange3-network/Makefile
index 6347dfdc2ee2..c4493b7d54ba 100644
--- a/misc/py-orange3-network/Makefile
+++ b/misc/py-orange3-network/Makefile
@@ -11,6 +11,9 @@ COMMENT= Network analysis add-on for Orange data mining suite
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Uses EOL Python 2.7 via misc/orange3
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYNUMPY} \
diff --git a/misc/py-orange3-timeseries/Makefile b/misc/py-orange3-timeseries/Makefile
index c7bffba83afa..979153bbc2ed 100644
--- a/misc/py-orange3-timeseries/Makefile
+++ b/misc/py-orange3-timeseries/Makefile
@@ -11,6 +11,9 @@ COMMENT= Orange add-on for analyzing, visualizing, manipulating time series
LICENSE= CC-BY-3.0
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Uses EOL Python 2.7 via misc/orange3
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= orange3>0:misc/orange3 \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools@${PY_FLAVOR} \