aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-01-10 14:20:12 +0000
committerStefan Eßer <se@FreeBSD.org>2022-01-10 15:15:39 +0000
commitbcaf25a8c8046b094f6b5ab5bc258333bc326ee1 (patch)
tree3930596b8cbea97540270b3d78ffb64373c89593 /misc
parentf1661bdbbac2d08cc535e38e41d2bbd3fec025c4 (diff)
downloadports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.tar.gz
ports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.zip
Diffstat (limited to 'misc')
-rw-r--r--misc/bdelta/Makefile2
-rw-r--r--misc/clpbar/Makefile2
-rw-r--r--misc/concourse/Makefile2
-rw-r--r--misc/cpuid/Makefile2
-rw-r--r--misc/deco/Makefile2
-rw-r--r--misc/gplink/Makefile2
-rw-r--r--misc/hxtools/Makefile2
-rw-r--r--misc/jojodiff/Makefile2
-rw-r--r--misc/lifelines/Makefile2
-rw-r--r--misc/rubygem-dotenv/Makefile2
10 files changed, 20 insertions, 0 deletions
diff --git a/misc/bdelta/Makefile b/misc/bdelta/Makefile
index 00e31f02628a..83f6bc2c5d98 100644
--- a/misc/bdelta/Makefile
+++ b/misc/bdelta/Makefile
@@ -18,6 +18,8 @@ USE_GITHUB= yes
GH_ACCOUNT= jjwhitney
GH_PROJECT= BDelta
+CONFLICTS_INSTALL= bpatch # bin/bpatch
+
PLIST_FILES= bin/bdelta bin/bpatch lib/libbdelta.so
PORTDOCS= README
diff --git a/misc/clpbar/Makefile b/misc/clpbar/Makefile
index 21f492732d3d..8d1108db764d 100644
--- a/misc/clpbar/Makefile
+++ b/misc/clpbar/Makefile
@@ -13,6 +13,8 @@ WRKSRC= ${WRKDIR}/bar-${PORTVERSION}
GNU_CONFIGURE= yes
MAKE_ARGS+= CFLAGS+="${CFLAGS}"
+CONFLICTS_INSTALL= bar # bin/bar
+
PLIST_FILES= bin/bar \
man/man1/bar.1.gz
diff --git a/misc/concourse/Makefile b/misc/concourse/Makefile
index c1672e870e1d..d73573c722e3 100644
--- a/misc/concourse/Makefile
+++ b/misc/concourse/Makefile
@@ -12,6 +12,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
USES= cpe go:modules
USE_GITHUB= yes
+CONFLICTS_INSTALL= concourse-fly fly # bin/fly
+
CPE_VENDOR= pivotal_software
GH_TUPLE= \
diff --git a/misc/cpuid/Makefile b/misc/cpuid/Makefile
index 3569853a8d57..353396d2e3b8 100644
--- a/misc/cpuid/Makefile
+++ b/misc/cpuid/Makefile
@@ -14,4 +14,6 @@ MAKEFILE= ${FILESDIR}/Makefile.bsd
PLIST_FILES= bin/cpuid
ONLY_FOR_ARCHS= i386 amd64
+CONFLICTS_INSTALL= gmap # bin/cpuid
+
.include <bsd.port.mk>
diff --git a/misc/deco/Makefile b/misc/deco/Makefile
index d4b11db6be9b..e1d455c10353 100644
--- a/misc/deco/Makefile
+++ b/misc/deco/Makefile
@@ -15,4 +15,6 @@ USES= ncurses tar:tgz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share
+CONFIGURE_INSTALL= deco # bin/deco
+
.include <bsd.port.mk>
diff --git a/misc/gplink/Makefile b/misc/gplink/Makefile
index e617e96f3080..bbb0b3b9dbef 100644
--- a/misc/gplink/Makefile
+++ b/misc/gplink/Makefile
@@ -20,6 +20,8 @@ MAKE_ARGS= CC="${CC}" \
LDFLAGS+= -lusb
WRKSRC_SUBDIR= src
+CONFLICTS_INSTALL= gputils # bin/gplink
+
PLIST_FILES= bin/gplink
do-install:
diff --git a/misc/hxtools/Makefile b/misc/hxtools/Makefile
index 1cd440127c53..12c48f93ffeb 100644
--- a/misc/hxtools/Makefile
+++ b/misc/hxtools/Makefile
@@ -34,6 +34,8 @@ SHEBANG_FILES= data/hxtools_bashrc.bash data/hxtools_profile.bash \
USE_PERL5= run
USE_XORG= xcb
+CONFLICTS_INSTALL= grx psptoolchain-pspsdk-stage2 # bin/bin2c
+
OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
diff --git a/misc/jojodiff/Makefile b/misc/jojodiff/Makefile
index 609fb17e98f8..c1ce17e40509 100644
--- a/misc/jojodiff/Makefile
+++ b/misc/jojodiff/Makefile
@@ -15,6 +15,8 @@ USES= gmake tar:tgz
MAKE_ARGS= CC="${CC}" CPP="${CXX}" CFLAGS="${CFLAGS}"
WRKSRC_SUBDIR= src
+CONFLICTS_INSTALL= py*-jsondiff # bin/jdiff
+
PLIST_FILES= bin/jdiff bin/jptch
PORTDOCS= readme.txt readme.htm
diff --git a/misc/lifelines/Makefile b/misc/lifelines/Makefile
index 0b2b970e35da..79ddf7ee0045 100644
--- a/misc/lifelines/Makefile
+++ b/misc/lifelines/Makefile
@@ -16,6 +16,8 @@ USES= autoreconf bison gmake iconv ncurses
GNU_CONFIGURE= yes
CONFIGURE_ENV= YACC="bison -y"
+CONFLICTS_INSTALL= atheme-services # bin/dbverify
+
MAKE_JOBS_UNSAFE=yes
# Lifelines always installs documenatation. This is contrary to the FreeBSD
diff --git a/misc/rubygem-dotenv/Makefile b/misc/rubygem-dotenv/Makefile
index a5f7da598018..0519ac95f125 100644
--- a/misc/rubygem-dotenv/Makefile
+++ b/misc/rubygem-dotenv/Makefile
@@ -14,6 +14,8 @@ USE_RUBY= yes
NO_ARCH= yes
+CONFLICTS_INSTALL= py*-python-dotenv # bin/dotenv
+
PLIST_FILES= bin/dotenv
.include <bsd.port.mk>