aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-08-04 08:58:17 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-08-04 08:58:17 +0000
commitd2eb5db2f84500ce5baf44bacd4187d8fe2be686 (patch)
tree32de3ebefeb124b4b5f890373e4288855b0d25e5 /misc
parent858030803a4629e8f222914c20e0aef539a19cc3 (diff)
downloadports-d2eb5db2f84500ce5baf44bacd4187d8fe2be686.tar.gz
ports-d2eb5db2f84500ce5baf44bacd4187d8fe2be686.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-pyfiglet/Makefile21
-rw-r--r--misc/py-pyfiglet/distinfo3
-rw-r--r--misc/py-pyfiglet/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index fa5faf1a4519..530097987960 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -374,6 +374,7 @@
SUBDIR += py-osd
SUBDIR += py-pexpect
SUBDIR += py-powerline-status
+ SUBDIR += py-pyfiglet
SUBDIR += py-pyprind
SUBDIR += py-progressbar
SUBDIR += py-progressbar231
diff --git a/misc/py-pyfiglet/Makefile b/misc/py-pyfiglet/Makefile
new file mode 100644
index 000000000000..482b1bd66186
--- /dev/null
+++ b/misc/py-pyfiglet/Makefile
@@ -0,0 +1,21 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyfiglet
+PORTVERSION= 0.7.5
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Pure-python FIGlet implementation
+
+LICENSE= GPLv2+
+
+# Actually 2.6-2.7,3.1-3.5 (no 3.0)
+USES= python:2.6-3.5
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-pyfiglet/distinfo b/misc/py-pyfiglet/distinfo
new file mode 100644
index 000000000000..4dc7bb65145f
--- /dev/null
+++ b/misc/py-pyfiglet/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470300341
+SHA256 (pyfiglet-0.7.5.tar.gz) = 446194e1fc3257ffc8024eafd3b486394847597f6210278d76bd582850205e12
+SIZE (pyfiglet-0.7.5.tar.gz) = 767904
diff --git a/misc/py-pyfiglet/pkg-descr b/misc/py-pyfiglet/pkg-descr
new file mode 100644
index 000000000000..f3ae36b47330
--- /dev/null
+++ b/misc/py-pyfiglet/pkg-descr
@@ -0,0 +1,4 @@
+pyfiglet is a full port of FIGlet (WWW: http://www.figlet.org/) into
+pure python. It takes ASCII text and renders it in ASCII art fonts.
+
+WWW: https://github.com/pwaller/pyfiglet