aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-20 03:09:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-20 03:28:20 +0000
commite6d92cff83d721087244b2a555abf8d56134cc1b (patch)
tree9223516c27da123a434a6a72591f84383e9cc328 /misc
parent11de76215b12111e638531a260d274a9780552da (diff)
downloadports-e6d92cff83d721087244b2a555abf8d56134cc1b.tar.gz
ports-e6d92cff83d721087244b2a555abf8d56134cc1b.zip
misc/vfc: New port: Library and tool for converting vertex formats
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/vfc/Makefile24
-rw-r--r--misc/vfc/distinfo9
-rw-r--r--misc/vfc/pkg-descr9
-rw-r--r--misc/vfc/pkg-plist13
5 files changed, 56 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index a089b457f8d8..cf04b78ec664 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -528,6 +528,7 @@
SUBDIR += vdmfec
SUBDIR += veles
SUBDIR += vera
+ SUBDIR += vfc
SUBDIR += vifm
SUBDIR += visp
SUBDIR += viz
diff --git a/misc/vfc/Makefile b/misc/vfc/Makefile
new file mode 100644
index 000000000000..0311358c90dd
--- /dev/null
+++ b/misc/vfc/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= vfc
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.3
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library and tool for converting vertex formats
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= cmake:testing compiler:c++11-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= akb825
+GH_PROJECT= VertexFormatConvert
+GH_TUPLE= g-truc:glm:bf71a834948186f4097caa076cd2663c69a10e1e:g_truc_glm/lib/glm \
+ Tencent:rapidjson:232389d4f1012dddec4ef84861face2d2ba85709:Tencent_rapidjson/tool/rapidjson \
+ google:googletest:ba96d0b1161f540656efdaed035b3c062b60e006:google_googletest/tool/rapidjson/thirdparty/gtest
+
+CMAKE_OFF= VFC_BUILD_TESTS
+CMAKE_TESTING_ON= VFC_BUILD_TESTS
+
+.include <bsd.port.mk>
diff --git a/misc/vfc/distinfo b/misc/vfc/distinfo
new file mode 100644
index 000000000000..2a017d4065a5
--- /dev/null
+++ b/misc/vfc/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1655694285
+SHA256 (akb825-VertexFormatConvert-v2.0.3_GH0.tar.gz) = 52fdd10d0a8627562a12dfc24102ee155d23cdc979ff8dffb04f248708326a15
+SIZE (akb825-VertexFormatConvert-v2.0.3_GH0.tar.gz) = 83723
+SHA256 (g-truc-glm-bf71a834948186f4097caa076cd2663c69a10e1e_GH0.tar.gz) = 70ad78e872c145f0164d54da833b651914c184edc65958906937b9739fb8fb1b
+SIZE (g-truc-glm-bf71a834948186f4097caa076cd2663c69a10e1e_GH0.tar.gz) = 4369431
+SHA256 (Tencent-rapidjson-232389d4f1012dddec4ef84861face2d2ba85709_GH0.tar.gz) = b9290a9a6d444c8e049bd589ab804e0ccf2b05dc5984a19ed5ae75d090064806
+SIZE (Tencent-rapidjson-232389d4f1012dddec4ef84861face2d2ba85709_GH0.tar.gz) = 1107967
+SHA256 (google-googletest-ba96d0b1161f540656efdaed035b3c062b60e006_GH0.tar.gz) = 949c556896cf31ed52e53449e17a1276b8b26d3ee5932f5ca49ee929f4b35c51
+SIZE (google-googletest-ba96d0b1161f540656efdaed035b3c062b60e006_GH0.tar.gz) = 987370
diff --git a/misc/vfc/pkg-descr b/misc/vfc/pkg-descr
new file mode 100644
index 000000000000..bd56a703b8da
--- /dev/null
+++ b/misc/vfc/pkg-descr
@@ -0,0 +1,9 @@
+Vertex Format Convert (VFC) is a simple library and utility for
+converting vertex formats. This is intended to aid in converting from
+raw model formats, such as from interchange formats (e.g. OBJ,
+COLLADA), into formats that are suitable for usage at runtime. This
+may include interleaving vertex data, re-mapping indices (e.g. from
+separate indices to a single combined index), and converting to packed
+formats.
+
+WWW: https://github.com/akb825/VertexFormatConvert
diff --git a/misc/vfc/pkg-plist b/misc/vfc/pkg-plist
new file mode 100644
index 000000000000..c3f53bbf660e
--- /dev/null
+++ b/misc/vfc/pkg-plist
@@ -0,0 +1,13 @@
+bin/vfc
+include/VFC/Config.h
+include/VFC/Converter.h
+include/VFC/Export.h
+include/VFC/IndexData.h
+include/VFC/VertexFormat.h
+include/VFC/VertexValue.h
+lib/cmake/VFC/VFCConfig.cmake
+lib/cmake/VFC/VFCConfigVersion.cmake
+lib/cmake/VFC/VFCTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/VFC/VFCTargets.cmake
+lib/libvfc.so
+lib/libvfc.so.2.0.3