aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-10-19 14:01:17 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-10-19 14:01:17 +0000
commitf0710f6344c608cd1db4a20456f962d3e1514fa0 (patch)
treef25cb68e804743bfd068527db69b069fe1109b86 /misc
parent47737236d5251a04b8aea3070ccad141ce650178 (diff)
downloadports-f0710f6344c608cd1db4a20456f962d3e1514fa0.tar.gz
ports-f0710f6344c608cd1db4a20456f962d3e1514fa0.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/qhacc/Makefile12
-rw-r--r--misc/qhacc/distinfo2
-rw-r--r--misc/qhacc/files/patch-aa16
-rw-r--r--misc/qhacc/files/patch-ab29
4 files changed, 11 insertions, 48 deletions
diff --git a/misc/qhacc/Makefile b/misc/qhacc/Makefile
index 078515bb32ad..47ea63561449 100644
--- a/misc/qhacc/Makefile
+++ b/misc/qhacc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qhacc
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.ostrich-emulators.cx/qhacc/
@@ -17,11 +17,19 @@ MAINTAINER= ports@FreeBSD.org
USE_QT_VER= 2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= QTDIR="${X11BASE}"
+CONFIGURE_ARGS= --with-qt-moc=${X11BASE}/bin \
+ --with-qt-libs=${X11BASE}/lib
post-extract:
@${RM} -f ${WRKSRC}/src/moc_*.cpp
+pre-patch:
+.for file in configure src/Makefile.in
+ @${PERL} -pi -e 's|/moc|/${MOC:T}|g ; \
+ s|-lqt|-l${QTNAME}|g ; \
+ s|-O2 -Wall|\@CXXFLAGS\@|g' ${WRKSRC}/${file}
+.endfor
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/qhacc ${PREFIX}/bin
@${MKDIR} ${DATADIR}
diff --git a/misc/qhacc/distinfo b/misc/qhacc/distinfo
index 83a04d71e359..38148aa689cf 100644
--- a/misc/qhacc/distinfo
+++ b/misc/qhacc/distinfo
@@ -1 +1 @@
-MD5 (qhacc-1.0.tar.gz) = e695e4421aca690fa29e38e90a1ec96f
+MD5 (qhacc-1.1.tar.gz) = 53a3b31a236c8fd43b690e0f275fd5bf
diff --git a/misc/qhacc/files/patch-aa b/misc/qhacc/files/patch-aa
deleted file mode 100644
index 42220fef60cf..000000000000
--- a/misc/qhacc/files/patch-aa
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/Makefile.in.orig Wed Nov 15 04:44:04 2000
-+++ src/Makefile.in Wed Nov 15 05:01:56 2000
-@@ -85,10 +85,10 @@
- INCLUDES = $(all_includes) -I$(QTINCDIR)
- LDFLAGS =
- qhacc_LDFLAGS = -L$(QTLIBDIR) $(LDFLAGS)
--qhacc_LDADD = -lqt
--MOC = $(QTMOCDIR)/moc
-+qhacc_LDADD = -lqt2
-+MOC = $(QTMOCDIR)/moc2
-
--CXXFLAGS = -O2 -Wall $(MYFLAGS)
-+CXXFLAGS = @CXXFLAGS@ $(MYFLAGS)
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
- CONFIG_CLEAN_FILES =
diff --git a/misc/qhacc/files/patch-ab b/misc/qhacc/files/patch-ab
deleted file mode 100644
index 57dadabd97ec..000000000000
--- a/misc/qhacc/files/patch-ab
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.orig Tue Aug 14 01:21:28 2001
-+++ configure Sat Aug 18 23:45:43 2001
-@@ -2197,7 +2197,7 @@
-
- for dir in $with_qt_moc
- do
-- if test -f $dir/moc
-+ if test -f $dir/moc2
- then
- qtmoc=$dir
- echo "found in $qtmoc"
-@@ -2231,7 +2231,7 @@
-
- for dir in $with_qt_libs
- do
-- if test -f $dir/libqt.so.2 -o "$dir/libqt.so.2.*" != "$dir/libqt.so.2.\*"
-+ if test -f $dir/libqt.so
- then
- qtlibs=$dir
- echo "found in $qtlibs"
-@@ -2265,7 +2265,7 @@
-
- for dir in $with_qt_incs
- do
-- if test -f $dir/qnamespace.h
-+ if test -f $dir/qt2/qnamespace.h
- then
- qtincs=$dir
- echo "found in $qtincs"