aboutsummaryrefslogtreecommitdiff
path: root/multimedia/arcan
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-02 22:07:09 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-03-02 22:07:09 +0000
commit015f1a3d1dfef4d27a798bd2bdbec3176260d778 (patch)
treed08aa736506ff147d01c1364cb04116248458c34 /multimedia/arcan
parent5923636a889f00726f5f28615eb7035e1e8fceff (diff)
downloadports-015f1a3d1dfef4d27a798bd2bdbec3176260d778.tar.gz
ports-015f1a3d1dfef4d27a798bd2bdbec3176260d778.zip
multimedia/arcan: use luajit-openresty on all architectures
lang/luajit hasn't been updated in years. Alpine, Debian, Fedora, Gentoo, Guix, Mageia, Nix, Void updated to 2.1.0 beta3 or snapshot. Of those Guix and Void have Arcan package. So, switch to 2.1 as well for better stability and non-x86 support. https://github.com/letoram/arcan/commit/b1290c6485db
Notes
Notes: svn path=/head/; revision=566992
Diffstat (limited to 'multimedia/arcan')
-rw-r--r--multimedia/arcan/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/multimedia/arcan/Makefile b/multimedia/arcan/Makefile
index 2ec70d79cdea..a0e5a0719b1f 100644
--- a/multimedia/arcan/Makefile
+++ b/multimedia/arcan/Makefile
@@ -2,7 +2,7 @@
PORTNAME= arcan
DISTVERSION= 0.6.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -35,7 +35,6 @@ LDFLAGS_i386= -Wl,-z,notext
OPTIONS_DEFINE= ESPEAK FFMPEG LUAJIT SDL SUID TESSERACT UVC VLC VNC WAYLAND
OPTIONS_DEFAULT=ESPEAK FFMPEG LUAJIT SDL SUID TESSERACT UVC VLC VNC WAYLAND
-OPTIONS_EXCLUDE_aarch64= LUAJIT # bug 225342
OPTIONS_SUB= yes
ESPEAK_DESC= Text to speech via eSpeak
@@ -44,7 +43,7 @@ ESPEAK_LIB_DEPENDS= libespeak.so:audio/espeak
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
LUAJIT_DESC= Use LuaJIT instead of standard Lua
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
LUAJIT_USES_OFF= lua:51
LUAJIT_CMAKE_BOOL_OFF= DISABLE_JIT
@@ -78,12 +77,6 @@ WAYLAND_USES= xorg
WAYLAND_USE= XORG=xcb
WAYLAND_CMAKE_BOOL_OFF= DISABLE_WAYLAND
-.include <bsd.port.options.mk>
-
-.if ${ARCH:Mpowerpc64*}
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
-.endif
-
post-patch:
@${REINPLACE_CMD} -i.prefix 's,/usr/local,${PREFIX},g' \
${WRKSRC:H}/doc/${PORTNAME}.1 \