aboutsummaryrefslogtreecommitdiff
path: root/multimedia/avidemux/Makefile.common
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:07:22 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:07:22 +0000
commit82f108df3064ff3c1a1e2286a12f648d68dae4cd (patch)
treeb4d5bf951a26d05982f5c0f534d2f244ff41ae41 /multimedia/avidemux/Makefile.common
parent7be404eb3fcc6b1994712ba54ceb56f81ab474e5 (diff)
downloadports-82f108df3064ff3c1a1e2286a12f648d68dae4cd.tar.gz
ports-82f108df3064ff3c1a1e2286a12f648d68dae4cd.zip
Notes
Diffstat (limited to 'multimedia/avidemux/Makefile.common')
-rw-r--r--multimedia/avidemux/Makefile.common4
1 files changed, 3 insertions, 1 deletions
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index 0d62ef905b69..7c3eda6992f8 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -17,7 +17,7 @@ USE_GNOME= libxml2
OPTIONS_FILE= ${PORT_DBDIR}/${OPTIONS_NAME:C/-.*//}/options
-USES= cmake:noninja pkgconfig iconv gmake compiler:features sqlite
+USES= cmake:noninja pkgconfig iconv gmake gnome compiler:features sqlite
USES+= dos2unix
DOS2UNIX_FILES= cmake/admCheckMiscLibs.cmake \
avidemux_core/ADM_coreVideoCodec/include/ADM_coreVideoCodec6_export.h \
@@ -137,6 +137,7 @@ CMAKE_ARGS+= -DFONTCONFIG:BOOL=OFF
.if ${PORT_OPTIONS:MXVIDEO}
#LIB_DEPENDS+= Xv:x11/libXv
+USES+= xorg
USE_XORG+= xv
.else
CMAKE_ARGS+= -DXVIDEO:BOOL=OFF
@@ -199,6 +200,7 @@ PLIST_SUB+= XVID="@comment "
.endif
.if ${PORT_OPTIONS:MSDL}
+USES+= sdl
USE_SDL= sdl
PLIST_SUB+= SDL=""
.else