aboutsummaryrefslogtreecommitdiff
path: root/multimedia/avidemux
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /multimedia/avidemux
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'multimedia/avidemux')
-rw-r--r--multimedia/avidemux/Makefile.common4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index da6af75fad01..91a2fc77f5ce 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -14,7 +14,6 @@ LIB_DEPENDS+= libmad.so:audio/libmad \
LICENSE= GPLv2
USE_GNOME= libxml2
-USE_QT4= # empty
OPTIONS_FILE= ${PORT_DBDIR}/${OPTIONS_NAME:C/-.*//}/options
@@ -96,7 +95,8 @@ PLIST_SUB+= GTK="@comment "
.endif
.if ${PORT_OPTIONS:MQT4}
-USE_QT4= qmake_build moc_build rcc_build uic_build linguist_build gui
+USES+= qt:4
+USE_QT= qmake_build moc_build rcc_build uic_build linguist_build gui
PLIST_SUB+= QT4=""
.else
CMAKE_ARGS+= -DQT4:BOOL=OFF