aboutsummaryrefslogtreecommitdiff
path: root/multimedia/bino
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-03-29 21:39:25 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-03-29 21:39:25 +0000
commit8e5546312249cec7a18e79b54bb72e17ab958bcd (patch)
tree148f50e2ea109388a825400e26b29cbf2fd2d270 /multimedia/bino
parent390da21310c0edb0870b92ec7f2c5aef7037e6be (diff)
downloadports-8e5546312249cec7a18e79b54bb72e17ab958bcd.tar.gz
ports-8e5546312249cec7a18e79b54bb72e17ab958bcd.zip
Bino is a video player with the following main features:
Support for stereoscopic 3D video, with a wide variety of input and output formats. Support for multi-display video, e.g. for powerwalls, Virtual Reality installations and other multi-projector setups. WWW: http://bino3d.org/ PR: ports/166389 Submitted by: Mykola Dzham <i@levsha.me> Feature safe: yes
Notes
Notes: svn path=/head/; revision=293974
Diffstat (limited to 'multimedia/bino')
-rw-r--r--multimedia/bino/Makefile50
-rw-r--r--multimedia/bino/distinfo2
-rw-r--r--multimedia/bino/pkg-descr7
-rw-r--r--multimedia/bino/pkg-plist61
4 files changed, 120 insertions, 0 deletions
diff --git a/multimedia/bino/Makefile b/multimedia/bino/Makefile
new file mode 100644
index 000000000000..a3807ac0d8b5
--- /dev/null
+++ b/multimedia/bino/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: bino
+# Date created: 2012-03-12
+# Whom: Mykola Dzham <i@levsha.me>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bino
+PORTVERSION= 1.2.1
+CATEGORIES= multimedia
+MASTER_SITES= http://download.savannah.nongnu.org/releases/bino/ http://levsha.me/ports/distfiles/
+
+MAINTAINER= i@levsha.me
+COMMENT= 3D video player with multi-display support
+
+LICENSE= GPLv3
+
+FETCH_ARGS= -Fpr
+USE_XZ= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_ICONS= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build opengl rcc_build
+
+# no port fow equalizer now, lirc detecting not working
+CONFIGURE_ARGS+= --without-equalizer --without-liblircclient --docdir=${DOCSDIR}
+
+LIB_DEPENDS+= ass.5:${PORTSDIR}/multimedia/libass \
+ avformat.1:${PORTSDIR}/multimedia/ffmpeg \
+ GLEW.1:${PORTSDIR}/graphics/glew \
+ openal.1:${PORTSDIR}/audio/openal-soft
+
+MAN1= bino.1
+INFO= bino
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+# fixes build on non UTF-8 enviroments
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo $<|LANG=C; LC_ALL=C; &|' \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/multimedia/bino/distinfo b/multimedia/bino/distinfo
new file mode 100644
index 000000000000..43e20a10dfa5
--- /dev/null
+++ b/multimedia/bino/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bino-1.2.1.tar.xz) = 2573ba0c0f8ae1f2cb8f7ecb5ac311146ac2759b52087bf6c8580942054458d0
+SIZE (bino-1.2.1.tar.xz) = 714608
diff --git a/multimedia/bino/pkg-descr b/multimedia/bino/pkg-descr
new file mode 100644
index 000000000000..3019686517b9
--- /dev/null
+++ b/multimedia/bino/pkg-descr
@@ -0,0 +1,7 @@
+Bino is a video player with the following main features:
+Support for stereoscopic 3D video, with a wide variety of input and output
+formats.
+Support for multi-display video, e.g. for powerwalls, Virtual Reality
+installations and other multi-projector setups.
+
+WWW: http://bino3d.org/
diff --git a/multimedia/bino/pkg-plist b/multimedia/bino/pkg-plist
new file mode 100644
index 000000000000..a5de4d7b3cc9
--- /dev/null
+++ b/multimedia/bino/pkg-plist
@@ -0,0 +1,61 @@
+@comment $FreeBSD$
+bin/bino
+share/applications/bino.desktop
+@dirrmtry share/applications
+%%DOCSDIR%%/bino.html
+%%DOCSDIR%%/multi-display-vrlab.jpg
+%%DOCSDIR%%/multi-display-rotated.jpg
+%%DOCSDIR%%/gamma-pattern-tb.png
+%%DOCSDIR%%/crosstalk-pattern-tb.png
+%%DOCSDIR%%/input-layout-mono.png
+%%DOCSDIR%%/input-layout-separate-left-right.png
+%%DOCSDIR%%/input-layout-separate-right-left.png
+%%DOCSDIR%%/input-layout-top-bottom.png
+%%DOCSDIR%%/input-layout-top-bottom-half.png
+%%DOCSDIR%%/input-layout-bottom-top.png
+%%DOCSDIR%%/input-layout-bottom-top-half.png
+%%DOCSDIR%%/input-layout-left-right.png
+%%DOCSDIR%%/input-layout-left-right-half.png
+%%DOCSDIR%%/input-layout-right-left.png
+%%DOCSDIR%%/input-layout-right-left-half.png
+%%DOCSDIR%%/input-layout-even-odd-rows.png
+%%DOCSDIR%%/input-layout-odd-even-rows.png
+%%DOCSDIR%%/output-type-mono-left.png
+%%DOCSDIR%%/output-type-mono-right.png
+%%DOCSDIR%%/output-type-top-bottom.png
+%%DOCSDIR%%/output-type-top-bottom-half.png
+%%DOCSDIR%%/output-type-left-right.png
+%%DOCSDIR%%/output-type-left-right-half.png
+%%DOCSDIR%%/output-type-even-odd-rows.png
+%%DOCSDIR%%/output-type-even-odd-columns.png
+%%DOCSDIR%%/output-type-checkerboard.png
+%%DOCSDIR%%/output-type-hdmi-frame-pack.png
+%%DOCSDIR%%/output-type-red-cyan.png
+%%DOCSDIR%%/output-type-green-magenta.png
+%%DOCSDIR%%/output-type-amber-blue.png
+%%DOCSDIR%%/output-type-red-green.png
+%%DOCSDIR%%/output-type-red-blue.png
+%%DOCSDIR%%/output-type-stereo.png
+@dirrm %%DOCSDIR%%
+share/icons/hicolor/16x16/apps/bino.png
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+share/icons/hicolor/32x32/apps/bino.png
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+share/icons/hicolor/48x48/apps/bino.png
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+share/icons/hicolor/64x64/apps/bino.png
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+share/icons/hicolor/scalable/apps/bino.svg
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+%%NLS%%share/locale/cs/LC_MESSAGES/bino.mo
+%%NLS%%share/locale/de/LC_MESSAGES/bino.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/bino.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/bino.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/bino.mo