aboutsummaryrefslogtreecommitdiff
path: root/multimedia/bino
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-04 11:39:58 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-04 11:39:58 +0000
commiteff5b4acdcb7f41fa7d5d394bf262fae44c0fd1f (patch)
tree7ff5b1916334aef23f273e4f4ad9f4cba08e0411 /multimedia/bino
parent53d8ac01d84edd0d04fb54366f3d07d7e0993bcf (diff)
downloadports-eff5b4acdcb7f41fa7d5d394bf262fae44c0fd1f.tar.gz
ports-eff5b4acdcb7f41fa7d5d394bf262fae44c0fd1f.zip
multimedia/bino: unbreak with ffmpeg 4.0
media_object.cpp:908:60: error: use of undeclared identifier 'CODEC_CAP_DR1' if (lowres || (codec && (codec->capabilities & CODEC_CAP_DR1))) ^ media_object.cpp:909:37: error: use of undeclared identifier 'CODEC_FLAG_EMU_EDGE' codec_ctx->flags |= CODEC_FLAG_EMU_EDGE; ^ PR: 227726 Reported by: antoine (via exp-run)
Notes
Notes: svn path=/head/; revision=469015
Diffstat (limited to 'multimedia/bino')
-rw-r--r--multimedia/bino/Makefile2
-rw-r--r--multimedia/bino/files/patch-src_media__object.cpp20
2 files changed, 20 insertions, 2 deletions
diff --git a/multimedia/bino/Makefile b/multimedia/bino/Makefile
index f22b1023247b..8e93d605cfe8 100644
--- a/multimedia/bino/Makefile
+++ b/multimedia/bino/Makefile
@@ -13,8 +13,6 @@ COMMENT= 3D video player with multi-display support
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= fails to build with ffmpeg 4.0
-
LIB_DEPENDS= libass.so:multimedia/libass \
libavformat.so:multimedia/ffmpeg \
libopenal.so:audio/openal-soft
diff --git a/multimedia/bino/files/patch-src_media__object.cpp b/multimedia/bino/files/patch-src_media__object.cpp
new file mode 100644
index 000000000000..09f2d2d59a76
--- /dev/null
+++ b/multimedia/bino/files/patch-src_media__object.cpp
@@ -0,0 +1,20 @@
+media_object.cpp:908:60: error: use of undeclared identifier 'CODEC_CAP_DR1'
+ if (lowres || (codec && (codec->capabilities & CODEC_CAP_DR1)))
+ ^
+media_object.cpp:909:37: error: use of undeclared identifier 'CODEC_FLAG_EMU_EDGE'
+ codec_ctx->flags |= CODEC_FLAG_EMU_EDGE;
+ ^
+
+--- src/media_object.cpp.orig 2016-11-30 19:18:54 UTC
++++ src/media_object.cpp
+@@ -905,8 +905,10 @@ void media_object::open(const std::string &url, const
+ #ifdef FF_API_LOWRES
+ lowres = codec_ctx->lowres;
+ #endif
++#ifdef FF_API_EMU_EDGE
+ if (lowres || (codec && (codec->capabilities & CODEC_CAP_DR1)))
+ codec_ctx->flags |= CODEC_FLAG_EMU_EDGE;
++#endif
+ }
+ // Find and open the codec. AV_CODEC_ID_TEXT is a special case: it has no decoder since it is unencoded raw data.
+ if (codec_ctx->codec_id != AV_CODEC_ID_TEXT && (!codec || (e = avcodec_open2(codec_ctx, codec, NULL)) < 0))