aboutsummaryrefslogtreecommitdiff
path: root/multimedia/blind
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-01-29 19:21:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-01-29 19:21:21 +0000
commitff2dd81377243bd8e3e577d182eae91f3190b70a (patch)
tree93cf823f57edb7574dc75dc01064e0c884c79e9c /multimedia/blind
parent11049b769a310f40ea9d58c0aa26e5f18659891d (diff)
downloadports-ff2dd81377243bd8e3e577d182eae91f3190b70a.tar.gz
ports-ff2dd81377243bd8e3e577d182eae91f3190b70a.zip
New port: multimedia/blind: Collection of command line video editing utilities
A minimalistic project from the suckless team: https://tools.suckless.org/blind/ Submitted by: myself Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D14099
Notes
Notes: svn path=/head/; revision=460326
Diffstat (limited to 'multimedia/blind')
-rw-r--r--multimedia/blind/Makefile19
-rw-r--r--multimedia/blind/distinfo3
-rw-r--r--multimedia/blind/files/patch-config.mk18
-rw-r--r--multimedia/blind/files/patch-src_blind-split.c14
-rw-r--r--multimedia/blind/pkg-descr13
-rw-r--r--multimedia/blind/pkg-plist76
6 files changed, 143 insertions, 0 deletions
diff --git a/multimedia/blind/Makefile b/multimedia/blind/Makefile
new file mode 100644
index 000000000000..62d75535b44a
--- /dev/null
+++ b/multimedia/blind/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= blind
+DISTVERSION= 1.1
+CATEGORIES= multimedia
+MASTER_SITES= https://dl.suckless.org/tools/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Collection of command line video editing utilities
+
+LICENSE= ISC
+LICENSE_GROUPS= FSF GPL OSI
+LICENSE_NAME= ISC License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= gmake # because of a bug in the makefiles: suckless is supposed to have POSIX makefiles
+
+.include <bsd.port.mk>
diff --git a/multimedia/blind/distinfo b/multimedia/blind/distinfo
new file mode 100644
index 000000000000..a2309c2970b9
--- /dev/null
+++ b/multimedia/blind/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517173257
+SHA256 (blind-1.1.tar.gz) = 24f903ccb5e118d75f38d3ae0d85fed909749f978bff47ff6973ee1bfddfcc5a
+SIZE (blind-1.1.tar.gz) = 47568
diff --git a/multimedia/blind/files/patch-config.mk b/multimedia/blind/files/patch-config.mk
new file mode 100644
index 000000000000..151f56a4b067
--- /dev/null
+++ b/multimedia/blind/files/patch-config.mk
@@ -0,0 +1,18 @@
+--- config.mk.orig 2017-05-06 11:27:39 UTC
++++ config.mk
+@@ -2,10 +2,10 @@
+ VERSION = 1.1
+
+ # Paths
+-PREFIX = /usr/local
+-MANPREFIX = $(PREFIX)/share/man
++PREFIX ?= /usr/local
++MANPREFIX = $(PREFIX)/man
+
+ # You may want to remove -DHAVE_PRCTL and -DHAVE_EPOLL from CPPFLAGS if you are not using Linux.
+-CFLAGS = -std=c99 -Wall -pedantic -O2
+-CPPFLAGS = -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE=700 -D_FILE_OFFSET_BITS=64 -DHAVE_PRCTL -DHAVE_EPOLL
+-LDFLAGS = -lm -s
++CFLAGS += -std=c99 -Wall -pedantic
++CPPFLAGS += -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_FILE_OFFSET_BITS=64
++LDFLAGS += -lm -lc -s
diff --git a/multimedia/blind/files/patch-src_blind-split.c b/multimedia/blind/files/patch-src_blind-split.c
new file mode 100644
index 000000000000..c3f8fe21186a
--- /dev/null
+++ b/multimedia/blind/files/patch-src_blind-split.c
@@ -0,0 +1,14 @@
+--- src/blind-split.c.orig 2017-05-06 11:27:39 UTC
++++ src/blind-split.c
+@@ -2,7 +2,11 @@
+ #include "stream.h"
+ #include "util.h"
+
++#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
++#include <stdlib.h>
++#else
+ #include <alloca.h>
++#endif
+ #include <fcntl.h>
+ #include <inttypes.h>
+ #include <limits.h>
diff --git a/multimedia/blind/pkg-descr b/multimedia/blind/pkg-descr
new file mode 100644
index 000000000000..5e9e2561d52b
--- /dev/null
+++ b/multimedia/blind/pkg-descr
@@ -0,0 +1,13 @@
+blind uses a raw video format with a simple container. A file begins with
+an plain-text line, containing the number of frames, the width, the height,
+and the pixel format, all separated by a single regular blank space, without
+and leading or tailing white space. After this line, which ends with an LF,
+there is a NUL-byte followed by the 4 characters "uivf" (unportable, interim
+video format). This head is followed by the video frame-by-frame with row-major
+frames. Pixels are independently encoded, and are encoded unscaled CIE XYZ with
+non-premultiplied alpha and without any transfer-function, with values stored
+in native doubles or optionally in native floats. These two configurations are
+the only options, but the container format is designed so this can be changed
+arbitrarily in the future.
+
+WWW: https://tools.suckless.org/blind/
diff --git a/multimedia/blind/pkg-plist b/multimedia/blind/pkg-plist
new file mode 100644
index 000000000000..a68770c883b3
--- /dev/null
+++ b/multimedia/blind/pkg-plist
@@ -0,0 +1,76 @@
+bin/blind-arithm
+bin/blind-colour-ciexyz
+bin/blind-colour-srgb
+bin/blind-compress
+bin/blind-concat
+bin/blind-crop
+bin/blind-cut
+bin/blind-decompress
+bin/blind-dissolve
+bin/blind-extend
+bin/blind-flip
+bin/blind-flop
+bin/blind-from-image
+bin/blind-from-text
+bin/blind-from-video
+bin/blind-gauss-blur
+bin/blind-invert-luma
+bin/blind-next-frame
+bin/blind-read-head
+bin/blind-repeat
+bin/blind-reverse
+bin/blind-rewrite-head
+bin/blind-set-alpha
+bin/blind-set-luma
+bin/blind-set-saturation
+bin/blind-single-colour
+bin/blind-skip-pattern
+bin/blind-split
+bin/blind-stack
+bin/blind-time-blur
+bin/blind-to-image
+bin/blind-to-text
+bin/blind-to-video
+bin/blind-translate
+bin/blind-transpose
+bin/blind-write-head
+man/man1/blind-arithm.1.gz
+man/man1/blind-colour-ciexyz.1.gz
+man/man1/blind-colour-srgb.1.gz
+man/man1/blind-compress.1.gz
+man/man1/blind-concat.1.gz
+man/man1/blind-crop.1.gz
+man/man1/blind-cut.1.gz
+man/man1/blind-decompress.1.gz
+man/man1/blind-dissolve.1.gz
+man/man1/blind-extend.1.gz
+man/man1/blind-flip.1.gz
+man/man1/blind-flop.1.gz
+man/man1/blind-from-image.1.gz
+man/man1/blind-from-text.1.gz
+man/man1/blind-from-video.1.gz
+man/man1/blind-gauss-blur.1.gz
+man/man1/blind-invert-luma.1.gz
+man/man1/blind-next-frame.1.gz
+man/man1/blind-read-head.1.gz
+man/man1/blind-repeat.1.gz
+man/man1/blind-reverse.1.gz
+man/man1/blind-rewrite-head.1.gz
+man/man1/blind-rotate-180.1.gz
+man/man1/blind-rotate-270.1.gz
+man/man1/blind-rotate-90.1.gz
+man/man1/blind-set-alpha.1.gz
+man/man1/blind-set-luma.1.gz
+man/man1/blind-set-saturation.1.gz
+man/man1/blind-single-colour.1.gz
+man/man1/blind-skip-pattern.1.gz
+man/man1/blind-split.1.gz
+man/man1/blind-stack.1.gz
+man/man1/blind-time-blur.1.gz
+man/man1/blind-to-image.1.gz
+man/man1/blind-to-text.1.gz
+man/man1/blind-to-video.1.gz
+man/man1/blind-translate.1.gz
+man/man1/blind-transpose.1.gz
+man/man1/blind-write-head.1.gz
+man/man7/blind.7.gz