aboutsummaryrefslogtreecommitdiff
path: root/multimedia/butt
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-05-10 16:50:49 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-05-10 16:50:49 +0000
commitf8e7eb71885504d33934e36ba183aa86a9127f21 (patch)
tree2bd3fd67213b858add172596543e88be0a8c29be /multimedia/butt
parent23b38616d53909a4e22a8cbcb10e0933b3034c57 (diff)
downloadports-f8e7eb71885504d33934e36ba183aa86a9127f21.tar.gz
ports-f8e7eb71885504d33934e36ba183aa86a9127f21.zip
multimedia/butt: update 0.1.18 -> 0.1.20
- added SSL/TLS support for icecast, among other things Submitted by: Per Gunnarsson <mustafejen@gmail.com> Relnotes: https://danielnoethen.de/butt/Changelog.html
Notes
Notes: svn path=/head/; revision=534856
Diffstat (limited to 'multimedia/butt')
-rw-r--r--multimedia/butt/Makefile5
-rw-r--r--multimedia/butt/distinfo6
-rw-r--r--multimedia/butt/files/patch-configure.ac43
-rw-r--r--multimedia/butt/files/patch-src_Makefile.am4
4 files changed, 33 insertions, 25 deletions
diff --git a/multimedia/butt/Makefile b/multimedia/butt/Makefile
index e2deea101c7a..78fa21961000 100644
--- a/multimedia/butt/Makefile
+++ b/multimedia/butt/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= butt
-PORTVERSION= 0.1.18
-PORTREVISION= 1
+PORTVERSION= 0.1.20
CATEGORIES= multimedia graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -24,7 +23,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libsamplerate.so:audio/libsamplerate \
libvorbis.so:audio/libvorbis
-USES= autoreconf compiler:c++11-lang gmake jpeg pkgconfig xorg
+USES= autoreconf compiler:c++11-lang gmake jpeg pkgconfig xorg ssl uidfix
USE_XORG= x11 xrender xcursor xfixes xext xft xinerama
GNU_CONFIGURE= yes
diff --git a/multimedia/butt/distinfo b/multimedia/butt/distinfo
index 6ad64ca60c4a..54916eb2dc34 100644
--- a/multimedia/butt/distinfo
+++ b/multimedia/butt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1562349284
-SHA256 (butt-0.1.18.tar.gz) = e812b4058a85c7de3733ff85f513e24891afe541eac399cba535b44490c00595
-SIZE (butt-0.1.18.tar.gz) = 968135
+TIMESTAMP = 1589118346
+SHA256 (butt-0.1.20.tar.gz) = e3f75fc2740bd92801d737f1985f5d662922f4c1f4c76eb0be6d75fe9758c70f
+SIZE (butt-0.1.20.tar.gz) = 986757
diff --git a/multimedia/butt/files/patch-configure.ac b/multimedia/butt/files/patch-configure.ac
index 28451307eb62..e8fdbc25cc9b 100644
--- a/multimedia/butt/files/patch-configure.ac
+++ b/multimedia/butt/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2019-05-12 09:03:53 UTC
+--- configure.ac.orig 2020-04-20 14:40:46 UTC
+++ configure.ac
-@@ -61,6 +61,7 @@ AM_CONDITIONAL(WINDOWS, test "$host_os" = "windows")
+@@ -64,6 +64,7 @@ AM_CONDITIONAL(WINDOWS, test "$host_os" = "windows")
build_linux=no
@@ -8,37 +8,44 @@
build_windows=no
build_mac=no
-@@ -75,6 +76,15 @@ case "${host_os}" in
+@@ -88,6 +89,25 @@ case "${host_os}" in
)
])
;;
-+ freebsd*)
++ freebsd*)
+ build_freebsd=yes
+ AC_MSG_NOTICE([FreeBSD detected])
-+ AS_IF([test "x$enable_aac" != "xno"], [
++
++ AS_IF([test "x$enable_aac" != "xno"],
++ [
+ AC_CHECK_LIB([fdk-aac], [aacEncOpen], [],
+ [AC_MSG_ERROR([**** Could not find libfdk-aac ****])]
++ )
++ ])
++ AS_IF([test "x$enable_ssl" != "xno"], [
++ AC_CHECK_LIB([crypto], [EVP_EncryptInit], [],
++ [AC_MSG_ERROR([**** Could not find libcrypto ****])]
++ )
++ AC_CHECK_LIB([ssl], [SSL_CTX_new], [],
++ [AC_MSG_ERROR([**** Could not find libssl ****])]
+ )
+ ])
+ ;;
cygwin*|mingw*|windows)
build_windows=yes
AC_MSG_NOTICE([Windows detected])
-@@ -90,6 +100,7 @@ esac
+@@ -109,6 +129,7 @@ esac
# Pass the conditionals to automake
AM_CONDITIONAL([LINUX], [test "$build_linux" = "yes"])
-+AM_CONDITIONAL([FREEBSD], [test "$build_freebsd" = "yes"])
++AM_CONDITIONAL([FreeBSD], [test "$build_freebsd" = "yes"])
AM_CONDITIONAL([WINDOWS], [test "$build_windows" = "yes"])
AM_CONDITIONAL([OSX], [test "$build_mac" = "yes"])
-@@ -121,6 +132,21 @@ if test "$build_linux" = "yes"; then
- AC_MSG_ERROR([**** Coud not find dbus dev files])
- ])
- fi
-+
-+#Add dbus library for FreeBSD
-+if test "$build_freebsd" = "yes"; then
+@@ -129,6 +150,20 @@ fi
+
+ #Add dbus library for Linux
+ if test "$build_linux" = "yes"; then
+ AC_MSG_NOTICE([])
+ PKG_CHECK_MODULES([DBUS], [dbus-1], [
+ AC_DEFINE([HAVE_DBUS], [1], [Use dbus to get current tracks])
@@ -51,6 +58,8 @@
+ ])
+fi
+
-
- # Checks for header files.
- AC_PATH_X
++#Add dbus library for FreeBSD
++if test "$build_freebsd" = "yes"; then
+ AC_MSG_NOTICE([])
+ PKG_CHECK_MODULES([DBUS], [dbus-1], [
+ AC_DEFINE([HAVE_DBUS], [1], [Use dbus to get current tracks])
diff --git a/multimedia/butt/files/patch-src_Makefile.am b/multimedia/butt/files/patch-src_Makefile.am
index f182ba4b3039..2b50edec4f62 100644
--- a/multimedia/butt/files/patch-src_Makefile.am
+++ b/multimedia/butt/files/patch-src_Makefile.am
@@ -1,10 +1,10 @@
---- src/Makefile.am.orig 2019-04-21 18:20:26 UTC
+--- src/Makefile.am.orig 2020-04-21 11:35:33 UTC
+++ src/Makefile.am
@@ -34,6 +34,10 @@ if LINUX
butt_SOURCES += currentTrack.h currentTrackLinux.cpp
endif
-+if FREEBSD
++if FreeBSD
+butt_SOURCES += currentTrack.h currentTrackLinux.cpp
+endif
+