aboutsummaryrefslogtreecommitdiff
path: root/multimedia/clive/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2008-04-21 22:20:08 +0000
committerNicola Vitale <nivit@FreeBSD.org>2008-04-21 22:20:08 +0000
commit1cce4efbc5d6cff3c3ca7c9efcfc01ec8582adec (patch)
tree54a562552db1870e9e2536153f090cfe840438cd /multimedia/clive/Makefile
parent2f703c4403c4af859b1c1d0f03657ddd6e9f0528 (diff)
Notes
Diffstat (limited to 'multimedia/clive/Makefile')
-rw-r--r--multimedia/clive/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/multimedia/clive/Makefile b/multimedia/clive/Makefile
index 1af66f894770..4652007df948 100644
--- a/multimedia/clive/Makefile
+++ b/multimedia/clive/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clive
-PORTVERSION= 0.4.9
+PORTVERSION= 0.4.10
#PORTREVISION= 0
#PORTEPOCH= 0
CATEGORIES= multimedia
@@ -33,6 +33,7 @@ CONFIGURE_ARGS= --with-doc=no
OPTIONS= FFMPEG "Install ffmpeg for re-encoding" off \
MPLAYER "Install mplayer as video player" off \
+ RSSATOM "Enable extraction videos from RSS/Atom feeds" on \
SQLITE3 "Install sqlite3 for caching visited URLs" off \
VLC "Install vlc as video player" off \
XCLIP "Install xclip (read URLs from clipboard)" off
@@ -60,4 +61,13 @@ RUN_DEPENDS+= vlc:${PORTSDIR}/multimedia/vlc
RUN_DEPENDS+= xclip:${PORTSDIR}/x11/xclip
.endif
+.if defined(WITH_RSSATOM)
+PLIST_SUB+= OPTRSSATOM=""
+LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PYTHON_INCLUDEDIR} $${CPPFLAGS}" LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS} -L${PYTHON_LIBDIR}" SLANG_LIBS="-lncurses -lslang"
+.else
+PLIST_SUB+= OPTRSSATOM="@comment "
+CONFIGURE_ARGS+= --with-newt=no
+.endif
+
.include <bsd.port.post.mk>