aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdauthor
diff options
context:
space:
mode:
authorPierre Beyssac <pb@FreeBSD.org>2010-07-24 16:59:05 +0000
committerPierre Beyssac <pb@FreeBSD.org>2010-07-24 16:59:05 +0000
commit363cc973cbf41e4635869f3c9903d86c8dd95dc9 (patch)
treed3ecf35f94b8b6afb6012bbcd382c8e5e0e9b64e /multimedia/dvdauthor
parentffb1f908b5e02918a1175306eee5af488b945ce0 (diff)
downloadports-363cc973cbf41e4635869f3c9903d86c8dd95dc9.tar.gz
ports-363cc973cbf41e4635869f3c9903d86c8dd95dc9.zip
Update to 0.6.18.
Notes
Notes: svn path=/head/; revision=258166
Diffstat (limited to 'multimedia/dvdauthor')
-rw-r--r--multimedia/dvdauthor/Makefile4
-rw-r--r--multimedia/dvdauthor/distinfo6
-rw-r--r--multimedia/dvdauthor/files/patch-src__dvdunauthor.c44
-rw-r--r--multimedia/dvdauthor/files/patch-src__subreader.c13
4 files changed, 27 insertions, 40 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index eb73b32b8db8..fb3303152eb3 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= dvdauthor
-PORTVERSION= 0.6.14
-PORTREVISION= 7
+PORTVERSION= 0.6.18
+WRKSRC= ${WRKDIR}/dvdauthor
CATEGORIES= multimedia
MASTER_SITES= SF
diff --git a/multimedia/dvdauthor/distinfo b/multimedia/dvdauthor/distinfo
index e12fa5890c95..3d1d1dde40cd 100644
--- a/multimedia/dvdauthor/distinfo
+++ b/multimedia/dvdauthor/distinfo
@@ -1,3 +1,3 @@
-MD5 (dvdauthor-0.6.14.tar.gz) = bd646b47950c4091ffd781d43fd2c5e9
-SHA256 (dvdauthor-0.6.14.tar.gz) = dd1b1512f3ed64938d40541b1f5aff6682898782469992d8caa81e2587a48ef4
-SIZE (dvdauthor-0.6.14.tar.gz) = 319371
+MD5 (dvdauthor-0.6.18.tar.gz) = ded5373800ac6448ff044606f5047550
+SHA256 (dvdauthor-0.6.18.tar.gz) = 0e21c2d9c09f7e347c4c9bd7b691455f524ec2e91bcafc18b84d7b7fb3a9cb26
+SIZE (dvdauthor-0.6.18.tar.gz) = 392809
diff --git a/multimedia/dvdauthor/files/patch-src__dvdunauthor.c b/multimedia/dvdauthor/files/patch-src__dvdunauthor.c
index a7c481d9f3a2..634a109a9ea3 100644
--- a/multimedia/dvdauthor/files/patch-src__dvdunauthor.c
+++ b/multimedia/dvdauthor/files/patch-src__dvdunauthor.c
@@ -1,28 +1,28 @@
---- src/dvdunauthor.c.orig Thu Jun 1 06:03:24 2006
-+++ src/dvdunauthor.c Sat May 5 20:59:53 2007
-@@ -818,6 +818,7 @@
- cell_adr_t *cells;
+--- src/dvdunauthor.c.orig 2010-07-24 18:22:12.113194336 +0200
++++ src/dvdunauthor.c 2010-07-24 18:19:15.409638405 +0200
+@@ -1033,6 +1033,7 @@
+ const cell_adr_t *cells;
int numcells,i,j,totalsect,numsect;
clock_t start,now,clkpsec;
+ struct tms tp;
- cptr=titlef?ifo->vts_c_adt:ifo->menu_c_adt;
- if( cptr ) {
-@@ -836,7 +837,7 @@
- for( i=0; i<numcells; i++ )
+ cptr = titlef ? ifo->vts_c_adt : ifo->menu_c_adt;
+ if (cptr)
+@@ -1054,7 +1055,7 @@
+ for (i = 0; i < numcells; i++)
totalsect += cells[i].last_sector - cells[i].start_sector + 1;
- clkpsec=sysconf(_SC_CLK_TCK);
-- start=times(NULL);
-+ start=times(&tp);
+ clkpsec = sysconf(_SC_CLK_TCK);
+- start = times(NULL);
++ start = times(&tp);
- for( i=0; i<numcells; i++ ) {
- int h,b,plen;
-@@ -874,7 +875,7 @@
- for( b=cells[i].start_sector; b<=cells[i].last_sector; b+=BIGBLOCKSECT ) {
- int rl=cells[i].last_sector+1-b;
- if( rl > BIGBLOCKSECT ) rl = BIGBLOCKSECT;
-- now=times(NULL);
-+ now=times(&tp);
- if( now-start>3*clkpsec && numsect>0 ) {
- int rmn=(totalsect-numsect)*(now-start)/(numsect*clkpsec);
- fprintf(stderr,"STAT: [%d] VOB %d, Cell %d (%d%%, %d:%02d remain)\r",i,cells[i].vob_id,cells[i].cell_id,(numsect*100+totalsect/2)/totalsect,rmn/60,rmn%60);
+ for (i = 0; i < numcells; i++)
+ {
+@@ -1106,7 +1107,7 @@
+ int rl = cells[i].last_sector + 1 - b;
+ if (rl > BIGBLOCKSECT)
+ rl = BIGBLOCKSECT;
+- now = times(NULL);
++ now = times(&tp);
+ if (now-start > 3 * clkpsec && numsect > 0)
+ {
+ const int rmn = (totalsect - numsect) * (now - start) / (numsect * clkpsec);
diff --git a/multimedia/dvdauthor/files/patch-src__subreader.c b/multimedia/dvdauthor/files/patch-src__subreader.c
deleted file mode 100644
index cf88d5a97562..000000000000
--- a/multimedia/dvdauthor/files/patch-src__subreader.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/subreader.c.orig 2006-06-01 06:04:50.000000000 +0200
-+++ src/subreader.c 2009-12-08 14:59:15.649467455 +0100
-@@ -1079,8 +1079,8 @@
- int char_set_num;
- fribidi_boolean log2vis;
- if(flip_hebrew) { // Please fix the indentation someday
-- fribidi_set_mirroring (FRIBIDI_TRUE);
-- fribidi_set_reorder_nsm (FRIBIDI_FALSE);
-+ fribidi_set_mirroring (1);
-+ fribidi_set_reorder_nsm (0);
-
- if( sub_utf8 == 0 ) {
- char_set_num = fribidi_parse_charset (fribidi_charset?fribidi_charset:"ISO8859-8");