aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdauthor
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-10-03 18:24:05 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-10-03 18:24:05 +0000
commit453d243d9753c179dbce3470005ff8fa9e931544 (patch)
tree88b4a9f15387c1177b0c2445357fc6986eb0ea29 /multimedia/dvdauthor
parentd61e63bc3fab49f0f825adb4ff49a5bcd684befb (diff)
downloadports-453d243d9753c179dbce3470005ff8fa9e931544.tar.gz
ports-453d243d9753c179dbce3470005ff8fa9e931544.zip
Notes
Diffstat (limited to 'multimedia/dvdauthor')
-rw-r--r--multimedia/dvdauthor/Makefile101
-rw-r--r--multimedia/dvdauthor/distinfo4
-rw-r--r--multimedia/dvdauthor/files/README.FreeBSD.in (renamed from multimedia/dvdauthor/files/README.FreeBSD)0
-rw-r--r--multimedia/dvdauthor/files/patch-spuunmux.c19
-rw-r--r--multimedia/dvdauthor/pkg-plist10
5 files changed, 65 insertions, 69 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index 53fe3cf5c095..54a44b0af1a1 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -1,69 +1,80 @@
-# New ports collection makefile for: dvdauthor
-# Date created: 20 April 2003
-# Whom: pb@FreeBSD.org
-#
+# Created by: pb@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= dvdauthor
-PORTVERSION= 0.7.0
-PORTREVISION= 3
+PORTVERSION= 0.7.1
CATEGORIES= multimedia
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Makes a DVD file structure from one or more MPEG2 streams
-LIB_DEPENDS= dvdread.4:${PORTSDIR}/multimedia/libdvdread \
- fribidi.3:${PORTSDIR}/converters/fribidi \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
- freetype.9:${PORTSDIR}/print/freetype2
+LICENSE= GPLv2
-USE_BISON= build
-USE_GMAKE= yes
+LIB_DEPENDS= dvdread:${PORTSDIR}/multimedia/libdvdread \
+ fribidi:${PORTSDIR}/converters/fribidi \
+ freetype:${PORTSDIR}/print/freetype2 \
+ png15:${PORTSDIR}/graphics/png \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GNOME= libxml2
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-WRKSRC= ${WRKDIR}/dvdauthor
-MAN1= dvdauthor.1 dvddirdel.1 dvdunauthor.1 mpeg2desc.1 spumux.1 spuunmux.1
+USE_GMAKE= yes
+USE_PKGCONFIG= build
+USE_ICONV= yes
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS ChangeLog README TODO
-.if exists(${LOCALBASE}/lib/libfreetype.so.9)
-WITH_FREETYPE= yes
-.endif
-.if exists(${LOCALBASE}/lib/libiconv.so)
-WITH_ICONV= yes
+DOCSRCDIR2= ${WRKDIR}
+DOC_FILES2= README.FreeBSD
+
+MAN1= dvdauthor.1 dvddirdel.1 dvdunauthor.1 mpeg2desc.1 spumux.1 spuunmux.1
+
+OPTIONS_DEFINE= VIDEO-FORMAT IMAGEMAGICK
+
+OPTIONS_SINGLE= VIDEO-FORMAT
+OPTIONS_SINGLE_VIDEO-FORMAT= NTSC PAL
+
+VIDEO-FORMAT_DESC= Use default video format
+NTSC_DESC= Default video format NTSC
+PAL_DESC= Default video format PAL
+
+SUB_FILES= README.FreeBSD
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNTSC}
+.if ${PORT_OPTIONS:MVIDEO-FORMAT}
+CONFIGURE_ENV+= --enable-default-video-format=NTSC
.endif
-.if exists(${LOCALBASE}/lib/libMagickWand.so.5)
-WITH_IMAGEMAGICK= yes
.endif
-.if defined(WITH_ICONV)
-USE_ICONV= yes
-CFLAGS+= -DICONV_CONV=yes
+.if ${PORT_OPTIONS:MPAL}
+.if ${PORT_OPTIONS:MVIDEO-FORMAT}
+CONFIGURE_ENV+= --enable-default-video-format=PAL
.endif
-.if defined(WITH_IMAGEMAGICK)
-LIB_DEPENDS+= MagickWand.5:${PORTSDIR}/graphics/ImageMagick
-.else
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
.endif
-pre-everything::
-.if !defined(WITH_ICONV)
- @${ECHO_MSG} "You can enable Iconv support by defining WITH_ICONV."
- @${ECHO_MSG}
+.if ${PORT_OPTIONS:MIMAGEMAGICK}
+LIB_DEPENDS+= Magick:${PORTSDIR}/graphics/ImageMagick
.endif
-.if !defined(WITH_IMAGEMAGICK)
- @${ECHO_MSG} "You can enable ImageMagick support by defining WITH_IMAGEMAGICK."
- @${ECHO_MSG}
+
+pre-configure:
+.if !${PORT_OPTIONS:MIMAGEMAGICK}
+ @${REINPLACE_CMD} 's|usemagick=1|usemagick=0|g' \
+ ${WRKSRC}/configure
.endif
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/dvdauthor
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dvdauthor
- ${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${PREFIX}/share/doc/dvdauthor
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/dvdauthor/distinfo b/multimedia/dvdauthor/distinfo
index 2d3e4dffb603..decdeb40928f 100644
--- a/multimedia/dvdauthor/distinfo
+++ b/multimedia/dvdauthor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dvdauthor-0.7.0.tar.gz) = aea6af7b99eba38ffa9dc5ad1521c2cc652e043cea0e7482e239d2a3fc2f34d0
-SIZE (dvdauthor-0.7.0.tar.gz) = 414191
+SHA256 (dvdauthor-0.7.1.tar.gz) = 501fb11b09c6eb9c5a229dcb400bd81e408cc78d34eab6749970685023c51fe9
+SIZE (dvdauthor-0.7.1.tar.gz) = 421324
diff --git a/multimedia/dvdauthor/files/README.FreeBSD b/multimedia/dvdauthor/files/README.FreeBSD.in
index aa1c3115c390..aa1c3115c390 100644
--- a/multimedia/dvdauthor/files/README.FreeBSD
+++ b/multimedia/dvdauthor/files/README.FreeBSD.in
diff --git a/multimedia/dvdauthor/files/patch-spuunmux.c b/multimedia/dvdauthor/files/patch-spuunmux.c
deleted file mode 100644
index 0ef3496b4962..000000000000
--- a/multimedia/dvdauthor/files/patch-spuunmux.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/spuunmux.c.orig 2010-05-10 09:27:55.000000000 +0200
-+++ src/spuunmux.c 2012-04-27 10:44:31.000000000 +0200
-@@ -39,6 +39,7 @@
- #include <netinet/in.h>
-
- #include <png.h>
-+#include <zlib.h>
-
- #include "rgb.h"
- #include "common.h"
-@@ -610,7 +611,7 @@
- png_destroy_write_struct(&png_ptr, (png_infopp)NULL);
- return -1;
- } /*if*/
-- if (setjmp(png_ptr->jmpbuf))
-+ if (setjmp(png_jmpbuf(png_ptr)))
- {
- png_destroy_write_struct(&png_ptr, &info_ptr);
- fclose(fp);
diff --git a/multimedia/dvdauthor/pkg-plist b/multimedia/dvdauthor/pkg-plist
index c63fb7486189..646ed8c09d83 100644
--- a/multimedia/dvdauthor/pkg-plist
+++ b/multimedia/dvdauthor/pkg-plist
@@ -4,9 +4,13 @@ bin/dvdunauthor
bin/mpeg2desc
bin/spumux
bin/spuunmux
-share/dvdauthor/dvdauthor.xsd
-share/dvdauthor/spumux.xsd
-@dirrm share/dvdauthor
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%DATADIR%%/common.xsd
+%%DATADIR%%/dvdauthor.xsd
+%%DATADIR%%/spumux.xsd
+@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%