aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdrip
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-07 17:12:50 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-07 17:12:50 +0000
commit223bc2a99decb80999a475558551d44dd4c3fef6 (patch)
tree3ec1ddcb0d38383dd36909fa9af81762dc53ecaa /multimedia/dvdrip
parentb060d1ce6f9ff533d7a7e876c5a6555b79a7a6f3 (diff)
downloadports-223bc2a99decb80999a475558551d44dd4c3fef6.tar.gz
ports-223bc2a99decb80999a475558551d44dd4c3fef6.zip
multimedia/dvdrip: stage, split out RAR as an option
The archivers/rar port is a FreeBSD BLOB which DragonFly can't use. In fact, only i386 and 32-bit enabled amd64 platforms on FreeBSD can use it. Rather than have dvdrip break by default on all the platforms that don't support RAR, change to an non-default option. While here: * use shebangfix to adjust perl * Don't define RUN_DEPENDS based on BUILD_DEPENDS (bad practice) * Use modern OPTIONS configuration
Notes
Notes: svn path=/head/; revision=361106
Diffstat (limited to 'multimedia/dvdrip')
-rw-r--r--multimedia/dvdrip/Makefile54
-rw-r--r--multimedia/dvdrip/pkg-plist5
2 files changed, 25 insertions, 34 deletions
diff --git a/multimedia/dvdrip/Makefile b/multimedia/dvdrip/Makefile
index 70d047082d2a..9ca905c8e483 100644
--- a/multimedia/dvdrip/Makefile
+++ b/multimedia/dvdrip/Makefile
@@ -3,13 +3,12 @@
PORTNAME= dvdrip
PORTVERSION= 0.98.11
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia
-MASTER_SITES= CPAN \
- http://www.exit1.org/dvdrip/dist/
+MASTER_SITES= CPAN http://www.exit1.org/dvdrip/dist/
MASTER_SITE_SUBDIR= CPAN:JRED
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Perl Gtk+ based dvd-ripper
BUILD_DEPENDS= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
@@ -18,57 +17,44 @@ BUILD_DEPENDS= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
p5-Gtk2-Ex-FormFactory>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2-Ex-FormFactory \
p5-Event-RPC>=0:${PORTSDIR}/devel/p5-Event-RPC \
p5-Locale-libintl>=0:${PORTSDIR}/devel/p5-Locale-libintl
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-RUN_DEPENDS+= cdrdao:${PORTSDIR}/sysutils/cdrdao \
+RUN_DEPENDS= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-Event-ExecFlow>=0:${PORTSDIR}/devel/p5-Event-ExecFlow \
+ p5-Gtk2-Ex-FormFactory>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2-Ex-FormFactory \
+ p5-Event-RPC>=0:${PORTSDIR}/devel/p5-Event-RPC \
+ p5-Locale-libintl>=0:${PORTSDIR}/devel/p5-Locale-libintl \
+ cdrdao:${PORTSDIR}/sysutils/cdrdao \
convert:${PORTSDIR}/graphics/ImageMagick \
mplayer:${PORTSDIR}/multimedia/mplayer \
pstree:${PORTSDIR}/sysutils/pstree \
transcode:${PORTSDIR}/multimedia/transcode \
vcdimager:${PORTSDIR}/multimedia/vcdimager \
- rar:${PORTSDIR}/archivers/rar \
${LOCALBASE}/sbin/fping:${PORTSDIR}/net/fping \
cdrecord:${PORTSDIR}/sysutils/cdrtools
-OPTIONS_DEFINE= VORBIS SUBTITLE
+OPTIONS_DEFINE= VORBIS SUBTITLE RAR
OPTIONS_DEFAULT= VORBIS SUBTITLE
+RAR_DESC= Support RAR-compressed vobsub subtitles
SUBTITLE_DESC= Enable support for getting subtitles
+RAR_RUN_DEPENDS= rar:${PORTSDIR}/archivers/rar
+SUBTITLE_RUN_DEPENDS= subtitle2pgm:${PORTSDIR}/multimedia/subtitleripper
+VORBIS_RUN_DEPENDS= oggenc:${PORTSDIR}/audio/vorbis-tools \
+ ogmmerge:${PORTSDIR}/multimedia/ogmtools
+
CONFIGURE_ENV= SKIP_UNPACK_REQUIRED_MODULES=1
-USES= gettext perl5
+USES= gettext perl5 shebangfix
USE_PERL5= configure patch
-MAKE_JOBS_UNSAFE= yes
+SHEBANG_FILES= bin/dvdrip*
-MAN1= dvdrip.1 dvdrip-progress.1 dvdrip-splitpipe.1
+MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MVORBIS}
-RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools \
- ogmmerge:${PORTSDIR}/multimedia/ogmtools
-.endif
-
-.if ${PORT_OPTIONS:MSUBTITLE}
-RUN_DEPENDS+= subtitle2pgm:${PORTSDIR}/multimedia/subtitleripper
-.endif
-
post-patch:
@${PERL} -pi -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#' \
${WRKSRC}/lib/Video/DVDRip/Cluster/Master.pm \
${WRKSRC}/lib/Video/DVDRip/Depend.pm
- @${PERL} -pi -e 's#/usr/local/bin/perl#${PERL5}#' \
- ${WRKSRC}/bin/dvdrip \
- ${WRKSRC}/bin/dvdrip-exec \
- ${WRKSRC}/bin/dvdrip-master \
- ${WRKSRC}/bin/dvdrip-multitee \
- ${WRKSRC}/bin/dvdrip-replex \
- ${WRKSRC}/bin/dvdrip-splash \
- ${WRKSRC}/bin/dvdrip-subpng \
- ${WRKSRC}/bin/dvdrip-thumb
@${FIND} ${WRKSRC} -name \*.orig -delete
-post-install:
- @cd ${WRKSRC}/blib/man3 && ${FIND} * -name "*.3" | ${SED} \
- 's,^,${MAN3PREFIX:S,^${PREFIX}/,,}/man/man3/,' >> ${TMPPLIST}
-
.include <bsd.port.mk>
diff --git a/multimedia/dvdrip/pkg-plist b/multimedia/dvdrip/pkg-plist
index 70916d6e4b4a..0a1ea525a7ab 100644
--- a/multimedia/dvdrip/pkg-plist
+++ b/multimedia/dvdrip/pkg-plist
@@ -8,6 +8,11 @@ bin/dvdrip-splash
bin/dvdrip-splitpipe
bin/dvdrip-subpng
bin/dvdrip-thumb
+man/man1/dvdrip.1.gz
+man/man1/dvdrip-progress.1.gz
+man/man1/dvdrip-splitpipe.1.gz
+%%PERL5_MAN3%%/Video::DVDRip.3.gz
+%%PERL5_MAN3%%/Video::DVDRip::CPAN::Scanf.3.gz
%%SITE_PERL%%/LocaleData/cs/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/LocaleData/da/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/LocaleData/de/LC_MESSAGES/video.dvdrip.mo