aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdrip
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-26 18:57:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-26 18:57:43 +0000
commit4df51c0623545364fca4d4a41f945eec5000a603 (patch)
treef93eac7d2c3e964b7ff9a93f3b5c9b188b0b298d /multimedia/dvdrip
parentabcb244170768ce0e4924766a5ac799e407706a3 (diff)
downloadports-4df51c0623545364fca4d4a41f945eec5000a603.tar.gz
ports-4df51c0623545364fca4d4a41f945eec5000a603.zip
- Fix hang on startup with perl 5.8.8
PR: ports/94944 Submitted by: Sam Stein <scs@b1tt3r.org>
Notes
Notes: svn path=/head/; revision=158173
Diffstat (limited to 'multimedia/dvdrip')
-rw-r--r--multimedia/dvdrip/Makefile4
-rw-r--r--multimedia/dvdrip/files/patch-FilterList.pm11
2 files changed, 13 insertions, 2 deletions
diff --git a/multimedia/dvdrip/Makefile b/multimedia/dvdrip/Makefile
index dbfef884f04c..6ebb7994dd3f 100644
--- a/multimedia/dvdrip/Makefile
+++ b/multimedia/dvdrip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dvdrip
PORTVERSION= 0.52.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= http://www.exit1.org/dvdrip/dist/
DISTNAME= Video-DVDRip-${PORTVERSION}
@@ -55,7 +55,7 @@ RUN_DEPENDS+= subtitle2pgm:${PORTSDIR}/multimedia/subtitleripper
.endif
.if ${OSVERSION} < 500000
-BROKEN= "Broken dependencies"
+BROKEN= Broken dependencies
.endif
pre-everything::
diff --git a/multimedia/dvdrip/files/patch-FilterList.pm b/multimedia/dvdrip/files/patch-FilterList.pm
new file mode 100644
index 000000000000..aafaa40c338c
--- /dev/null
+++ b/multimedia/dvdrip/files/patch-FilterList.pm
@@ -0,0 +1,11 @@
+--- lib/Video/DVDRip/FilterList.pm.orig Sat Jul 23 03:00:00 2005
++++ lib/Video/DVDRip/FilterList.pm Sat Mar 25 18:09:24 2006
+@@ -211,7 +211,7 @@
+ print STDERR "[filterlist] (re)scanning transcode's module path $modpath...\n";
+
+ my @filter_names = grep !/^(pv|preview)$/,
+- map {m!/filter_([^/]+)\.so$!}
++ map {m!/filter_([^/]+)\.so$/!}
+ glob ("$modpath/filter_*");
+
+ my %filters;