aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdstyler
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-05-03 16:32:27 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-05-03 16:32:27 +0000
commitbdcd5ca4db31ce11543e0b7296c6268780836f65 (patch)
tree5ab8ff7523451e6865c97dc0ddaeb0e0fd45afd4 /multimedia/dvdstyler
parent7b13a7569aa99bbf16b1228865f53d1623de4aa9 (diff)
downloadports-bdcd5ca4db31ce11543e0b7296c6268780836f65.tar.gz
ports-bdcd5ca4db31ce11543e0b7296c6268780836f65.zip
- Update to upstream version 2.9.2
- USE_AUTOTOOLS -> USES - Pet portlint - Add -std=c++11 to CXXFLAGS for gcc (does not build on pre-10.x system without it) PR: 199245 Submitted by: tkato432@yahoo.com Reviewed by: riggs
Notes
Notes: svn path=/head/; revision=385287
Diffstat (limited to 'multimedia/dvdstyler')
-rw-r--r--multimedia/dvdstyler/Makefile20
-rw-r--r--multimedia/dvdstyler/distinfo4
-rw-r--r--multimedia/dvdstyler/files/patch-configure.ac6
-rw-r--r--multimedia/dvdstyler/files/patch-docs-Makefile.in6
-rw-r--r--multimedia/dvdstyler/pkg-plist4
5 files changed, 22 insertions, 18 deletions
diff --git a/multimedia/dvdstyler/Makefile b/multimedia/dvdstyler/Makefile
index d5c55f78a577..7ae945736afc 100644
--- a/multimedia/dvdstyler/Makefile
+++ b/multimedia/dvdstyler/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dvdstyler
-PORTVERSION= 2.8
-PORTREVISION= 3
+PORTVERSION= 2.9.2
PORTEPOCH= 2
CATEGORIES= multimedia
MASTER_SITES= SF
@@ -30,14 +29,14 @@ RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
mkisofs:${PORTSDIR}/sysutils/cdrtools \
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
-USES= gettext gmake pkgconfig tar:bzip2
+USES= autoreconf compiler:c++11-lib gettext gmake pkgconfig tar:bzip2
USE_WX= 3.0
+GNU_CONFIGURE= yes
WX_UNICODE= yes
WX_CONF_ARGS= absolute
-USE_AUTOTOOLS= aclocal automake autoconf
ACLOCAL_ARGS= -I ${WRKSRC}
AUTOMAKE_ARGS= --add-missing --copy --force-missing --foreign
-CONFIGURE_ENV= ac_cv_path_AVCONV_PATH=""
+CONFIGURE_ENV= ac_cv_path_AVCONV_PATH="" OBJCXX="${CXX}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -47,7 +46,7 @@ OPTIONS_DEFINE= DOCS GNOME
GNOME_USE= GNOME=libgnomeui
GNOME_CONFIGURE_WITH= gnome
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if defined(WITH_DVD_DEVICE)
DEFAULT_DVD_DEVICE=${WITH_DVD_DEVICE}
@@ -55,6 +54,10 @@ DEFAULT_DVD_DEVICE=${WITH_DVD_DEVICE}
DEFAULT_DVD_DEVICE=/dev/cd0
.endif
+.if ${CHOSEN_COMPILER_TYPE} == "gcc"
+CXXFLAGS+= -std=c++11
+.endif
+
pre-everything::
.if !defined(WITH_DVD_DEVICE)
@${ECHO_MSG} "===>"
@@ -63,9 +66,6 @@ pre-everything::
@${ECHO_MSG} "===> For example, 'make WITH_DVD_DEVICE=\"/dev/somedevice\"'"
.endif
-post-extract:
- @${ECHO_CMD} -n > ${WRKSRC}/NEWS
-
post-patch:
@${REINPLACE_CMD} -e '/doc_DATA/s|COPYING||' \
${WRKSRC}/Makefile.am
@@ -76,4 +76,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|g' \
${WRKSRC}/src/Config.h
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/dvdstyler/distinfo b/multimedia/dvdstyler/distinfo
index 619669a467a2..950fcf20e64f 100644
--- a/multimedia/dvdstyler/distinfo
+++ b/multimedia/dvdstyler/distinfo
@@ -1,2 +1,2 @@
-SHA256 (DVDStyler-2.8.tar.bz2) = 90fabb6f97f980c0dbc244c658b9b7bf80336e2059eb8e70998bfcc5b8b3bba2
-SIZE (DVDStyler-2.8.tar.bz2) = 6341733
+SHA256 (DVDStyler-2.9.2.tar.bz2) = 88abd17b0dcdfccbdfffe6e80bcfa59df023f1ff2eed782e58d1f793a81dbd1f
+SIZE (DVDStyler-2.9.2.tar.bz2) = 7861116
diff --git a/multimedia/dvdstyler/files/patch-configure.ac b/multimedia/dvdstyler/files/patch-configure.ac
index 92739b0fe246..64358677a295 100644
--- a/multimedia/dvdstyler/files/patch-configure.ac
+++ b/multimedia/dvdstyler/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig
+--- configure.ac.orig 2015-02-17 21:14:03 UTC
+++ configure.ac
-@@ -9,6 +9,7 @@
+@@ -9,6 +9,7 @@ AM_MAINTAINER_MODE
dnl options
AM_OPTIONS_WXCONFIG
AC_ARG_ENABLE(debug, [ --enable-debug Enable debugging information], USE_DEBUG="$enableval", USE_DEBUG="no")
@@ -8,7 +8,7 @@
AC_MSG_CHECKING(for install location)
case "$prefix" in
-@@ -111,7 +112,9 @@
+@@ -112,7 +113,9 @@ if test "x$WXSVGLIBAV" = x"no"; then
fi
dnl check gnomeui-2.0
diff --git a/multimedia/dvdstyler/files/patch-docs-Makefile.in b/multimedia/dvdstyler/files/patch-docs-Makefile.in
index e0c955dbd72c..6f58626e46f3 100644
--- a/multimedia/dvdstyler/files/patch-docs-Makefile.in
+++ b/multimedia/dvdstyler/files/patch-docs-Makefile.in
@@ -1,11 +1,11 @@
---- docs/Makefile.in.orig
+--- docs/Makefile.in.orig 2015-02-17 21:35:57 UTC
+++ docs/Makefile.in
-@@ -461,7 +461,7 @@ uninstall-man: uninstall-man1
+@@ -551,7 +551,7 @@ uninstall-man: uninstall-man1
help_%.zip: DVDStylerGuide_%.xml
t=`mktemp -d tempXXXXXXX`; \
- (cd "$$t" && $(XMLTO) --skip-validation htmlhelp ../DVDStylerGuide_$*.xml && rm -f *.hh* && $(ZIP) ../help_$*.zip *.html); \
+ (cd "$$t" && $(XMLTO) --skip-validation htmlhelp ../DVDStylerGuide_$*.xml && rm -f *.hh* *.proc && $(ZIP) ../help_$*.zip *.html); \
rm -f "$$t"/*.html; \
+ rm -f "$$t"/*.proc; \
if [ -d "images/$*" ]; then \
- $(ZIP) help_$*.zip htmlhelp.hhp toc.hhc images/$*/*.png images/$*/*.jpg; \
diff --git a/multimedia/dvdstyler/pkg-plist b/multimedia/dvdstyler/pkg-plist
index 2730eeef0f33..7cd1b4d380f6 100644
--- a/multimedia/dvdstyler/pkg-plist
+++ b/multimedia/dvdstyler/pkg-plist
@@ -25,6 +25,7 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/backgrounds/40_swans.jpg
%%DATADIR%%/backgrounds/45_nevado.jpg
%%DATADIR%%/backgrounds/46_paisaje.jpg
+%%DATADIR%%/backgrounds/Cake.jpg
%%DATADIR%%/backgrounds/blue_treetops.jpg
%%DATADIR%%/backgrounds/dark_wedding.jpg
%%DATADIR%%/backgrounds/frosty_forest.jpg
@@ -128,6 +129,7 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/rc/add.png
%%DATADIR%%/rc/addVideo.png
%%DATADIR%%/rc/dvdstyler.png
+%%DATADIR%%/rc/error.png
%%DATADIR%%/rc/files.png
%%DATADIR%%/rc/help.png
%%DATADIR%%/rc/justifyCenter.png
@@ -144,9 +146,11 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/rc/new.png
%%DATADIR%%/rc/noaudio.png
%%DATADIR%%/rc/nwse.cur
+%%DATADIR%%/rc/ok.png
%%DATADIR%%/rc/open.png
%%DATADIR%%/rc/plus.png
%%DATADIR%%/rc/preferences.png
+%%DATADIR%%/rc/refresh.png
%%DATADIR%%/rc/remove.png
%%DATADIR%%/rc/rotate.cur
%%DATADIR%%/rc/run.png