aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ffmpeg/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-23 09:35:49 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-23 09:35:49 +0000
commited84ccc48fc5689332508e768b6b8473f451d553 (patch)
treeeed8456f456f5be1b8a415a05c52dab8c7a7c9b9 /multimedia/ffmpeg/Makefile
parentf625ccc2cf5138217f7b309c18955c3b04f3ee56 (diff)
downloadports-ed84ccc48fc5689332508e768b6b8473f451d553.tar.gz
ports-ed84ccc48fc5689332508e768b6b8473f451d553.zip
Notes
Diffstat (limited to 'multimedia/ffmpeg/Makefile')
-rw-r--r--multimedia/ffmpeg/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 786cc24ebafe..6bcf4c779148 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -626,10 +626,13 @@ DOC_FILES= Changelog CREDITS INSTALL.md LICENSE.md MAINTAINERS \
DOC_DOCFILES= APIchanges *.txt
PORTDOCS= *
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-.if ${ARCH} == powerpc64 && ${PORT_OPTIONS:MLTO}
-USE_GCC= yes
+.if ${ARCH} == powerpc64 && ${PORT_OPTIONS:MLTO} && ${CHOSEN_COMPILER_TYPE} == clang
+CPP= ${LOCALBASE}/bin/clang-cpp${LLVM_DEFAULT}
+CC= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}
+BUILD_DEPENDS+= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
+LLD_UNSAFE= yes
.endif
post-install:
@@ -638,4 +641,4 @@ post-install:
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \
"${DOC_DOCFILES}" ${STAGEDIR}${DOCSDIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>