aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ffmpeg2theora
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-06-09 15:29:41 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-06-09 15:29:41 +0000
commit7abf75308009004a4245dfddda72ba44becf134b (patch)
tree932a87ba93d05d4f84683f06edac516f196ed09c /multimedia/ffmpeg2theora
parentb5949efa4554b739efeccb9f13c342d0e09b031b (diff)
downloadports-7abf75308009004a4245dfddda72ba44becf134b.tar.gz
ports-7abf75308009004a4245dfddda72ba44becf134b.zip
multimedia/ffmpeg2theora:
- Update to 0.30 - Remove patch-ffmpeg2 (not needed now that 0.30 uses new FFmpeg API) - Tidy up remaining patches (pet portlint) Changes this release: https://git.xiph.org/?p=ffmpeg2theora.git;a=blob;f=ChangeLog;h=7b2c20e19e4ca6d042d8f2bb3d4491e513d422fa;hb=ff86d204adf335b6314ef568b08d4af8799f108d This new version also allows ffmpeg2theora to build successfully once multimedia/ffmpeg is updated to 3.0.x. Note that multimedia/ffmpeg is currently still on the 2.8.x branch, however this update is backwards compatible with ffmpeg 2.8.x. PR: 209375 Approved by: wg (maintainer timeout), mat (mentor) Differential Revision: https://reviews.freebsd.org/D6784
Notes
Notes: svn path=/head/; revision=416611
Diffstat (limited to 'multimedia/ffmpeg2theora')
-rw-r--r--multimedia/ffmpeg2theora/Makefile3
-rw-r--r--multimedia/ffmpeg2theora/distinfo5
-rw-r--r--multimedia/ffmpeg2theora/files/patch-SConstruct8
-rw-r--r--multimedia/ffmpeg2theora/files/patch-ffmpeg240
-rw-r--r--multimedia/ffmpeg2theora/files/patch-src_ffmpeg2theora.c (renamed from multimedia/ffmpeg2theora/files/patch-src__ffmpeg2theora.c)6
-rw-r--r--multimedia/ffmpeg2theora/files/patch-src_subtitles.c (renamed from multimedia/ffmpeg2theora/files/patch-src-subtitles.c)2
6 files changed, 12 insertions, 52 deletions
diff --git a/multimedia/ffmpeg2theora/Makefile b/multimedia/ffmpeg2theora/Makefile
index 47ebd27add3c..c192c92b4336 100644
--- a/multimedia/ffmpeg2theora/Makefile
+++ b/multimedia/ffmpeg2theora/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ffmpeg2theora
-PORTVERSION= 0.29
-PORTREVISION= 2
+PORTVERSION= 0.30
CATEGORIES= multimedia
MASTER_SITES= http://v2v.cc/~j/ffmpeg2theora/downloads/
diff --git a/multimedia/ffmpeg2theora/distinfo b/multimedia/ffmpeg2theora/distinfo
index 7702a5bf6744..647b78d84f65 100644
--- a/multimedia/ffmpeg2theora/distinfo
+++ b/multimedia/ffmpeg2theora/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ffmpeg2theora-0.29.tar.bz2) = 214110e2a5afdd8ff8e0be18152e893dbff5dabc1ae1d1124e64d9f93eae946d
-SIZE (ffmpeg2theora-0.29.tar.bz2) = 90143
+TIMESTAMP = 1465461122
+SHA256 (ffmpeg2theora-0.30.tar.bz2) = 4f6464b444acab5d778e0a3359d836e0867a3dcec4ad8f1cdcf87cb711ccc6df
+SIZE (ffmpeg2theora-0.30.tar.bz2) = 91269
diff --git a/multimedia/ffmpeg2theora/files/patch-SConstruct b/multimedia/ffmpeg2theora/files/patch-SConstruct
index 0a123240ebf0..38b7c79686de 100644
--- a/multimedia/ffmpeg2theora/files/patch-SConstruct
+++ b/multimedia/ffmpeg2theora/files/patch-SConstruct
@@ -1,6 +1,6 @@
---- SConstruct.orig 2012-06-25 17:15:16 UTC
+--- SConstruct.orig 2016-01-10 04:35:56 UTC
+++ SConstruct
-@@ -37,7 +37,7 @@ opts.AddVariables(
+@@ -38,7 +38,7 @@ opts.AddVariables(
BoolVariable('libkate', 'enable libkate support', 1),
BoolVariable('crossmingw', 'Set to 1 for crosscompile with mingw', 0)
)
@@ -9,7 +9,7 @@
Help(opts.GenerateHelpText(env))
pkg_flags="--cflags --libs"
-@@ -151,7 +151,6 @@ if not env.GetOption('clean'):
+@@ -152,7 +152,6 @@ if not env.GetOption('clean'):
"libavcodec >= 52.30.0",
"libpostproc",
"libswscale",
@@ -17,7 +17,7 @@
"libavutil",
]
if os.path.exists("./ffmpeg"):
-@@ -200,9 +199,8 @@ if not env.GetOption('clean'):
+@@ -214,9 +213,8 @@ if not env.GetOption('clean'):
env.Append(CCFLAGS=[
'-DHAVE_ICONV'
])
diff --git a/multimedia/ffmpeg2theora/files/patch-ffmpeg2 b/multimedia/ffmpeg2theora/files/patch-ffmpeg2
deleted file mode 100644
index ee3e98756d63..000000000000
--- a/multimedia/ffmpeg2theora/files/patch-ffmpeg2
+++ /dev/null
@@ -1,40 +0,0 @@
-commit d3435a6a83dc656379de9e6523ecf8d565da6ca6
-Author: Jan Gerber <j@xiph.org>
-Date: Sun May 26 15:25:42 2013 +0200
-
- don't use deprecated AVCODEC_MAX_AUDIO_FRAME_SIZE
-
-diff --git src/ffmpeg2theora.c.orig src/ffmpeg2theora.c
-index cde63b9..8bebf28 100644
---- src/ffmpeg2theora.c
-+++ src/ffmpeg2theora.c
-@@ -47,6 +47,9 @@
- #include "ffmpeg2theora.h"
- #include "avinfo.h"
-
-+#define MAX_AUDIO_FRAME_SIZE 192000 // 1 second of 48khz 32bit audio
-+
-+
- #define LENGTH(x) (sizeof(x) / sizeof(*x))
-
- enum {
-@@ -1069,8 +1072,8 @@ void ff2theora_output(ff2theora this) {
- int first = 1;
- int audio_eos = 0, video_eos = 0, audio_done = 0, video_done = 0;
- int ret;
-- int16_t *audio_buf=av_malloc(4*AVCODEC_MAX_AUDIO_FRAME_SIZE);
-- int16_t *resampled=av_malloc(4*AVCODEC_MAX_AUDIO_FRAME_SIZE);
-+ int16_t *audio_buf=av_malloc(4*MAX_AUDIO_FRAME_SIZE);
-+ int16_t *resampled=av_malloc(4*MAX_AUDIO_FRAME_SIZE);
- int16_t *audio_p=NULL;
- int no_frames;
- int no_samples;
-@@ -1531,7 +1534,7 @@ void ff2theora_output(ff2theora this) {
- while((audio_eos && !audio_done) || avpkt.size > 0 ) {
- int samples=0;
- int samples_out=0;
-- int data_size = 4*AVCODEC_MAX_AUDIO_FRAME_SIZE;
-+ int data_size = 4*MAX_AUDIO_FRAME_SIZE;
- int bytes_per_sample = av_get_bytes_per_sample(aenc->sample_fmt);
-
- if (avpkt.size > 0) {
diff --git a/multimedia/ffmpeg2theora/files/patch-src__ffmpeg2theora.c b/multimedia/ffmpeg2theora/files/patch-src_ffmpeg2theora.c
index 19981ce19dae..5b210f9b14b7 100644
--- a/multimedia/ffmpeg2theora/files/patch-src__ffmpeg2theora.c
+++ b/multimedia/ffmpeg2theora/files/patch-src_ffmpeg2theora.c
@@ -1,6 +1,6 @@
---- src/ffmpeg2theora.c.orig 2012-01-29 17:00:19.000000000 +0900
-+++ src/ffmpeg2theora.c 2012-07-04 01:49:09.000000000 +0900
-@@ -2970,7 +2970,11 @@
+--- src/ffmpeg2theora.c.orig 2016-01-10 04:35:56 UTC
++++ src/ffmpeg2theora.c
+@@ -3103,7 +3103,11 @@ int main(int argc, char **argv) {
fprintf(stderr,"\nUnable to decode input.\n");
return(1);
}
diff --git a/multimedia/ffmpeg2theora/files/patch-src-subtitles.c b/multimedia/ffmpeg2theora/files/patch-src_subtitles.c
index e00b2e547d7c..490c8670185f 100644
--- a/multimedia/ffmpeg2theora/files/patch-src-subtitles.c
+++ b/multimedia/ffmpeg2theora/files/patch-src_subtitles.c
@@ -1,4 +1,4 @@
---- src/subtitles.c.orig 2011-09-15 20:20:46 UTC
+--- src/subtitles.c.orig 2016-01-10 04:35:56 UTC
+++ src/subtitles.c
@@ -284,7 +284,7 @@ static char *convert_subtitle_to_utf8(co
return NULL;