aboutsummaryrefslogtreecommitdiff
path: root/multimedia/filebot
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-03-16 18:31:51 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-03-16 18:31:51 +0000
commit21e0c9f3e5146627b7b6be0c1aef1019e8388393 (patch)
tree6d6dde4867ec2a90eb3717ad2177b15078e6e8a5 /multimedia/filebot
parent28c528249da853ee166d2d62478f25f93fbdd509 (diff)
downloadports-21e0c9f3e5146627b7b6be0c1aef1019e8388393.tar.gz
ports-21e0c9f3e5146627b7b6be0c1aef1019e8388393.zip
New port: multimedia/filebot: the ultimate tool for organizing and renaming your media
FileBot is the ultimate tool for organizing and renaming your Movies, TV Shows and Anime as well as fetching subtitles and artwork. It's smart and just works. FileBot makes organizing your movies and TV shows a breeze! We'll automatically match your files with information from various online databases. How you want your media files to be named and organized is completely up to you. Our groovy format engine supports pretty much anything! Fetching subtitles is just as easy, just drop it in! Besides automatic lookup you'll also be able to manually search and download subtitles, preview subtitles and fix encoding problems (e.g. force UTF-8). Use FileBot on the command-line! There is a simple CLI for core tasks like renaming media files and fetching subtitles as well as checking or creating SFV files. On top of that you can use our scripting engine to define more complex automated processing. There's already shared scripts for various tasks that you can just run right away or further customize to your needs. Setting up a fully automated media center - extract archives, organize tv shows and movies, download subtitles, fetch artwork and metadata, update Kodi - with FileBot it's that easy! WWW: https://www.filebot.net/ PR: 254226 Submitted by: Dan Kotowski <dan.kotowski AT a9development DOT com>
Notes
Notes: svn path=/head/; revision=568599
Diffstat (limited to 'multimedia/filebot')
-rw-r--r--multimedia/filebot/Makefile41
-rw-r--r--multimedia/filebot/distinfo3
-rw-r--r--multimedia/filebot/pkg-descr23
-rw-r--r--multimedia/filebot/pkg-message13
-rw-r--r--multimedia/filebot/pkg-plist51
5 files changed, 131 insertions, 0 deletions
diff --git a/multimedia/filebot/Makefile b/multimedia/filebot/Makefile
new file mode 100644
index 000000000000..1a3f96882d81
--- /dev/null
+++ b/multimedia/filebot/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= filebot
+DISTVERSION= 4.9.3
+CATEGORIES= multimedia java
+MASTER_SITES= https://get.filebot.net/filebot/FileBot_${DISTVERSION}/
+DISTNAME= FileBot_${DISTVERSION}-portable
+
+MAINTAINER= dan.kotowski@a9development.com
+COMMENT= FileBot is the ultimate tool for organizing and renaming your media
+
+LICENSE= FileBot_EULA
+LICENSE_NAME= FileBot End User License Agreement
+LICENSE_TEXT= Description of the license can be obtained from the following URL: \
+ https://www.filebot.net/eula.html
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+LIB_DEPENDS= libmediainfo.so:multimedia/libmediainfo \
+ libfontconfig.so:x11-fonts/fontconfig
+RUN_DEPENDS= ffprobe:multimedia/ffmpeg \
+ chromaprint>0:audio/chromaprint \
+ jna>0:devel/jna \
+ openjfx14>0:java/openjfx14
+
+USES= tar:xz
+USE_JAVA= yes
+JAVA_VERSION= 11
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+NO_INSTALL= yes
+NO_TEST= yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/${PORTNAME}/jar
+ ${INSTALL_SCRIPT} ${WRKSRC}/filebot.sh ${STAGEDIR}${PREFIX}/share/${PORTNAME}/
+ @cd ${WRKSRC}/jar && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/${PORTNAME}/jar/
+ ${RLN} ${STAGEDIR}${PREFIX}/share/${PORTNAME}/filebot.sh ${STAGEDIR}${PREFIX}/bin/filebot
+
+.include <bsd.port.mk>
diff --git a/multimedia/filebot/distinfo b/multimedia/filebot/distinfo
new file mode 100644
index 000000000000..234331a8fd95
--- /dev/null
+++ b/multimedia/filebot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614693879
+SHA256 (FileBot_4.9.3-portable.tar.xz) = 4fecbc93be7bfea14254e09cfd235cedaf8a9b2b1c3e5a30b9b35063332bf236
+SIZE (FileBot_4.9.3-portable.tar.xz) = 34557528
diff --git a/multimedia/filebot/pkg-descr b/multimedia/filebot/pkg-descr
new file mode 100644
index 000000000000..ccf1a083bb3d
--- /dev/null
+++ b/multimedia/filebot/pkg-descr
@@ -0,0 +1,23 @@
+FileBot is the ultimate tool for organizing and renaming your Movies, TV Shows
+and Anime as well as fetching subtitles and artwork. It's smart and just works.
+
+FileBot makes organizing your movies and TV shows a breeze! We'll automatically
+match your files with information from various online databases. How you want
+your media files to be named and organized is completely up to you. Our groovy
+format engine supports pretty much anything!
+
+Fetching subtitles is just as easy, just drop it in! Besides automatic lookup
+you'll also be able to manually search and download subtitles, preview subtitles
+and fix encoding problems (e.g. force UTF-8).
+
+Use FileBot on the command-line! There is a simple CLI for core tasks like
+renaming media files and fetching subtitles as well as checking or creating SFV
+files. On top of that you can use our scripting engine to define more complex
+automated processing. There's already shared scripts for various tasks that you
+can just run right away or further customize to your needs.
+
+Setting up a fully automated media center - extract archives, organize tv shows
+and movies, download subtitles, fetch artwork and metadata, update Kodi - with
+FileBot it's that easy!
+
+WWW: https://www.filebot.net/
diff --git a/multimedia/filebot/pkg-message b/multimedia/filebot/pkg-message
new file mode 100644
index 000000000000..0a01fc72db2e
--- /dev/null
+++ b/multimedia/filebot/pkg-message
@@ -0,0 +1,13 @@
+[
+{ type: install
+ message: <<EOM
+FileBot relies on OpenJDK 11. You may need to set the following in your profile:
+
+ JAVA_HOME=/usr/local/openjdk11
+
+You may also wish to use an alias, like:
+
+ alias filebot='JAVA_HOME=/usr/local/openjdk11 LD_LIBRARY_PATH=/usr/local/share/java/classes filebot'
+EOM
+}
+]
diff --git a/multimedia/filebot/pkg-plist b/multimedia/filebot/pkg-plist
new file mode 100644
index 000000000000..0c992b392574
--- /dev/null
+++ b/multimedia/filebot/pkg-plist
@@ -0,0 +1,51 @@
+bin/filebot
+share/filebot/filebot.sh
+share/filebot/jar/args4j.jar
+share/filebot/jar/bcpg.jar
+share/filebot/jar/bcpkix.jar
+share/filebot/jar/bcprov.jar
+share/filebot/jar/bencode.jar
+share/filebot/jar/caffeine.jar
+share/filebot/jar/commons-io.jar
+share/filebot/jar/commons-logging.jar
+share/filebot/jar/darcula.jar
+share/filebot/jar/ehcache.jar
+share/filebot/jar/failureaccess.jar
+share/filebot/jar/filebot.jar
+share/filebot/jar/glazedlists.jar
+share/filebot/jar/groovy-datetime.jar
+share/filebot/jar/groovy-dateutil.jar
+share/filebot/jar/groovy-json.jar
+share/filebot/jar/groovy-jsr223.jar
+share/filebot/jar/groovy-nio.jar
+share/filebot/jar/groovy-xml.jar
+share/filebot/jar/groovy.jar
+share/filebot/jar/guava.jar
+share/filebot/jar/icu4j.jar
+share/filebot/jar/imgscalr.jar
+share/filebot/jar/istack-commons-runtime.jar
+share/filebot/jar/ivy.jar
+share/filebot/jar/jakarta.activation.jar
+share/filebot/jar/jakarta.mail.jar
+share/filebot/jar/jakarta.xml.bind-api.jar
+share/filebot/jar/java-objc-bridge.jar
+share/filebot/jar/jaxb-core.jar
+share/filebot/jar/jaxb-runtime.jar
+share/filebot/jar/jna-platform.jar
+share/filebot/jar/jna.jar
+share/filebot/jar/json-io.jar
+share/filebot/jar/jsoup.jar
+share/filebot/jar/language-detector.jar
+share/filebot/jar/lanterna.jar
+share/filebot/jar/metadata-extractor.jar
+share/filebot/jar/miglayout-core.jar
+share/filebot/jar/miglayout-swing.jar
+share/filebot/jar/rsyntaxtextarea.jar
+share/filebot/jar/sevenzipjbinding.jar
+share/filebot/jar/simmetrics-core.jar
+share/filebot/jar/slf4j-api.jar
+share/filebot/jar/slf4j-jdk14.jar
+share/filebot/jar/streamex.jar
+share/filebot/jar/xmlrpc.jar
+share/filebot/jar/xmpcore.jar
+share/filebot/jar/xz.jar